Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: ART Ray Tracer renders weird  (Read 3471 times)

Apophis

  • Newbie
  • *
  • Posts: 8
    • View Profile
ART Ray Tracer renders weird
« on: August 23, 2008, 06:52:37 pm »

The same images are rendering differently with Scanline and ART Ray Tracer. Specifically, objects are being shaded/casting and receiving shadows oddly. ART is giving me an odd, partial shadow. How can I fix the shadows in the ART renders?


I've included some examples. Other than moving the camera, nothing has been changed in any way.  As you can see, only the bottom half of the jewel is casting a shadow.

The settings are as follows:

    Rendering Antialiased
    Light and Camera hidden
    Rendering from View->Camera

    Environment:
            Background: Solid,     Color: 153, 153, 153
            Ground Grid: Off
            Fog: Enabled, Start: 300, End: 1250, Max%: 100, Color: 153, 153, 153
            Shadow Bias: 0.0010
            Clip Planes: Z-Near: 50, Z-Far: 10000

    Light:
            Color: 255,255,255
            Type: spot
            Inner: Radius 500, Angle 30
            Outer: Radius 5000, Angle 40
            Casts Shadows, Percent Dark: 70, Ray Trace

    "Jewel" material:
            Ambient:  0.300     Color: 206, 6, 1
            Diffuse:    0.300     Color: 206, 6, 1
            Specular: 1.000     Color: 126, 12, 9
            Emissive: 0.100     Color: 0, 0, 0
            Rough: 5
            Brilliance: 1
            Transparency: 0.30

    "Wall" material: none/default

    The "Jewel" also has Smooth Angle: 20 (I've since changed it to 10, which has no effect on the shadows but makes it look more like a jewel.)

     



Edit: Here's are two more examples. They're the exact same settings as the two above, except that I turned on the ground grid. As you can see, the shadow is more complete, but there are still strange gaps. Why am I getting these gaps, and why is the ground affecting the shadows?

     
« Last Edit: August 24, 2008, 04:44:03 pm by Apophis »
Logged

Apophis

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: ART Ray Tracer renders weird
« Reply #1 on: August 24, 2008, 05:13:03 pm »

Oddly, moving everything higher on the y-axis changes which and how many sections of the shadow are missing. I don't get it, since the light, camera, and objects are in the same positions relative to one another and the light's cone doesn't intersect with the ground until well past the Wall. Also, the shadow problem doesn't occur with scanline, but I don't want to get it to work with ART so I can try to use the new ART classes for materials.

Edit: Rotating the jewel around the Z-axis in object mode also affects where the gap is in the shadow. Again, I get a complete shadow when using the Scanline renderer.

Also, it only happens when the light and objects are lined up one the same horizontal plane. Tilt the axis that runs through all three, and you get a complete shadow.
« Last Edit: August 24, 2008, 08:01:08 pm by Apophis »
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1523
    • View Profile
Re: ART Ray Tracer renders weird
« Reply #2 on: August 24, 2008, 08:39:38 pm »

Strange.  Can you send me the .an8 file?  This looks like a bug and I'd like to fix it.
Logged

Apophis

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: ART Ray Tracer renders weird
« Reply #3 on: August 25, 2008, 06:47:01 pm »

Okay. I sent you the link.
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1523
    • View Profile
Re: ART Ray Tracer renders weird
« Reply #4 on: August 26, 2008, 05:41:48 am »

#097-016 - Ray traced shadows can have missing faces.

Yeah, it's fixed!  I stumbled on the problem with your example.  That's at least the third time I've tried to find the cause but now I'm pretty sure this is it.  It was definitely a bug (I used the x coordinate for one part of a formula when I should have usedy.)
Logged

Apophis

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: ART Ray Tracer renders weird
« Reply #5 on: August 26, 2008, 06:18:02 pm »

Glad to help. Incidentally, I've noticed the bug numbering system you use, and I was wondering if there is a current list available for viewing. The one on the v0.97 preview is for v0.96 and hasn't been updated in over a year (August 1, 2007).
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1523
    • View Profile
Re: ART Ray Tracer renders weird
« Reply #6 on: August 26, 2008, 09:46:54 pm »

Yeah, I should upload the new list, shouldn't I?  I'll do it tonight when I get home.
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1523
    • View Profile
Re: ART Ray Tracer renders weird
« Reply #7 on: August 28, 2008, 06:23:46 am »

Current bug list has been uploaded:  http://www.anim8or.com/beta/v0.95_bugs.txt
Logged