Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: It wont fill holes!!!!!!!!!!!!!  (Read 2808 times)

Agent513

  • Newbie
  • *
  • Posts: 6
    • View Profile
It wont fill holes!!!!!!!!!!!!!
« on: January 28, 2009, 06:09:51 pm »

I am trying to make a car on Anim8tor and I've come to a point where I have to fill a hole
when I try to I just can't. It won't let me.
I am able to click on the fill holes button but it doesn't do anything.
I have followed all the advice i have gotten but nothing works.
HELP!!!
Logged

RudySchneider

  • Sr. Member
  • ****
  • Posts: 413
  • There are no problems, only opportunities
    • View Profile
Re: It wont fill holes!!!!!!!!!!!!!
« Reply #1 on: January 28, 2009, 06:53:57 pm »

Anim8or --- and any other modeling or CAD program --- has very specific rules about what constitutes valid vertices, edges, and faces.  If "it won't let" you do something, there's probably a good reason.  Either your model's edges don't join vertices in a loop, you've selected too many edges (yes, there's a limit), or you're trying to create a face between two separate meshes.  Without knowing which of these (or other) conditions you're up against, it's difficult to give you a proper corrective action.

Whenever you have a problem, it's always a wise idea to post a screen shot of your model, or post the .an8 project itself.  That way, we can take a look at it, and offer better suggestions.  You can upload your image within a post, or upload it to a free hosting site, like www.imageshack.us, and post a link.

Then, we can start helping you...
Logged
G

rctmonger1108

  • Newbie
  • *
  • Posts: 31
    • View Profile
Re: It wont fill holes!!!!!!!!!!!!!
« Reply #2 on: January 28, 2009, 07:54:46 pm »

Plain and simple, Anim8or won't let you "fill holes" if any of the edges in a would-be face is already part of two faces. Each edge can ONLY be part of TWO faces. Two. Dos.

I had the same problem myself, a while back, when I was working on the short sword tutorial available on CGNation.
Logged
Trying to do too many things at once: game design, programming, 3D modelling & animation, and graphic design.

http://johnsongames.110mb.com
http:///johnsongames.lefora.com

drak

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: It wont fill holes!!!!!!!!!!!!!
« Reply #3 on: January 28, 2009, 09:27:17 pm »

Make sure the "hole" you're trying to fill will make a normal, unbent polygon or triangle.  If the face you're trying to create will not be flat, you can have problems getting it to "fill".  Also, see if the poly you're trying to fill has 4 or less edges.   The less edges the better while using the fill holes tool.  If it has four edges and won't fill, divide it in two so there's 2 triangles instead and try that.  Another thing you could do is make sure there's not 2 points in one spot, go through each point, group select the point,  and use the "merge points" tool on each one.  Other than that, if it's between 2 different objects make sure you use the join solids tool to join them as one.
Logged

floyd86

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1056
    • View Profile
    • http://youtube.com/profile?user=floyd386
Re: It wont fill holes!!!!!!!!!!!!!
« Reply #4 on: January 28, 2009, 10:42:21 pm »

I often have a problem with filling holes, mostly because of my own mistake. Sometimes point look connected but there not. Select the edge/point around the faces with drag select hit shift+L or the merge points commant (edit>merge points) and try again to file holes.
Still this may not apply to your case and you might have made an other mistake.

Water Music

  • Jr. Member
  • **
  • Posts: 86
    • View Profile
Re: It wont fill holes!!!!!!!!!!!!!
« Reply #5 on: January 29, 2009, 02:20:41 am »


With regards to human error, my most common mistake in this regard is to miss an edge that is more or less invisible from the view that I am currently using.  To fix this, zoom around with the perspective camera to make sure you've included all of the little fiddly ones.

Once in a blue moon, however, the program won't fill in a hole with no apparent reason.  Going through the checklist: all edges selected, drag select/merge points at all of the vertices, etc. still nothing.  If this does happen, and I must point out that is rare, there are a couple of quick workarounds:  first, try making an edge across where you want the face to go, fill the faces for each half and then merge the two faces together; and if that doesn't work, cut one of the edges, draw an edge from that new vertex such that you remove one triangle from the face, fill the rest, move your newest vertex over to cover what's left, and merge points.  The second one is rather difficult to explain, but actually easy to do.  I hope that works, I really don't see it often enough to be able to tell what causes it.
Logged