Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: AO Thread  (Read 5555 times)

$imon

  • Sr. Member
  • ****
  • Posts: 540
    • View Profile
AO Thread
« on: March 30, 2009, 12:29:59 pm »

Hey all,

I would like people to share their ideas and experiences with getting Ambient Occlusion effects in Anim8or.

In the attachment you will see a picture of an AO pass i rendered out to use with a Museum scene i made. As you can see some areas look a bit weird, for example:

- The corners of the room are white, where you expect them to be darker (faces closer to each other = less light)
- Some other parts show up as over bright
- The ceiling is way darker than the floor

This last point is very probably because the hole in the ceiling lets the light in the scene.. though I would like to get a more even effect.

The settings i used are:

Everything has the following material:
  Ambient : 1
  Diffuse: 0
  Specular : 0
AmbientOccluder attribute on in Scene editor, no other lights.
There are holes in the ceiling to let the light of the environment in.


Maybe someone has a different way of achieving maybe a more accurate AO pass render?
Or you would like to share something else about it.. go ahead!
Logged

ENSONIQ5

  • Sr. Member
  • ****
  • Posts: 928
    • View Profile
    • Mission Backup Earth
Re: AO Thread
« Reply #1 on: March 30, 2009, 01:12:41 pm »

I have not experienced this before $imon, but my first instinct would be to point the finger at the wall normals being perhaps reversed.  This may also be the case on the bench "feet".  (You no doubt know this already, but if a face selected in Point mode shows yellow the normal is correct, if it shows blue it is flipped, and should be corrected using Edit>Flip Normals.  If some of a wireframes faces are flipped and some are not use the Edit>Fix Normals command).  If this is not the case, what are the Global Illumination settings in Scene mode?  Are you able to replicate this in a simple model that you would be willing to post up, and allow me to fiddle with?
Logged

$imon

  • Sr. Member
  • ****
  • Posts: 540
    • View Profile
Re: AO Thread
« Reply #2 on: March 30, 2009, 02:06:15 pm »

Heh thanks for replying ensoniq5..

Thanks for the perspective, but im afraid the polies arent flipped..

Ill attach a simple .an8 file here if you want to have a look at it, that would be great!
Logged

$imon

  • Sr. Member
  • ****
  • Posts: 540
    • View Profile
Re: AO Thread
« Reply #3 on: March 30, 2009, 02:14:41 pm »

Some Examples of using AO in a scene:



you see the lights used in the top, the materials in the different images on the bottom.

- To make a AO pass to use in post production, the diffuse slot will have to be at 0, to not have other shadows intervene.

- The Ambient Occlusion will not show up if the Ambient slot in a material is 0.

Maybe some nice points to keep in mind when you want to render a scene with AO, and youre working on the materials!
« Last Edit: March 30, 2009, 02:16:41 pm by $imon »
Logged

Raxx

  • Administrator
  • Hero Member
  • *****
  • Posts: 1448
    • View Profile
Re: AO Thread
« Reply #4 on: March 30, 2009, 02:24:39 pm »

Nice example :)

Regarding your first post, I think it's a bug...If you place an object inside another, it'll have that rendering problem...try opening the room behind the camera by deleting a wall or corner
Logged

$imon

  • Sr. Member
  • ****
  • Posts: 540
    • View Profile
Re: AO Thread
« Reply #5 on: March 30, 2009, 02:41:53 pm »

Hey raxx, tnx for replying..

I am thinking its a bug as well, but I was thinking I would ask for a second opinion first ;)

I don't think opening the room up on more sides will get rid of the effect, though it could maybe lessen it by lighting the whole room up a bit more.

Here is that example file i posted rendered out, as you can see more than half the walls are open, and it still has a white edge in the corners..


Logged

Raxx

  • Administrator
  • Hero Member
  • *****
  • Posts: 1448
    • View Profile
Re: AO Thread
« Reply #6 on: March 30, 2009, 03:25:26 pm »

Now try shelling it. The larger the shell, the less light (should be)
Logged

$imon

  • Sr. Member
  • ****
  • Posts: 540
    • View Profile
Re: AO Thread
« Reply #7 on: March 30, 2009, 06:12:43 pm »

Raxx; thanks a lot for that tip ^^ helped me out here..

I wonder how you figured that out haha.. its a bit of a weird bug.. but fortunately fixable.

Heres how it turned out now
Logged

3D Joe Wiltshire

  • Sr. Member
  • ****
  • Posts: 728
  • Winter's Coming :O
    • View Profile
Re: AO Thread
« Reply #8 on: March 30, 2009, 06:57:17 pm »

Well I haven't done much with AO, but here's 2 images i've rendered:

1. AO Pass
2. Normal Pass
Logged

floyd86

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1056
    • View Profile
    • http://youtube.com/profile?user=floyd386
Re: AO Thread
« Reply #9 on: March 30, 2009, 07:04:02 pm »

Yes, i had some problems with this too. Good to see it's fixable.
@3d joe: try a higher AA value when rendering an AO pass (atleast 64 but 256 gives best results vs. time). This will stop the images from being so grainy. Or atleast will remove most of the grain...