Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: Very Old Bugs...  (Read 2416 times)

Pincho

  • Full Member
  • ***
  • Posts: 165
    • View Profile
Very Old Bugs...
« on: July 26, 2009, 02:11:07 am »

I think it's time that some of the really old bugs were sorted out....

1/ Loading a texture with the same name doesn't replace the old texture, you have to delete the texture first.

2/ 3DS models are exported as unwelded, and look messy in other programs.

3/ Selecting faces is a bit dodgy at times.

4/ Moving the mouse near the edge of the screen does not allow an operation to take place.


Plus some handy additions...

Cut a circle... this is my most important feature. Changing anything into a circular extrude would be great. Good for trees especially.

Logged

headwax

  • Sr. Member
  • ****
  • Posts: 600
    • View Profile
    • Headwax's Website
Re: Very Old Bugs...
« Reply #1 on: July 26, 2009, 02:57:54 am »

"Please" and "Thankyou" are also handy additions.
Logged

hihosilver

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1294
    • View Profile
Re: Very Old Bugs...
« Reply #2 on: July 27, 2009, 05:27:12 pm »

Could you explain number 3?  the description "a bit dodgy" doesn't really give much of an idea of the issue.
Logged

Pincho

  • Full Member
  • ***
  • Posts: 165
    • View Profile
Re: Very Old Bugs...
« Reply #3 on: July 27, 2009, 08:42:01 pm »

Could you explain number 3?  the description "a bit dodgy" doesn't really give much of an idea of the issue.

A lot of times you can't select a face no matter what angle you turn your model.
Logged

Pincho

  • Full Member
  • ***
  • Posts: 165
    • View Profile
Re: Very Old Bugs...
« Reply #4 on: July 27, 2009, 08:43:15 pm »

"Please" and "Thankyou" are also handy additions.

Are they? I give tons of games away that I make with Anim8or, I find it helpful for people to tell me of the bugs.

Here's an example of the sort of things that I give away. A demo of my art gallery program...
http://homepage.ntlworld.com/pinchopaxton/V2.rar

Don't think I was ever thanked for it, don't think I expected to be. I thank the people who tell me about bugs.
« Last Edit: July 27, 2009, 08:49:55 pm by Pincho »
Logged

Suppastar

  • Jr. Member
  • **
  • Posts: 65
    • View Profile
Re: Very Old Bugs...
« Reply #5 on: July 27, 2009, 10:00:24 pm »

Could you explain number 3?  the description "a bit dodgy" doesn't really give much of an idea of the issue.

A lot of times you can't select a face no matter what angle you turn your model.

I have also experienced this, it's quite odd. You usually have turn on or off the 'Front' or 'Back' face selection tabs. A lot of times you have to group and then un-group (up to 1-5 times depending on what got corrupted) the model to re-enable face selection. However, these are the fixes for me when this happens, it may not work for all of Anim8ors... well, let's just call them ...quirks.

EDIT: I tired your Demo, it was very nice, little slow moving though. Built with 'Gamemaker' or C+?
« Last Edit: July 27, 2009, 10:05:13 pm by Suppastar »
Logged

Pincho

  • Full Member
  • ***
  • Posts: 165
    • View Profile
Re: Very Old Bugs...
« Reply #6 on: July 28, 2009, 02:48:53 am »

Could you explain number 3?  the description "a bit dodgy" doesn't really give much of an idea of the issue.

A lot of times you can't select a face no matter what angle you turn your model.

I have also experienced this, it's quite odd. You usually have turn on or off the 'Front' or 'Back' face selection tabs. A lot of times you have to group and then un-group (up to 1-5 times depending on what got corrupted) the model to re-enable face selection. However, these are the fixes for me when this happens, it may not work for all of Anim8ors... well, let's just call them ...quirks.

EDIT: I tired your Demo, it was very nice, little slow moving though. Built with 'Gamemaker' or C+?

Dark Basic.

There's a new bug that I don't think was in the old versions as well.

You have the drag a square selector (multiple selection tool), and you also have the pointer selector (single selection tool) OK....

So do this...

Click the top arrow, and the multiple selection tool. Now click Edit Points and faces. Instead of the multiple selection tool being selected, the tool jumps over to single selection.

I tend to have the habit of picking multiple selection first, so I always end up having to click it again. I've used Anim8or since about version 0.1, I'm sure that I have always had this habit, but only recently has the selector been jumping to single selection.

Anyway, this post is not intended to have gripes, it's just a post to say.. lets take a step back to the beginning before moving forwards a bit more.

« Last Edit: July 28, 2009, 02:56:36 am by Pincho »
Logged