Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: Difficulty Extruding along Splines  (Read 1885 times)

RBT

  • Newbie
  • *
  • Posts: 2
    • View Profile
Difficulty Extruding along Splines
« on: August 27, 2009, 09:34:55 am »

Hi,
I'm new to the forum, but I've been using Anim8or on and off for about a year now.   I've hit a hurdle I just can't figure out though, so I'm seeking expert advice here! :)

I'm trying to get the Extrude along a Spline feature to work properly, but its producing some bizarre results for me currently.

What I'm trying to model is a piece of 'pipe' which includes a fair number of smoothly-curved bends in it, going both horizontally, and vertically.

Using the Spline tools I've got my pathway drawn (see attachment #309), with a mixture of straights and curves.   It follows the shape I'm after perfectly.

I then use the Curve Spline tool to make a separate, small, circle which I wish to extrude along that pathway in order to make the pipe.

I highlight the circle, choose Build>Extrude, then set the 'Axis' to 'Path' and click OK.   Once the dialogue closes, I select the pathway and I get the weirdest danged results (see attachment #310)!

Can anyone try to explain to me -- in laymans terms please -- what I'm doing wrong and what I need to pay greater attention to in order to get this feature to work?

Thanks in advance for any assistance!

Ross.
« Last Edit: August 27, 2009, 09:37:43 am by RBT »
Logged

RudySchneider

  • Sr. Member
  • ****
  • Posts: 413
  • There are no problems, only opportunities
    • View Profile
Re: Difficulty Extruding along Splines
« Reply #1 on: August 27, 2009, 11:21:56 am »

To obtain better results, place the object you wish to extrude centered at the beginning (the "tip") of the spline.
Logged
G

RBT

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Difficulty Extruding along Splines
« Reply #2 on: August 27, 2009, 11:17:22 pm »

To obtain better results, place the object you wish to extrude centered at the beginning (the "tip") of the spline.

Thanks Rudy!

That seems to have helped quite a bit.   Roughly the first 2/3rds of the pipe is coming out perfectly now -- right up to the point where the pipe heads vertically downwards.

After there, I'm getting a bit of a "twist" effect at various places along the pipe.   Any ideas what might be causing that?

Ross.

Logged

NickE

  • Full Member
  • ***
  • Posts: 157
    • View Profile
Re: Difficulty Extruding along Splines
« Reply #3 on: August 28, 2009, 02:29:59 am »

You might want to try the script attached.  It creates a tube along a path.  The help is in the header of the script.
Logged

Kubajzz

  • Flying Platypus
  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 548
  • Little doggie ate my avatar...
    • View Profile
Re: Difficulty Extruding along Splines
« Reply #4 on: August 28, 2009, 10:56:18 am »

Here is one thing that might help: the spline that should be extruded (a circle in your case) should be created in the front view.

In other words, extruding along a path is just like extruding along the Z-axis - if you try to extrude your circle along the Z-axis, you'll get a wrong result because you created the circle in the "Left" view. Try rotating the circle 90 along the Y axis and then extrude it along the path, I believe you will get the result you want.
Logged