Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: Texturing a horse model  (Read 4464 times)

Dosser

  • Full Member
  • ***
  • Posts: 104
    • View Profile
Texturing a horse model
« on: February 17, 2008, 08:41:37 am »

G'day all,
first post here in the Anim8or community (well, at least on this board). I keep trying to get into 3d modelling, for about a year now. I keep reading books and tutorials, but can't really think of a full project to do, so lack practise (I like developing games, but haven't really come up with an idea that can be easily implemented in 3d yet). So I decided to make a horse, since that can be used for heaps of projects, and should be simpler than a person, but challenging enough.

I've made a basic model from 3 cylinders (torso, 2 for legs), then realigned the points to follow the reference image. Then I paused before adding a head or tail. I remember some weird stuff when texturing: I may have seen it in tutorials. How would I texture a model which clearly wouldn't fit into the normal UVMapper shapes (cylinder, sphere, box etc.). Should I join the legs to the body now, or wait? Should I mirror the legs now or later? I guess I'm just confused as to what needs to be done next, to make it as simple as possible to finish.

I've attached a pic of the model. The back leg looks weird because I still haven't decided how low poly it should be. It's amazing how much less smooth a hexagonal cylinder is than an octagonal cylinder (front leg) :S
Logged

Frankie

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Texturing a horse model
« Reply #1 on: February 17, 2008, 12:25:12 pm »

just use uv mapper
it will still work

Try using different mappings and find the one that makes the most sence.
Logged

hihosilver

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1294
    • View Profile
Re: Texturing a horse model
« Reply #2 on: February 17, 2008, 08:46:09 pm »

I'd finish the modeling before you move on too the texturing.  What you want to do to texture is use an outside program such as UV mapper or Lithunwrap to unwrap the UV's of the model (google for tutorials on this) and paint the texture yourself.  As for the smoothing of the legs.  You can double click an object and change the 'smooth angle' too a value between 0 and 180.  180 will shade everything as smoothed, 0 will shade all edges as sharp.  Hope that helps a bit ;)
Logged

Dosser

  • Full Member
  • ***
  • Posts: 104
    • View Profile
Re: Texturing a horse model
« Reply #3 on: March 10, 2008, 02:32:07 am »

I finished the modelling and am now up to the texturing. As I predicted, most of the unwrapping options (in UVMapper classic) just look like a mess. Perhaps the best one is planar, which isn't ideal since it would stretch the flatter areas on the head and rump (correct me if i'm wrong). Could someone please have a look and tell me how to unwrap properly?
Logged

hihosilver

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1294
    • View Profile
Re: Texturing a horse model
« Reply #4 on: March 10, 2008, 02:52:42 am »

I'd recommend using lithunwrap instead of UV mapper classic since in lithunwrap you can view the model in realtime as you unwrap it.  For the horse you'll probably want to do the legs as cylindrical maps,  For the tail and body you may want to do the same, but you'll need to stretch them out.  I'd really advise using lithunwrap though.  It's much simpler.
Logged

Dosser

  • Full Member
  • ***
  • Posts: 104
    • View Profile
Re: Texturing a horse model
« Reply #5 on: March 11, 2008, 12:21:56 am »

I think you're right about lithunwrap. It would be trivial to texture if the 'bits' were separate (which is why i was worried earlier about joining the legs to the body), but I can't see any options in UVmapper to split the model.

I've tried downloading Lithunwrap, but keep getting weird javascript errors. will search for a mirror or something later.
Logged

Dosser

  • Full Member
  • ***
  • Posts: 104
    • View Profile
Re: Texturing a horse model
« Reply #6 on: March 15, 2008, 07:11:49 am »

got it: found lithunwrap and found that yes, it is superior to uvmapper. It was simple to split the map into bits, then map each one separately.

It's far from perfect, but I'm sick of this horse anyway. I learnt quite a bit, as it is my first proper model (of something organic, rather than simple metallic weapons / boxes etc.). I know I missed a few faces with the texturing. I'm not sure why there is a 'seam' running through the middle of my model though (I made half of it, then mirrored after applying textures).

Not sure how to upload a textured model, so here's a screenshot. The model seems to be too large anyway :S

Logged

mcheccyb

  • Full Member
  • ***
  • Posts: 173
    • View Profile
Re: Texturing a horse model
« Reply #7 on: March 15, 2008, 04:27:15 pm »

why don't you render a picture instead of just showing us a screenshot.

also, you might want to turn down the spec a bit.
Logged

Dosser

  • Full Member
  • ***
  • Posts: 104
    • View Profile
Re: Texturing a horse model
« Reply #8 on: March 15, 2008, 10:40:53 pm »

never done rendering before. i did turn down the specular (from .2 to .08): I thought it looked good shiny: since horses do often have that shine to them, but realised it basically looked like plastic.

However, my attempts to render failed. I clicked on Render -> Render image, and it mostly worked, except the textures wouldn't show.

Anyway, do you know why that 'seam' is there? the wireframe doesn't show that area as being any pointier than the other curves. I don't know why the texture it darker on one side.
Logged

ENSONIQ5

  • Sr. Member
  • ****
  • Posts: 925
    • View Profile
    • Mission Backup Earth
Re: Texturing a horse model
« Reply #9 on: March 16, 2008, 12:10:26 am »

The "seam" might be due to the normals being reversed on the mirrored side.  Go to wireframe view mode, select Point Edit mode, and select any face.  It should show yellow, not blue.  If any faces are showing blue when selected, select them all and select "flip normals" from the edit menu.  If that's not it, and the model is not actually pointy along the spine, then the only other thing I can think of that could be causing it is the texture itself.  I haven't used Lithunwrap so I am afraid I can't help you there.  Otherwise, I think it is an excellent model and the texture looks really good.  Only criticism would be that the head lacks a truly horsey shape, although I suppose it is a bit like a Shire or draught horse.
Logged

hihosilver

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1294
    • View Profile
Re: Texturing a horse model
« Reply #10 on: March 16, 2008, 01:10:50 am »

The seam would probably be because you didn't join the solids (select both sides then go "Build>Join Solids") then merge the points (select the row of middle points going along the seam then go "Edit>Merge Points")  Then set how far away the points need to be to merge.  You can probably leave it at 0.5, or make it lower.

As for rendering, you can check out my rendering tutorial Here.  It should help you with rendering.  Good start on the texturing though, you're making good progress.

Lastly, if textures don't show when rendering, make sure to go "view>preferences" and check the "textures" box under the "File output" section.
« Last Edit: March 16, 2008, 01:20:55 am by hihosilver »
Logged