Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: Trouble getting Anim8or to run in Windows 7  (Read 7124 times)

Kyle

  • Full Member
  • ***
  • Posts: 184
    • View Profile
Trouble getting Anim8or to run in Windows 7
« on: December 25, 2009, 09:38:19 pm »

I mentioned this in the preview forum, but since this isn't about the beta it might as well go here.

I just got a new  Dual core hp laptop with windows 7, and I'm pretty unfamiliar with it, up till now Ive only used XP.

After a few hours of trying to research it i'm still not having much luck. I feel like such a noob, I cant even figure out the exact graphics card I have. but it has to a problem with open GL. I could probably update if I knew which version to download.

Any suggestions? I tried running as administrator but no luck.
Logged

Yit

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Trouble getting Anim8or to run in Windows 7
« Reply #1 on: December 25, 2009, 09:47:12 pm »

First place to start when looking for your graphics chipset is to look at Device Manager. They kinda buried it in Win7 but you can search for it on the start bar. There should be a "Display Adapters" listing. Thats where you'll find the options to update and such.  Since its Win7, there may not be an "updated" driver that includes OpenGL, and laptops seems to be the culprit when someone can't run Anim8or. Sorry if you knew any of that but there's not much else to do. Good luck.
Logged

LordDeRock

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Trouble getting Anim8or to run in Windows 7
« Reply #2 on: December 25, 2009, 09:54:47 pm »

Ok, I just fixed this problem on my computer because i upgraded from vista to 7 today and it may not be possible for you to do what i did but first you need to find out what your graphic card is.

1. Press the start button and search "Device Manager" in the search bar.
2. When in the Device Manager click on "Display Adapters" and you should see your chip set.

Tell me what it is and I'll see if I can help.
Logged

Kyle

  • Full Member
  • ***
  • Posts: 184
    • View Profile
Re: Trouble getting Anim8or to run in Windows 7
« Reply #3 on: December 25, 2009, 10:06:28 pm »

Mobile Intel 4 Express Chipset family? I guess thats it...
Logged

LordDeRock

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Trouble getting Anim8or to run in Windows 7
« Reply #4 on: December 25, 2009, 10:13:03 pm »

Good same here, ok this is important did you update you system and drivers using windows system update?
Logged

Kyle

  • Full Member
  • ***
  • Posts: 184
    • View Profile
Re: Trouble getting Anim8or to run in Windows 7
« Reply #5 on: December 25, 2009, 10:26:38 pm »

As far as I know I updated as much as I could, yes.

Edit: ok everything but the e explorer update, but there's no way thats related...
« Last Edit: December 25, 2009, 10:43:10 pm by Kyle »
Logged

LordDeRock

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Trouble getting Anim8or to run in Windows 7
« Reply #6 on: December 25, 2009, 10:44:31 pm »

Ok bad choice, logical yes but still bad. You need to run system restore and go back to what you had. The problem is that (as far as I know) Intel no longer supports Open GL in there new drivers so you need to undo the the update and once you have go into the update window and tell the computer to update everything but the Intel stuff. my driver version is 8.15.10.1749 (find this by going into device manager, display adapters, left click on the chip set, go to properties, and driver tab) this is the lastest driver version to work so if you restore the system and it is higher then this there is nothing you can do about it. Sorry i could be more help if it doesn't work and if it does work... your welcome. Good Luck.
Logged

Kyle

  • Full Member
  • ***
  • Posts: 184
    • View Profile
Re: Trouble getting Anim8or to run in Windows 7
« Reply #7 on: December 26, 2009, 12:49:38 am »

Alright, I'll try that when I get a chance, I actually found an update on the ati site using their auto detection thing, so I'll see is that does anything first, though I don't expect it to.

Edit: well that didnt work, as I thought. but it also looks like I dont have a restore point to go back to, I didnt set one up...

I wonder if the  8.15.10.1749 driver can be found somewhere to download...

maybe it would be possible for you to upload your own driver?

*Sigh* really starting to regret going with Intel. I assumed any pc on the market, pc or laptop would be able to run things my desktop (which is nearly 10 years old at this point) could just as well if not better, and from the looks of it Open GL doesn't run well on Intels at all. Even if I get that driver it sounds like I'm not going to be able to use it without crashing on occasion.

Edit: ok, I did a restore and the driver is still too recent  (8.15.10.1808) . Im not sure if it even changed or not, as I didnt check which driver it was before the restore. none the less still no Open gl. :(
« Last Edit: December 26, 2009, 09:44:27 am by Kyle »
Logged

Yit

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Trouble getting Anim8or to run in Windows 7
« Reply #8 on: December 27, 2009, 12:40:18 am »

You can try to search for a Win7 OpenGL driver for your chipset. A thrid party may have hacked one for you O.o
Logged

Kyle

  • Full Member
  • ***
  • Posts: 184
    • View Profile
Re: Trouble getting Anim8or to run in Windows 7
« Reply #9 on: January 11, 2010, 10:06:57 pm »

Okay, I just downloaded this opengl demo.
http://www.softpedia.com/progDownload/OpenGL-demo-Download-32457.html

And it works. So why wouldn't anim8or run too?  this officially cant be an opengl probelm now can it?  Steve, if your reading I'd love to get some input.
Logged

Yit

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Trouble getting Anim8or to run in Windows 7
« Reply #10 on: January 13, 2010, 01:26:55 am »

I saw on another thread that there's a program to convert openGl to direct x. search for something like that and see if that works.
Logged

Raxx

  • Administrator
  • Hero Member
  • *****
  • Posts: 1446
    • View Profile
Re: Trouble getting Anim8or to run in Windows 7
« Reply #11 on: January 13, 2010, 02:48:51 am »

Quote
If anyone else has issues with Windows 7 and Intel chipsets:

The trick is that the drivers Windows Update installs don't usually include OpenGL. What I did was download the Windows Vista installer from Intel.com (since Vista and 7 don't really have any humongous fundamental differences that I know of), and run it in compatibility for Windows Vista. This tricked the installer into installing, and OpenGL is now up and running.

I don't have this problem, but if Windows 7 drivers don't come with opengl then it makes sense to download and install the vista drivers instead. You could try the directions above and see if it works.
Logged

Kyle

  • Full Member
  • ***
  • Posts: 184
    • View Profile
Re: Trouble getting Anim8or to run in Windows 7
« Reply #12 on: January 13, 2010, 03:50:23 am »

Hmm, would you be able to give me more info on which one I should try? there are so many drivers/installers on the site that I cant seem to narrow it down.
Logged