Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: need some help  (Read 2974 times)

blazecon0

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
need some help
« on: February 19, 2010, 03:38:25 am »

ok, this is my leaf as it should be

this is what i get in my UV mapper, lithunwrap

and in 3d view


why don't my faces not show up in lithunwrap? iv tried exporting it as a wavefront and a 3Ds
any suggestions?
if more info is needed tell me
Logged

Raxx

  • Administrator
  • Hero Member
  • *****
  • Posts: 1446
    • View Profile
Re: need some help
« Reply #1 on: February 19, 2010, 03:51:35 am »

Do you mean shaded versus wireframe, or are you expecting the subdivided result? Subdivision objects export as their cage mesh counterparts, so if the leaf is a subdivision object and you want to uvmap the subdivided version, you'll have to convert the subdivision object to mesh first before exporting. Of course this means you won't be able to convert back to the cage mesh once you unwrap and import it back into anim8or again. I did go over a way to preserve the cage mesh for a subdivision object in this topic if you want to read through it: http://www.anim8or.com/smf/index.php?topic=1729.msg13139#msg13139

I haven't used lithunwrap much if at all, I expect you can change to shaded view by looking in your options though. If you meant that in the uvmap you can't see the side faces...that's because it's unwrapping using planar unwrapping and it's basically just like looking down on it from the top. You'd have to manually select expand the side faces out to the side within the uvmap or use a different unwrapping method than just planar.
Logged

blazecon0

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: need some help
« Reply #2 on: February 19, 2010, 03:57:04 am »

how do you turn the subdivided model back into its low poly form again?
Logged

Raxx

  • Administrator
  • Hero Member
  • *****
  • Posts: 1446
    • View Profile
Re: need some help
« Reply #3 on: February 19, 2010, 04:08:58 am »

Is it a subdivision object or did you convert the subdivision object to mesh? If you converted it to mesh after turning it into a subdivision then there's no way to get it back. If it's a subdivision object (Build->Convert to subdivided...) then you double click the subdivision object, give it working divisions of 0, and then convert it to mesh. If you subdivided the faces (Build->Subdivide faces...), then you can't get it back either.

There is an unsubdivision script located in the ASL Scripts Database you could try out if you can't get it back. No guarantees that it'll give you exactly the same result as the original unsubdivided object, but it's worth a try.
Logged

blazecon0

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: need some help
« Reply #4 on: February 19, 2010, 04:14:12 am »

no what i mean is that my model is flat out missing most of its top and bottom faces

see?  i cant do anything with it. it still there in anim8or but not in lithunwrap
Logged

Raxx

  • Administrator
  • Hero Member
  • *****
  • Posts: 1446
    • View Profile
Re: need some help
« Reply #5 on: February 19, 2010, 04:24:03 am »

Ah, I see. Have you tried exporting as .obj and reimporting that .obj into anim8or to make sure it's exporting everything correctly? Also, some programs separate the parts by material, make sure the entire leaf is one material before you export out of Anim8or.

If it's lithunwrap then it looks like it doesn't seem very compatible with the file (or your mesh). You could try it in uvmapper classic or another program to see if you get the same results, and if it looks fine then export it from that program and import into lithunwrap and see if it helps.

If anything, attach your .an8 file so I can look at it in case it's a mesh error.
Logged

blazecon0

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: need some help
« Reply #6 on: February 19, 2010, 04:30:22 am »

well i cant attach that atm cus i got kiked from my pc and am now using my dsi. now that you mentioned that tho, i did try to reload one of my exports and a part close to the base of the stem was gone, but not the surface of the leaf. thx btw for helpin me
Logged

blazecon0

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: need some help
« Reply #7 on: February 19, 2010, 04:48:36 am »

well this is interesting, im usin another computer (w/o internet T_T) but when i inported the object i tried to use in lithunwrap, it had yent back to its undivided form!! its not a perfect original,cus its missin parts, but its very close otherwise.
Logged

blazecon0

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: need some help
« Reply #8 on: February 19, 2010, 05:01:36 am »

fixed it, i never turned the subdivided version into a mesh XD
holy #$%& this thing has almost 2000 polys!!!
Logged

blazecon0

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: need some help
« Reply #9 on: February 19, 2010, 05:06:31 am »

lol lithunwrap wants to triangulate it, my computers goin to have a heart attack XD
Logged