Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: weird error  (Read 1729 times)

blazecon0

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
weird error
« on: November 21, 2010, 04:47:20 am »

one of my projects has some kind of error that occurs everytime i open i and i wanted to see if anyone can fix it.
i think it occurred while i was in a a fit of rage trying to make bones move the way i wanted to, i dont rly know -.-
anyway, i did something and now my model has errors every time i open it. just open it and you will see, and if you can please tell me what i did

i know im not the most organized person, thus my files are highly unorganized as well, so i rly appreciate yall trying to sort through this mess ^^
« Last Edit: November 24, 2010, 09:39:29 pm by blazecon0 »
Logged

Gyperboloid

  • Full Member
  • ***
  • Posts: 233
  • It's better not to do anything, than to do nothing
    • View Profile
Re: weird error
« Reply #1 on: November 21, 2010, 12:58:26 pm »

The project ( file ) by itself  has not any problem. If you mean the errors that pops up when you start the project, it's the textures which probably you moved somewhere else. You just have to "show" to Anim8or where they are. Go again to materials and select the textures again.
Logged

blazecon0

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: weird error
« Reply #2 on: November 21, 2010, 06:34:53 pm »

i know what a texture error looks like, i was refering to this
Logged

ENSONIQ5

  • Sr. Member
  • ****
  • Posts: 925
    • View Profile
    • Mission Backup Earth
Re: weird error
« Reply #3 on: November 22, 2010, 07:20:10 am »

The error report is actually telling you what the problem is and where to find it.  Open the file, go to Scene mode, open scene04, in the timeline find efigure01 and check the properties for joint.bone23-X.  The controller script in there is incorrect, in that it assigns a value to a variable without first declaring it, which is an illegal operation as you must first declare the variable type (eg. Floating point).  Check the Script documentation for variable types.  You will notice if you save the controller script without changing it you get a 'parse error' message, which indicates something is wrong with the script's syntax.  If you see this message and choose to ignore it Anim8or will still warn you of the issue on opening the file.
Logged

blazecon0

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: weird error
« Reply #4 on: November 24, 2010, 09:39:45 pm »

i see, thanks
Logged