Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Pages: 1 ... 5 6 [7] 8 9 ... 46

Author Topic: Changed to Older Releases [builds 1162 to 1230]  (Read 126517 times)

Kyle

  • Full Member
  • ***
  • Posts: 184
    • View Profile
Re: Current Development Release - Build 1112, October 1, 2014
« Reply #90 on: October 04, 2014, 10:24:19 pm »

Kyle: Any polygonal representation of a sphere will be an approximation because polygons simply don't have spherical surfaces.

 I get that, but in the thread there are several spheres linked to (in the form of plug ins for anim8or) taken from other programs that are much closer to perfectly round (as in same height and width) than what anim8or currently can provide on its own.  Yet they can't completely replace the built in primitive as the divisions are non editable.  I was hoping this could be addressed at some point as It seems like an oversight to me.  Keep in mind I'm not referring to the surface, just matching height and widths.
« Last Edit: October 04, 2014, 10:26:00 pm by Kyle »
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1523
    • View Profile
Re: Current Development Release - Build 1112, October 1, 2014
« Reply #91 on: October 04, 2014, 11:56:33 pm »

Hmmm. This looks like a driver bug.  What graphics chip do you have?
« Last Edit: October 05, 2014, 05:05:05 pm by Steve »
Logged

Water Music

  • Jr. Member
  • **
  • Posts: 86
    • View Profile
Re: Current Development Release - Build 1112, October 1, 2014
« Reply #92 on: October 05, 2014, 12:33:30 am »

I'm a pretty weak programmer, and of course haven't seen Anim8or's source code, but there are a few extra brains here at your disposal if you want any help if you want any help with the IK logic.  Just let us know what you need.
Logged

MvGulik

  • Full Member
  • ***
  • Posts: 107
  • [... Lost in Space ...]
    • View Profile
Re: Current Development Release - Build 1112, October 1, 2014
« Reply #93 on: October 05, 2014, 03:28:16 am »

MvGulik: I think there is a bug in your graphics driver that's preventing the text from showing. I can't reproduce the problem. What graphics card do you have? (See the About->SystemInfo dialog.)
Bummer. Although I figured this video card would eventually crap out. :(
- System restart, just in case: nope, no change.
- Other/better computer, not mine: yep, showing text as intended.

Code: [Select]
OpenGL Vendor:   Intel
OpenGL Renderer: Intel 915G
OpenGL Version:  1.4.0 - Build 7.14.10.4764
OS Version:      Windows XP Service Pack 3  (5.1)  Build 2600
+ O yea. Using the drivers direct from Nvidia(must be Intel). Instead of the older HP/Compact video drivers for this system (those where giving problems with a other program/game)



MvGulik: #098-025 - Effect Modifier sets wrong level.
I'll set the final layer to the same as the Bound-Mesh (layer.l) since this is just an editing operation on that mesh. Does that sound OK?
I did gave it some thoughts when reporting, but found it a tricky one. Initially I was leaning towards inheriting the modifier layer. But that's strongly influenced by how I in general used to use them (more long turn modifier use). Other users will use them differently.
So, at this point I think just using the bound-mesh layer seems fine to.

*spelling*
« Last Edit: October 05, 2014, 04:33:30 am by MvGulik »
Logged

captaindrewi

  • Sr. Member
  • ****
  • Posts: 450
  • errm...errr?
    • View Profile
Re: Current Development Release - Build 1112, October 1, 2014
« Reply #94 on: October 06, 2014, 12:33:05 am »

This seems odd i was just doodling but found i couldn't interact with these models
moving vertices or extrude faces. though could initially. :o 1112build
« Last Edit: October 06, 2014, 12:34:07 am by captaindrewi »
Logged
!

ClassicTyler

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
Re: Current Development Release - Build 1112, October 1, 2014
« Reply #95 on: October 06, 2014, 01:15:36 am »

Steve, I have a weird question and request.

So when working with 2D items for like trees and stuff, there's the blue side and yellow side.
In lighted environments, the yellow side reflects the settings you have in the work field. The blue doesn't. I know it's there for a reason, but I'm using a lot of extra polygons just to cover the blue so everything is evenly lighted.

Is there something that can be done to have both sides lighted evenly? Or is that the industry standard?
Logged

MvGulik

  • Full Member
  • ***
  • Posts: 107
  • [... Lost in Space ...]
    • View Profile
Re: Current Development Release - Build 1112, October 1, 2014
« Reply #96 on: October 06, 2014, 05:32:30 am »

This seems odd i was just doodling but found i couldn't interact with these models
moving vertices or extrude faces. though could initially. :o 1112build
See:
#098-024 - Point Edit Mode: Subdivision Meshes control points are not editable.
Logged

Claude

  • Full Member
  • ***
  • Posts: 244
    • View Profile
Re: Current Development Release - Build 1112, October 1, 2014
« Reply #97 on: October 06, 2014, 06:22:25 am »

ClassicTyler

Have you tried selecting  two sided in the material editor ?
Logged

MvGulik

  • Full Member
  • ***
  • Posts: 107
  • [... Lost in Space ...]
    • View Profile
Re: Current Development Release - Build 1112, October 1, 2014
« Reply #98 on: October 06, 2014, 04:36:39 pm »

Seems the text-display inside the work views got eaten in 1112.
It took a while for this coin to drop at this side. But, just in case.
Although my video is not showing the [Front, Back, etc] & Axis text in the workview. ... It is showing the Rules(Grid/Show Scale) values(assuming similar text rendering).

*language*
« Last Edit: October 06, 2014, 10:09:26 pm by MvGulik »
Logged

ClassicTyler

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
Re: Current Development Release - Build 1112, October 1, 2014
« Reply #99 on: October 06, 2014, 07:41:24 pm »

ClassicTyler

Have you tried selecting  two sided in the material editor ?
...


...I didn't even think to try that.
I've been using this program for almost 7 years LOL
I'm so sorry I can be a hassle to you guys. A lot of this is self-taught. I've only recently started posting on the forum. I'll play around with this some.

EDIT: Well, it works. Maybe I should ask things more often instead of putting off projects.  :'(
« Last Edit: October 06, 2014, 07:45:08 pm by ClassicTyler »
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1523
    • View Profile
Re: Current Development Release - Build 1112, October 1, 2014
« Reply #100 on: October 06, 2014, 08:45:32 pm »

ClassicTyler: Default OpenGL uses the normal of a triangle when lighting. If the normal is pointed away from the light it the diffuse and specular components are set to 0. So the backside of triangles only show the ambient component. Two sided lighting uses the negative of the normal (plus a potentially different color) for the backs of triangles.

The yellow and blue sides shown for selected faces in Point Edit mode are to make it easier to see what's happening. Sometimes a face can have it's normal reversed and this helps find such cases.
Logged

ClassicTyler

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
Re: Current Development Release - Build 1112, October 1, 2014
« Reply #101 on: October 06, 2014, 09:03:40 pm »

Steve,
I'm not at all smart. Thank you for making Anim8or accessible even for people like me and for people who DO know what they're doing. ;)
I'm learning new stuff daily, thanks to the forums. I should have joined a long time ago! I feel like I can finally start getting more stuff done on the projects. Keep up the great work!

Also, once you get to the celshading/bloom lighting updates, let me know. I'll be happy to test things for you!
My environments will be standard with the lighting, and the characters will have celshading.
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1523
    • View Profile
Re: Current Development Release - Build 1113, October 6, 2014
« Reply #102 on: October 06, 2014, 09:50:52 pm »

These should be working in 1113 :)

MvGulik, kreator and many others: #098-024 - Point Edit Mode: Subdivision Meshes control points are not editable.
MvGulik: #098-025 - Effect Modifier sets wrong level.
Logged

MvGulik

  • Full Member
  • ***
  • Posts: 107
  • [... Lost in Space ...]
    • View Profile
Re: Current Development Release - Build 1113, October 6, 2014
« Reply #103 on: October 06, 2014, 10:25:10 pm »

Thanks. :)

O dear. One little (v1113) modifier problem though. When trying to create a new/empty modifier, its not showing in the workview (The yellow outline. The element itself seems to be created thou, shows in element list).
(Checked on two computers.)

(work-around: Modifier becomes visible when its bound to something/mesh.)

*stuff*
« Last Edit: October 06, 2014, 10:46:06 pm by MvGulik »
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1523
    • View Profile
Re: Current Development Release - Build 1113, October 6, 2014
« Reply #104 on: October 06, 2014, 10:46:26 pm »

Rats!  I rushed 1113 to fix the Subdivision point-edit bug and guess I didn't do enough testing :(  I'll post a quick update of just this fix soon...
Logged
Pages: 1 ... 5 6 [7] 8 9 ... 46