Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Pages: 1 ... 17 18 [19] 20 21 ... 46

Author Topic: Changed to Older Releases [builds 1162 to 1230]  (Read 126199 times)

kreator

  • Hero Member
  • *****
  • Posts: 1113
  • Anim8or, Blender, & Carrara. A Great Combination!
    • View Profile
    • Anim8orWorld
Re: Current Development Release - Build 1152, January 15, 2015
« Reply #270 on: January 24, 2015, 08:19:26 am »

Build 1152, Ommission.

Unfortunately for me now, any Scenes I save , do not reference the textures in the file. I have to keep re-entering them when I return from a session to continue, Is this happening for others?
Logged
O

johnar

  • Sr. Member
  • ****
  • Posts: 812
  • Make it, Move it--Give it Life
    • View Profile
    • youtube vids
Re: Current Development Release - Build 1152, January 15, 2015
« Reply #271 on: January 24, 2015, 08:44:34 pm »

No problem with that here.
 I have come across similar, but in figure, and sometimes sequence mode. Noticed figures would lose textures, and i would go back to object mode and quickly 'ok' the textures, which were still listed, just not showing/applied.
 It turned out that this happened after importing objects/figures which shared the same texture. (or was it importing the same object with different textures). hmmm....not 100% sure there...hasn't happened for some time, can't reproduce at will, but will take more notice if/when it happens again.
 Possibly your problem could be something to do with Scenes/sequences/figures/object import??
 I know this isn't any kind of solution, but , just maybe, it could be related?
 Sorry can't be of much help. as i said, no problems with textures in Scene mode here...
Logged
%

TheBlackHole

  • Jr. Member
  • **
  • Posts: 97
    • View Profile
Re: Current Development Release - Build 1152, January 15, 2015
« Reply #272 on: January 25, 2015, 05:25:32 am »

Is spherical UV mapping still possible? There doesn't seem to be an option for it anymore.
Logged

captaindrewi

  • Sr. Member
  • ****
  • Posts: 450
  • errm...errr?
    • View Profile
Re: Current Development Release - Build 1152, January 15, 2015
« Reply #273 on: January 25, 2015, 11:46:07 am »

yes, select object-click UV button,when yellow grid appears double click on area,then dialog box/choices appear.
Logged
!

davdud101

  • Sr. Member
  • ****
  • Posts: 949
  • Couldn't ever use Blender or Maya. Anim8or's good.
    • View Profile
Re: Current Development Release - Build 1152, January 15, 2015
« Reply #274 on: January 27, 2015, 08:55:03 pm »

Loving Build 1152! The orange bounding boxes are somehow more elegant and modern to me. These feature are sweet! (sorry guys, I just found the link to where the new builds are)
Logged
?

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1523
    • View Profile
Re: Current Development Release - Build 1159, January 29, 2015
« Reply #275 on: January 29, 2015, 10:20:22 pm »

Build 1159 is out with some really useful changes:

Arc-Rotate: Middle mouse button dollies without changing the point of interest for Perspective, Camera and Spotlight views; Zooms the Field Of View if the <Ctrl> key is pressed. Mouse Wheel behaves similarly.

'F' hot-key (Frame Selected) centers on selected Points/Faces/Edges in the Point Editor.
Logged

Raxx

  • Administrator
  • Hero Member
  • *****
  • Posts: 1446
    • View Profile
Re: Current Development Release - Build 1159, January 29, 2015
« Reply #276 on: January 30, 2015, 04:01:46 am »

Looks good, works good. Any chance when Frame Selected is used on a single point, it moves the POI to that point's coordinates, without zooming?

I can't figure out how to use the flatten mesh and intersect edges tools. They don't seem to do anything, and I'm not even sure what intersect edges is supposed to do.

Any plans to enable extruding a mesh along a path?

The Viewport labels in the opengl workspaces look different (larger, unbolded text). Is this intentional? Never mind, this is the result of a change in localization on my system
« Last Edit: January 30, 2015, 12:01:15 pm by Raxx »
Logged

ronaldefarmer

  • Sr. Member
  • ****
  • Posts: 293
    • View Profile
    • Ron's Website
Re: Current Development Release - Build 1159, January 29, 2015
« Reply #277 on: January 30, 2015, 05:25:59 am »

Major changes for build 1159:

Extrude-Connected and Shell: Improve uniformity of thickness in extruded parts.


Thanks Steve, this is much better. I've been waiting for this one.

« Last Edit: January 30, 2015, 05:30:26 am by ronaldefarmer »
Logged

Raxx

  • Administrator
  • Hero Member
  • *****
  • Posts: 1446
    • View Profile
Re: Current Development Release - Build 1159, January 29, 2015
« Reply #278 on: January 30, 2015, 09:27:15 pm »

Just a few comments...the picking radius for points in fast select needs to be a lot wider, at least doubled. It's far too small for quick editing.

Also, any chance we can have the name, "fast select" officially changed to something like "fast edit"? A trivial detail, I know, but "fast select" is misleading since it's the editing actions that are sped up, not the selection actions. Does anyone else feel that way?
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1523
    • View Profile
Re: Current Development Release - Build 1162, January 30, 2015
« Reply #279 on: January 31, 2015, 12:25:37 am »

Just posted 1162 wit a couple of fixes.

Perspective views now correctly dolly instead of zoom in Arc Rotate when the <Ctrl> key isn't pressed.

For single points Frame Selected I allow it but set a bounding box minimum size of 1. This was done as a side effect adding code to prevent the view from zooming in extremely close when two points are almost aligned in the X and Y axis, such as when a single edge is selected that points almost directly at the viewer. Raxx If you think it's better to just center the screen in this case I can do that for single points.

Not entirely sure that Fast Edit is a better name but it's no worse. Does anyone have any feedback?

The 2D Flatten and Intersect Edges commands weren't supposed to be released but since I say that they were in the executable that I posted I thought I'd mention them.  As it is the Flatten command only works in the Debug builds so I removed it from the latest post.

The Intersect Edges command does work: Selected edges that aren't part of any faces that intersect are cut at the intersection point. A new point is added at the intersection and the end points are all connected to the new point. (I can also allow edges with faces but it's a lot more work and I'm not sure of the utility.

This is useful for making a lot of things (i.e. a floor plan for a house) because you can first add all the global edge, then add more detail, and connect them at the cross points with a single command.

I'll be adding more tools like that on the path to true Solids Modeling - but it will be a while before that is all ready.

Extrude a Mesh along a Path is a good idea.  I'll add it to the "to-do" list.
Logged

captaindrewi

  • Sr. Member
  • ****
  • Posts: 450
  • errm...errr?
    • View Profile
Re: Current Development Release - Build 1162, January 30, 2015
« Reply #280 on: January 31, 2015, 01:38:38 am »

1159 and 1162
using extrude an object... all open edges of an object....ermm i tried it with this half sphere then i applied the thickness tool but it kinda distorts is that what one should expect.
see image below...extrude.jpg
also
when using the bulge tool the face disappears ,it returns when you subdivide or click where it should be after a short time.
not a huge problem but worth mentioning perhaps. :)
see image below...bulge1.jpg
Logged
!

Raxx

  • Administrator
  • Hero Member
  • *****
  • Posts: 1446
    • View Profile
Re: Current Development Release - Build 1162, January 30, 2015
« Reply #281 on: January 31, 2015, 01:51:15 am »

Ah! Ok, I got Intersect Edges to work. Now it's obvious why Flatten is needed.

Personally, I think I prefer that Frame Selected only centers a single point, rather than zoom as well. It'll serve as a good trick to center the view on special interest areas of a mesh, without needing a separate "center w/o zoom" command cluttering up the place. I feel like I'll be using it a lot ;)

Speaking of zoom, it seems that the middle mouse button doesn't zoom as much anymore, both when clicking and dragging via arc rotate or when scrolling. I definitely prefer the original zoom rate that it used to have. Or, an option to change the zoom rate might be nice to have in Configure UI.

Thanks for the update!
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1523
    • View Profile
Re: Current Development Release - Build 1162, January 30, 2015
« Reply #282 on: January 31, 2015, 02:11:43 am »

captaindrewi: Verified the Bulge bug:

#098-060 - Faces disappear during Bulge operation.

but I can't reproduce the shell bug that you show.  I did: Sphere --> Mesh --> Cut top off --> Shell  and it worked OK. Are you sure that there weren't some extra edges or such in your sphere?  If not, can you send me the model before you Shell if?

raxx: I think the mouse wheel changes were reduced when I merged all the code.  I'll increase the change.  2. I'll try single point centering also for the next build.
Logged

captaindrewi

  • Sr. Member
  • ****
  • Posts: 450
  • errm...errr?
    • View Profile
Re: Current Development Release - Build 1162, January 30, 2015
« Reply #283 on: January 31, 2015, 02:30:28 am »

before shelling i used the new object extrude in y axis, via build.
try shelling this prepared object.
Logged
!

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1523
    • View Profile
Re: Current Development Release - Build 1162, January 30, 2015
« Reply #284 on: January 31, 2015, 02:56:08 am »

The normals for one of the faces is flipped.  Used the Edit->FixNormals tool on it in the main Object Editor and then it works OK.

Note: In the Point Editor select all the faces.  You can see that the outside is all yellow and the inside is all blue except for one face, which is the one that's causing trouble.  I'll look into the Extrude Edges too to see it if is causing this.

Logged
Pages: 1 ... 17 18 [19] 20 21 ... 46