Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Pages: 1 ... 37 38 [39] 40 41 ... 46

Author Topic: Changed to Older Releases [builds 1162 to 1230]  (Read 125812 times)

nemyax

  • Full Member
  • ***
  • Posts: 213
    • View Profile
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #570 on: February 17, 2016, 08:16:17 am »

In build 1219 the mirror is much improved, but weird things still happen around the mirror plane. For example, dissolving this pair of mirrored edges should just obliterate them as it would any other:



Instead, it pokes a hole:



You can't reliably dissolve the centre edges or vertices on them. It only works some of the time.
Also, cuts that involve centre components aren't always mirrored.
Logged

selden

  • Full Member
  • ***
  • Posts: 142
    • View Profile
    • Modelling for Celestia
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #571 on: February 17, 2016, 11:14:23 am »

When build 1219 starts on my system, it opens a very tiny desktop window which is mostly off-screen at the top left. At first I thought its window wasn't opening at all.

Build 1215 starts fine: its initial window occupies most of the screen.

I'm running Anim8or with the traditional GUI colors.

What additional info can I provide to find the problem?

Here's my basic system info:

Computer: Dell Latitude E6510 laptop
          Core i7 Q720 (1.6GHz), 8GB; Win 7 Pro x64 (SP1), Aero GUI
Disk: PNY CS1111 SSD (480GB)
DVD: Hitachi HL-DT-ST GU10N -- Multi DVD Rewriter, Region 1
Display: 1920x1080 FHD, 60Hz (1080p)
Graphics: Nvidia Quadro NVS 3100M (512MB),  driver v341.44
Logged
Selden

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1519
    • View Profile
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #572 on: February 17, 2016, 04:46:46 pm »

I found out what the problem is.  You can fix it like this:

1. Open Anim8or and resize the screen to something useful.
2. In the File->Configure dialog check the "Remember Window Location" box.
3. Close Anim8or.

Now it should always start in the same place.  I'll fix this in the next drop.
Logged

selden

  • Full Member
  • ***
  • Posts: 142
    • View Profile
    • Modelling for Celestia
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #573 on: February 17, 2016, 05:28:35 pm »

Thanks!
Logged
Selden

Kyle

  • Full Member
  • ***
  • Posts: 184
    • View Profile
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #574 on: February 17, 2016, 09:28:17 pm »

First time trying normal maps. It crashes every time I attempt to apply a material with one.  I'm on Windows 10 and the latest build of anim8or.

Edit: ok, it seems to work if I first open your sample normal mapped file, it just doesnt like it when I start from scratch. Strange.
« Last Edit: February 17, 2016, 09:51:51 pm by Kyle »
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1519
    • View Profile
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #575 on: February 18, 2016, 01:51:15 am »

Kyle: if you could send me a project with the material that crashes, and the normal map file, I'll try to find the problem.
Logged

AlecJames

  • Jr. Member
  • **
  • Posts: 87
    • View Profile
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #576 on: February 19, 2016, 10:42:31 pm »

1215 and 1219   win7 x64    opengl 4.2

In point edit mode, texture UV, the texture is only visible in smooth shaded mode. Flat shaded and wire frame can show the rear of the texture of the opposite face (and you can think that you are editing the opposite texture).  This has changed since 0.98, is it correct?
 
I'm not sure if this isn't the intended operation - If I double click texture UV to see the Texture Coordinate parameters and click reset or 'reset to default' it affects all faces, not just the selected faces, is that correct?

I can post a detailed write up if needed.
Thanks
A

Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1519
    • View Profile
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #577 on: February 19, 2016, 11:19:22 pm »

I can reproduce the problem.  I'll fix it.  In the mean time you can disable the new OpenGL vertex array code with the Options->Debug->NewOGLRenderer option and it will work OK.

I think it's always reset the whole object.  I just tried it in v0.981.

#098-077 - UV editor doesn't show textures in wireframe views.
Logged

Hypure

  • Full Member
  • ***
  • Posts: 123
    • View Profile
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #578 on: February 20, 2016, 03:32:55 am »

You can retain undo history between scene and object on all objects except for the object currently selected....  Just noticed that- will come in handy.
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1519
    • View Profile
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #579 on: February 20, 2016, 05:29:22 am »

In the next build the Undo history will be preserved across all renders.  I've already finished that part but am waiting to finish a few more things before posting it :)
Logged

kreator

  • Hero Member
  • *****
  • Posts: 1113
  • Anim8or, Blender, & Carrara. A Great Combination!
    • View Profile
    • Anim8orWorld
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #580 on: February 20, 2016, 06:26:55 am »

Steve: Any way you can extend the list of recent projects from four to at least 10 in the menu/file. I know it is in the registry but I have tried adding more without any success. Would be nice as I always have loads of projects on the go but its always the case of trying to remember where l put them ( I`m getting an old man now!)
« Last Edit: February 20, 2016, 06:28:11 am by kreator »
Logged
O

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1519
    • View Profile
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #581 on: February 20, 2016, 07:21:04 am »

kreator: that's not a bad idea!  I'll see what I can do...  (i.e. Sure, just give me a moment!)
Logged

Kyle

  • Full Member
  • ***
  • Posts: 184
    • View Profile
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #582 on: February 21, 2016, 06:40:54 am »

Kyle: if you could send me a project with the material that crashes, and the normal map file, I'll try to find the problem.
I was just about to until it randomly started to work, now I cant reproduce it. At least not consistently.


Anyway, I like the idea of putting more recent projects in the list. I'm so disorganized it would help me quite a bit for such a small thing.
« Last Edit: February 21, 2016, 06:42:35 am by Kyle »
Logged

AlecJames

  • Jr. Member
  • **
  • Posts: 87
    • View Profile
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #583 on: February 21, 2016, 09:02:57 pm »

Hi Steve,
In build 1219 the playback issue is back where clicking on the screen / track window can cause anim8or to stop responding until the end of the playback.  I found it quite easy to reproduce using the testglobe project I posted earlier in this thread.  Clicking in the track window during play back does it. (sometimes just once, sometimes several clicks are required).
Thanks for all your hard work :)
A
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1519
    • View Profile
Re: Current Development Release - Build 1219, February 16, 2016
« Reply #584 on: February 21, 2016, 11:46:47 pm »

AlecJames: I changed how the messaging works to redraw windows when I added the floating track option.  I think the redraws aren't getting there when Anim8or is busy.  It also happens when you render a movie using the OpenGL renderer - nothing shows up on the screen until it's finished, though the frame counter in the status window updates. It's on my list to fix.
Logged
Pages: 1 ... 37 38 [39] 40 41 ... 46