Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: [fixed] Materials-bar, switching object, An8 loading.  (Read 1402 times)

MvGulik

  • Full Member
  • ***
  • Posts: 107
  • [... Lost in Space ...]
    • View Profile
[fixed] Materials-bar, switching object, An8 loading.
« on: August 28, 2014, 05:10:05 pm »

#098-016 - Material window doesn't show bitmaps when first opened after switching objects.
Fixed: v0.9.8 build 1101



Something that's kinda annoying me. (0.98 series, as far as I (like to) know)

- On a just loaded an8 file,
- When switching to a other Object,
- The Material bar (Already active, and in Object mode) shows as empty (While there are materials defined and used in the target Object.)

- Ones the materials-bar is displaying correctly, it seems to maintain its normal behavior. ... I think.
« Last Edit: October 04, 2014, 06:26:06 am by MvGulik »
Logged

jwalt

  • Newbie
  • *
  • Posts: 41
    • View Profile
Re: Materials-bar, switching object, An8 loading.
« Reply #1 on: August 28, 2014, 06:26:21 pm »

I've seen this, too. I hadn't paid enough attention to when it happens, so I can't back up MvGulik's comments. It reappears if I "pull it down." I also seem to lose the first slot material, off and on, when grouping or adding things to the model. It reverts back to the default material. Then I have to reapply to the faces.

Neither of these seem consistent failures. I'll try and note when/if they happen again.
Logged

MvGulik

  • Full Member
  • ***
  • Posts: 107
  • [... Lost in Space ...]
    • View Profile
Re: Materials-bar, switching object, An8 loading.
« Reply #2 on: August 28, 2014, 11:45:42 pm »

I've seen this, too. I hadn't paid enough attention to when it happens, so I can't back up MvGulik's comments. It reappears if I "pull it down."
Its a UI drawing/updating issue. With different side effects on different actions. The painted case in the OP being one of them.

Quote
I also seem to lose the first slot material, off and on, when grouping or adding things to the model. It reverts back to the default material. Then I have to reapply to the faces.
Those are other issues that are better served by giving them there own topic/tread/(Ticket!).
« Last Edit: August 28, 2014, 11:46:19 pm by MvGulik »
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1520
    • View Profile
Re: Materials-bar, switching object, An8 loading.
« Reply #3 on: September 02, 2014, 09:11:13 pm »

Yes, I've noticed this as well. You prompted me to chase it down.

#098-016 - Material window doesn't show bitmaps when first opened after switching objects.

I have a pretty good fix for this. The cause is rather complex and I couldn't think of a true fix that didn't require rewriting a ton of code but what I did works except in obscure cases (such as an other app's window being moved over the Anim8or window while the Materials toolbar is being drawn). So I'm calling this "fixed". It'll be in the next post.

The small spheres that show the material aren't built until the Material Menu is being drawn. Sometimes when there are being rendered an outside Windows message comes along and some other part of Anim8or draws on the screen somewhere. When this happens the GDI draw object can be left in a strange state so the Material Menu fails to show the material, and/or stops drawing and  updating the rest of the materials as well. What I did was reduce the places where these other messages can happen, but not entirely eliminate them. So it should (sees to) work OK for everything that I have tested.


« Last Edit: September 03, 2014, 10:24:09 pm by Steve »
Logged

MvGulik

  • Full Member
  • ***
  • Posts: 107
  • [... Lost in Space ...]
    • View Profile
Re: Materials-bar, switching object, An8 loading.
« Reply #4 on: September 03, 2014, 08:28:34 pm »

Roger.

Aha. Observed material-bar behavior making more sense now.
Logged