Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Pages: 1 2 3 [4] 5 6 ... 8

Author Topic: Where can I start?  (Read 17649 times)

ENSONIQ5

  • Sr. Member
  • ****
  • Posts: 925
    • View Profile
    • Mission Backup Earth
Re: Where can I start?
« Reply #45 on: December 17, 2014, 01:24:20 pm »

Haven't played your file, but most common cause of ends not capping in an extrude is if the spline being extruded is not closed. When drawing the spline, don't try to close the spline by clicking the last point over the first.  Instead, once the final point has been entered and all that's missing is the final line that is needed to close the spline, double-click anywhere on the spline to open the Path Editor.  Select 'Closed', untick 'Extendable' and click OK and the gap between the first and last points will be closed with a line.  Extrude it (Z axis if working in front view) with end caps selected and everything should be fine.

The end caps are generally triangulated which isn't suitable for subdivision so some manual re-working of the mesh is often required, but that's probably not critical at this stage in your Anim8or journey.
Logged

Owl

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
Re: Where can I start?
« Reply #46 on: December 17, 2014, 02:35:02 pm »

Thank you for your thoughts. I believe the second object in the video does all you said.
I also have been leaving a big gap between the last two points so I can verify that the close command actually closed it.
Have spent several hours trying to find the pattern, to no avail
Thank You.
« Last Edit: December 17, 2014, 02:35:40 pm by Owl »
Logged

kreator

  • Hero Member
  • *****
  • Posts: 1113
  • Anim8or, Blender, & Carrara. A Great Combination!
    • View Profile
    • Anim8orWorld
Re: Where can I start?
« Reply #47 on: December 17, 2014, 05:32:03 pm »

Re: Your flv file,Your extruding in the wrong direction. Thats why you are having trouble getting caps, for Front view, if you try it in the Z direction you should have no trouble.
« Last Edit: December 17, 2014, 06:19:24 pm by kreator »
Logged
O

Owl

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
Re: Where can I start?
« Reply #48 on: December 17, 2014, 06:47:04 pm »

Hi kreator,
Please look at my screen capture again. You are right about the first time, firsr object. I thought by doing this object first that this was one of the ways to get it to mess up the second time, where I choose "Z" axis (...yes?). But I have had it work or not work without being able to figure the pattern.
Do you see a problem with the way I extruded the second object?
Thank You.
Logged

captaindrewi

  • Sr. Member
  • ****
  • Posts: 450
  • errm...errr?
    • View Profile
Re: Where can I start?
« Reply #49 on: December 17, 2014, 07:06:03 pm »

Could it be that there are a few versions of 0.98.
and therein lies the peculiarity OWL is experiencing.
Mine is 2013
and i have just looked at anim8or main download page where the latest is 2014.
what edition have you got OWL?
The latest version Anim8or, v0.98 dated January 23, 2014 is available here: animv098.zip. It is identical to the original release dated November 30, 2014 with a fix for an spline extrusion/filling bug.
« Last Edit: December 17, 2014, 07:07:28 pm by captaindrewi »
Logged
!

Owl

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
Re: Where can I start?
« Reply #50 on: December 17, 2014, 07:22:25 pm »

My version says:
"Version 0.98
23-Jan-14"
Logged

kreator

  • Hero Member
  • *****
  • Posts: 1113
  • Anim8or, Blender, & Carrara. A Great Combination!
    • View Profile
    • Anim8orWorld
Re: Where can I start?
« Reply #51 on: December 17, 2014, 07:57:14 pm »

Hmmm, mine says 20th Nov 2013

I would hazard a guess and say you have a development copy!

Heres the link http://www.anim8or.com/download/files/animv0981.zip
« Last Edit: December 17, 2014, 08:05:44 pm by kreator »
Logged
O

Owl

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
Re: Where can I start?
« Reply #52 on: December 17, 2014, 08:37:50 pm »

According to the message before mine (captiandrewi), I have the correct version, no?
Logged

captaindrewi

  • Sr. Member
  • ****
  • Posts: 450
  • errm...errr?
    • View Profile
Re: Where can I start?
« Reply #53 on: December 17, 2014, 09:04:43 pm »

I now have the same version as you OWL and it works ok re caps and ends.
Sorry i cant offer any solution.its a puzzle.
Logged
!

Owl

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
Extrude Problem
« Reply #54 on: December 17, 2014, 11:12:11 pm »

It works correctly about 1/3 the time. But remember as a newbie, I am trying all kinds of illogical parameters and decision paths.

Some symptoms that may help debug it:
1) Once the problem happens, it will do it every time. I have to close/restart the Anim8or.exe.
2) Some times it won't extrude on a line or spline. I can draw a line back in Z (0,0,z), and it won't do anything, But if I choose "Z" in BUILD>Extrude it works.
Again once it happens it will continue to happen until I close and reopen it.
3) Anim8or_1143 NEVER works, because double clicking on a point does not bring up a "close" option.

Well at least I can move on. Have maybe 5 hours working on this problem.

 
« Last Edit: December 17, 2014, 11:13:30 pm by Owl »
Logged

ENSONIQ5

  • Sr. Member
  • ****
  • Posts: 925
    • View Profile
    • Mission Backup Earth
Re: Where can I start?
« Reply #55 on: December 18, 2014, 02:15:20 am »

I have not been able to replicate your fault in the same build version.  My advice would be to run some more tests adhering to the following rules:

1) Keep the spline simple, no internal angles (ie. a square, rectangle, pentagon etc.)
2) Do not attempt to close the spline manually, there is no need to create a final point close to the first point.  If creating a square, stop after the third line.
3) Double-click on a LINE element to open the path editor, not a node.  In your screen cap you click the node, converting the line(s) adjoining it to curves (as evidenced by the green handles popping out the side).  If done correctly, the selected line should show green while the path editor is open.

If you are able to trigger the fault under these conditions I would recommend re-downloading Anim8or and check your compatibility settings (run as Windows XP SP3 with desktop composition disabled).  Also make sure you make no changes to any config or preference dialogs, keep it all default for the sake of the test.

Re extruding on a spline, I have always had best results creating both splines (the section and the extrusion path) in Front view, so the paths are expressed in the X-Y plane only.  After creating the path in Front view you can swap to other views to pull it about in the Z-axis, but always run the extrusion process from the Front view *. Be sure to create the section around the centre of the screen as this is the point that is mapped to the path.

* This requirement may not be necessary in later versions, I have not tested it comprehensively.  This was true in V0.97x and earlier.
« Last Edit: December 18, 2014, 06:38:44 am by ENSONIQ5 »
Logged

Owl

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
Re: Where can I start?
« Reply #56 on: December 18, 2014, 11:08:00 am »

Thank you for your thoughts. What you have described is "work arounds". Hopefully someone is going to look at the code and fix it.

What's up with the beta version, I don't find a "close"option ?
Logged

ENSONIQ5

  • Sr. Member
  • ****
  • Posts: 925
    • View Profile
    • Mission Backup Earth
Re: Where can I start?
« Reply #57 on: December 18, 2014, 11:30:27 am »

I haven't provided work-arounds, I've suggested a process you can follow to try to isolate the cause of the bug, assuming that's what it is.  The idea is to remove as many variables as possible and, if this proves stable, to individually introduce further complexity to the process until the issue recurs.  The only way to determine the cause of this fault will be via a process of elimination.  The fact that this fault has not previously been identified and does not seem to be replicable by others suggests it could be local to your instance and may not represent an issue in the code, I would again recommend re-loading the latest non-beta version of Anim8or to eliminate executable file corruption as the cause.
Logged

captaindrewi

  • Sr. Member
  • ****
  • Posts: 450
  • errm...errr?
    • View Profile
Re: Where can I start?
« Reply #58 on: December 18, 2014, 01:58:28 pm »

What's up with the beta version, I don't find a "close"option ?
Yes that does appear to be an oversight
Logged
!

kreator

  • Hero Member
  • *****
  • Posts: 1113
  • Anim8or, Blender, & Carrara. A Great Combination!
    • View Profile
    • Anim8orWorld
Re: Where can I start?
« Reply #59 on: December 18, 2014, 04:35:40 pm »

Lets get This sorted once an for all ..... What windows version are you using, Graphics card, and are you using the 0.98 version or a development copy as I cannot replicate your problems either.

What does the splash screen say when anim8or  boots up, and have you tried it in compatibility mode?

Logged
O
Pages: 1 2 3 [4] 5 6 ... 8