Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: bones not showing in scene  (Read 1495 times)

johnar

  • Sr. Member
  • ****
  • Posts: 814
  • Make it, Move it--Give it Life
    • View Profile
    • youtube vids
bones not showing in scene
« on: April 13, 2015, 12:34:22 pm »

Can't work this out. 
 The bones aren't showing up in the timetrack list, but you can see them in the workspace.
 (When i click on a bone it says no controllers.
 But the bones are set to no limits in figure mode.
 Create a controller, and 1 axis of one bone shows up in the timetrack.)
 Its happening on winxp and win7, and seems to be any version of anim8or.
 How can this be?
 I've been trying for the last long time to work this out. . lol. Please someone tell me it's something simple.
 This is so strange......

 Edit: Has it always been like this..??
  Normally, when you import a figure into scene mode, aren't the bones automatically there under the figures name in the timetrack?
 Maybe i've just been dreaming thats how it was ... 
« Last Edit: April 15, 2015, 11:08:57 am by johnar »
Logged
%

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1532
    • View Profile
Re: bones not showing in scene
« Reply #1 on: April 15, 2015, 04:37:57 pm »

Well, this certainly needs to be improved!

Currently (and, I guess, since the beginning) there are two ways to make the bone joints appear:

1) You need to use the Rotate Bone (hot key R) tool, double click on a bone and answer "Yes" to the dialog "Do you want to create a controller for xxx?". Use the LMB to create one for the X-axis, the RMB for the Y-axis, and the MMB for the Z-axis.

2) Add a Sequence that uses those bones.

I normally start with building a Sequence so I never noticed this - or just know how to do it so I though it wasn't an issue.  But today I'd forgotten and it took a bit of clicking around to figure it all out.
Logged

davdud101

  • Sr. Member
  • ****
  • Posts: 950
  • Couldn't ever use Blender or Maya. Anim8or's good.
    • View Profile
Re: bones not showing in scene
« Reply #2 on: April 15, 2015, 05:28:12 pm »

Oh, that was happening to me to. The temporary fix I think is to use a sequence/pose that has all bones keyed. This also has always happened for figures with morph targets and I fix it by importing the object of the figure that has the morphs.
Logged
?

johnar

  • Sr. Member
  • ****
  • Posts: 814
  • Make it, Move it--Give it Life
    • View Profile
    • youtube vids
Re: bones not showing in scene
« Reply #3 on: April 16, 2015, 12:34:40 am »

Quote
I normally start with building a Sequence so I never noticed this
  Far out. Thanks Steve. Thought i was loosing my marbles. If thats the way its always been, then i've been carrying on as per normal without noticing as well.
 Don't know what made me think of it. Just imported a figure into scene mode the other day and thought, "Hey, wheres the bones?!?"
 (perhaps that was a day when i actually found my marbles, temporarilly) lol


 davdud. Yes, thats what i do.
Logged
%