Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: Can't import .LWO models: missing LWOBJ  (Read 1744 times)

selden

  • Full Member
  • ***
  • Posts: 143
    • View Profile
    • Modelling for Celestia
Can't import .LWO models: missing LWOBJ
« on: October 20, 2015, 11:14:06 pm »

When I try to import a Lightwave .lwo model file, Anim8or fails. It generates an error popup complaining

Just so you'd know...
Missing LWOBJ

Where can I get a copy of "LWOBJ" and where should it be put?
I have a trial version of Lightwave v 2015.3 installed, but it does not include any file with that name.

Edited to add: this failure is seen in Anim8or v0.98 and v0.98a [build 1185]
« Last Edit: October 20, 2015, 11:24:13 pm by selden »
Logged
Selden

RudySchneider

  • Sr. Member
  • ****
  • Posts: 413
  • There are no problems, only opportunities
    • View Profile
Re: Can't import .LWO models: missing LWOBJ
« Reply #1 on: October 21, 2015, 12:57:19 am »

The "LWOBJ" to which you refer is simply a generic name to indicate that you're missing one or more LightWave object files.  I doubt the file you're looking for is actually called "LWOBJ."

Lightwave projects use a filing hierarchy that uses "Images," "Objects," and "Scene" directories.  The object or objects you're looking for should be in the "Objects" directory for the project you downloaded.  Normally, when you're using LightWave and you get the "Missing LWOBJ" message, it asks you if you want to get it from another location.  All you should have to do is say "Yes," and then navigate to the "Objects" folder and LightWave will automatically load the proper file as long as it exists in that folder.

BTW, just as with Anim8or, it's always a good idea to READ THE MANUAL, or look over the multitude of tutorials that are online for LightWave.
« Last Edit: October 21, 2015, 12:58:17 am by RudySchneider »
Logged
G

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1532
    • View Profile
Re: Can't import .LWO models: missing LWOBJ
« Reply #2 on: October 21, 2015, 01:08:05 am »

OK that error message is somewhat misleading.  The first few bytes of a .lwo file contain a signature so that you can tell what kind of file it is.  Bytes 0 to 3 should contain the ASCII characters "FORM", bytes 4 to 7 the file size in big-endian format, and the next 4 bytes should be "LWOB". My guess is that you have a newer file format that the one that Anim8or can read.

Can you send me a .lwo file that shows this problem? I don't know if I will be able to do anything about it anytime soon but I'll take a look to see if there isn't something simple that I can do to fix this.
« Last Edit: October 21, 2015, 09:36:15 pm by Steve »
Logged

selden

  • Full Member
  • ***
  • Posts: 143
    • View Profile
    • Modelling for Celestia
Re: Can't import .LWO models: missing LWOBJ
« Reply #3 on: October 21, 2015, 01:56:58 pm »

Steve,

A failing lwo model is included in the post by argo34116 at http://www.anim8or.com/smf/index.php/topic,5286.msg39097.html#msg39097

Logged
Selden

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1532
    • View Profile
Re: Can't import .LWO models: missing LWOBJ
« Reply #4 on: October 21, 2015, 09:39:09 pm »

This file is in the .lwo2 format used by Lightwave versions 6.0 and greater, which Anim8or does not currently support. I don't have time to add support for this format right now, but I added a better error message explaining what's happening.
Logged

selden

  • Full Member
  • ***
  • Posts: 143
    • View Profile
    • Modelling for Celestia
Re: Can't import .LWO models: missing LWOBJ
« Reply #5 on: October 22, 2015, 02:38:17 am »

OK, I understand. Thanks for investigating it.
Logged
Selden