General Category > Anim8or v0.98 Discussion Forum

Loop animation results in unresponsive program


Not sure if anyone has pointed this out yet, at least I haven't seen it in the recent posts...

Usually what I'd do with .95 in a scene to test if a character movement looks right at regular speed is: hit the loop scene button and then highlight the range of frames I want to see, then play. It will run through the section of the animation and jump back to the beginning of the highlighted range until I hit stop. But in the current version (or at least I've only tried it in 1258) doing this results in the program getting stuck in the loop when I try to stop it, then graying out and becoming unresponsive with the only option to kill the operation.

This bug has been reported. It should be partially fixed, but it's a hard one to find the root cause for.

Can you try using the <ESC> key to stop it, or the <space> key to pause and then restart it?  I think these should work. But clicking on the time track can make it hang, as you've unfortunately found out :(

So far nothing has really stopped it.
Any attempt to interact with the program causes it to gray out the whole thing and the only way I seem to get out of it is when the computer asks me if I want to stop the unresponsive program.

The weird thing is it only seems to lock after the program has been in scene mode for a while. like if I just go in an immediately go to scene mode and try it, then it seems fine, but I try it a few minutes later and that's when it locks. Before that I'm sure space or esc would probably stop it, but that's only because you can still hit the stop button and achieve the same effect, once it hits the point of not return nothing I can do will save it.

I was just messing with the IK tool to try and learn how it's used in Anim8or, and I've found that it still freezes as I mentioned before,  even without highlighting the frames in the timeline as I used to do with the older .95 version

What I did was copy the first key frame to the last frame of a 31 (0-30)frame animation after creating 2 or 3 key frames before the end. then I removed the rest of the default number of frames (31-70) and set the animation to loop scene. When I tried to stop it it froze even though it should have simply treated as a normal animation. So now I wonder if it's not something directly related to the "loop scene" command rather than my initial monkeying with the timeline.


[0] Message Index

Go to full version