General Category > Anim8or v0.98 Discussion Forum

Movie Render crashes

(1/2) > >>

On several projects, when I try to render a movie, Anim8or crashes right before the Video Compression window shows up -- sometimes later in the render. It happens with any of the 3 renderers and in several different views - camera, front.

The image render works fine.

One crash seems related to a certain png texture file (with alpha) since, if I delete that texture, save the project then reopen the project, the movie render won't crash.

However, the object that has this 'bad' texture isn't even in the scene that crashes(?) AS a test I removed everything (except world and camera) from the scene. Still crashes.

The offending texture is moderately large: 2048 x 1024.

In another project has about 2 thousand elements for smoke. It too crashes before the Video Compression window. Resource monitor says that the program is taking 250~300 megabytes with several gigs free.

Occasionally, if I fiddle enough and they render ok, I get a "Cannot set allocations" message before the Video Compression window opens and then they seem to render ok.

Is there some limit on what texture sizes can be or how complex scenes can be?

Win 7, 64 bit 8 Gig. 2 Gig NVidia GT 730.


(projects are available if interested.)

If you post the smaller project that crashes along with the associated texture files I'll run it under the debugger and see if I can find something.

Steve - Thanks.

This crashes for me. Open Anim8or, load this, select scene mode, select render movie, select output file, hit OK.

This file is stripped of stuff that didn't seem to affect the crashing.

What codecs have you tried? Which render (scanline, ARTRay Tracer, OpenGL)? This project is rendering an image 2560 by 1440 pixels, which takes a lot of memory and which is too big fro some codecs. Can you try a smaller image size?

For large image sizes I sometimes get a system error (i.e. 0x80044066) from the codec.


First, found this so-far-working work-around for me: Render something that doesn't crash (one that I removed the 'offending' texture from), close that an8 file, then open a crasher an8 within same Anim8or session. And tho I often get a message "dll initialization failed" before getting to the Video Compression selection, it seems to let me render OK. Works so far on both problem projects.

Second, looking at the crash report, seems "StackHash" is a Data Execution Prevention exception which can be turned off in Windows. So maybe one of my codecs is goofy. Will investigate. Not as good as first fix above since only works on one project.

Before finding these two above things, I wrote these answers to your questions:

Crashes with any codec since it crashes before I get to select one, and with any of the three renderers.

I tried at 720x1280 and it crashes the same -- before selecting a codec. (Intention was to render with opengl and use the big frame size for antialiasing.)

Other files (like the one that I removed the 'offending' texture from) renders ok at the big sizes.

If this just my problem, OK.

Did try XP mode and run as admin. Tried no multithread and set process affinity to one processor.

Here's the crash report:
Problem Event Name:   APPCRASH
  Application Name:   Anim8or_1264.exe
  Application Version:
  Application Timestamp:   5864366c
  Fault Module Name:   StackHash_bc7e
  Fault Module Version:
  Fault Module Timestamp:   00000000
  Exception Code:   c0000005
  Exception Offset:   10061d51
  OS Version:   6.1.7600.
  Locale ID:   1033
  Additional Information 1:   bc7e
  Additional Information 2:   bc7ed343cd08601ea4a68f4f11772834
  Additional Information 3:   b10d
  Additional Information 4:   b10d69c7a4b8c862ade0ad8a0f22fe9f




[0] Message Index

[#] Next page

Go to full version