Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: Movie Render crashes  (Read 1407 times)

dancingshoes

  • Newbie
  • *
  • Posts: 19
    • View Profile
Movie Render crashes
« on: January 12, 2017, 05:20:40 pm »

On several projects, when I try to render a movie, Anim8or crashes right before the Video Compression window shows up -- sometimes later in the render. It happens with any of the 3 renderers and in several different views - camera, front.

The image render works fine.

One crash seems related to a certain png texture file (with alpha) since, if I delete that texture, save the project then reopen the project, the movie render won't crash.

However, the object that has this 'bad' texture isn't even in the scene that crashes(?) AS a test I removed everything (except world and camera) from the scene. Still crashes.

The offending texture is moderately large: 2048 x 1024.

In another project has about 2 thousand elements for smoke. It too crashes before the Video Compression window. Resource monitor says that the program is taking 250~300 megabytes with several gigs free.

Occasionally, if I fiddle enough and they render ok, I get a "Cannot set allocations" message before the Video Compression window opens and then they seem to render ok.

Is there some limit on what texture sizes can be or how complex scenes can be?

Win 7, 64 bit 8 Gig. 2 Gig NVidia GT 730.

Thanks.

(projects are available if interested.)
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1532
    • View Profile
Re: Movie Render crashes
« Reply #1 on: January 12, 2017, 06:18:41 pm »

If you post the smaller project that crashes along with the associated texture files I'll run it under the debugger and see if I can find something.
Logged

dancingshoes

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: Movie Render crashes
« Reply #2 on: January 13, 2017, 01:01:58 pm »

Steve - Thanks.

This crashes for me. Open Anim8or, load this, select scene mode, select render movie, select output file, hit OK.

This file is stripped of stuff that didn't seem to affect the crashing.
« Last Edit: January 14, 2017, 03:38:16 pm by dancingshoes »
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1532
    • View Profile
Re: Movie Render crashes
« Reply #3 on: January 13, 2017, 05:41:44 pm »

What codecs have you tried? Which render (scanline, ARTRay Tracer, OpenGL)? This project is rendering an image 2560 by 1440 pixels, which takes a lot of memory and which is too big fro some codecs. Can you try a smaller image size?

For large image sizes I sometimes get a system error (i.e. 0x80044066) from the codec.
Logged

dancingshoes

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: Movie Render crashes
« Reply #4 on: January 13, 2017, 09:02:12 pm »

Steve

First, found this so-far-working work-around for me: Render something that doesn't crash (one that I removed the 'offending' texture from), close that an8 file, then open a crasher an8 within same Anim8or session. And tho I often get a message "dll initialization failed" before getting to the Video Compression selection, it seems to let me render OK. Works so far on both problem projects.

Second, looking at the crash report, seems "StackHash" is a Data Execution Prevention exception which can be turned off in Windows. So maybe one of my codecs is goofy. Will investigate. Not as good as first fix above since only works on one project.

Before finding these two above things, I wrote these answers to your questions:

Crashes with any codec since it crashes before I get to select one, and with any of the three renderers.

I tried at 720x1280 and it crashes the same -- before selecting a codec. (Intention was to render with opengl and use the big frame size for antialiasing.)

Other files (like the one that I removed the 'offending' texture from) renders ok at the big sizes.

If this just my problem, OK.

Did try XP mode and run as admin. Tried no multithread and set process affinity to one processor.

Here's the crash report:
Problem Event Name:   APPCRASH
  Application Name:   Anim8or_1264.exe
  Application Version:   0.9.8.2
  Application Timestamp:   5864366c
  Fault Module Name:   StackHash_bc7e
  Fault Module Version:   0.0.0.0
  Fault Module Timestamp:   00000000
  Exception Code:   c0000005
  Exception Offset:   10061d51
  OS Version:   6.1.7600.2.0.0.256.48
  Locale ID:   1033
  Additional Information 1:   bc7e
  Additional Information 2:   bc7ed343cd08601ea4a68f4f11772834
  Additional Information 3:   b10d
  Additional Information 4:   b10d69c7a4b8c862ade0ad8a0f22fe9f

Yikes!

Thanks.
Logged

dancingshoes

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: Movie Render crashes
« Reply #5 on: January 14, 2017, 03:37:28 pm »

To close this out, for what ever reason, when I uninstalled on old cineform codec, things smoothed out.

Sorry and thanks.
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1532
    • View Profile
Re: Movie Render crashes
« Reply #6 on: January 15, 2017, 09:41:30 pm »

Thanks, dancingshoes. It's good to know that can be a problem.
Logged

dancingshoes

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: Movie Render crashes
« Reply #7 on: February 14, 2017, 10:52:12 am »

Belated update.

My crashes now seem(?) related to going in and out of sleep and hibernation modes while using a solid state drive with TRIM enabled.

Files were being corrupted.

I've turned TRIM off for the last several weeks w/o problems with hopes this is the answer.
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1532
    • View Profile
Re: Movie Render crashes
« Reply #8 on: February 14, 2017, 07:46:28 pm »

Thanks for letting me know. These kinds of bug are difficult to find without being able to debug on the computer that has the problem.
Logged

slex

  • Jr. Member
  • **
  • Posts: 87
  • 3D-TV
    • View Profile
Re: Movie Render crashes
« Reply #9 on: February 16, 2017, 06:15:41 am »

I had similar problem with crashes during rendering in video format, solved it by rendering scene in pictures, then I join those pictures into a video with some other program.
No mater how long is the scene it renders every time at the first attempt, never had those crushes since that.
Logged