General Category > Anim8or v1.0 Discussion Forum

Sequence import bug

(1/1)

johnar:
Sequence import crashing if no figure is in the sequence file.
 All builds up to, and including, 1253 don't have a problem importing a sequence that doesn't have a figure referenced in the sequence file, but all builds from 1255 upward, including V1betas, will crash Anim8or, when trying to import a 'figureless' sequence.  8)  ;)

 

Steve:
I'm having trouble reproducing the crash. Can you send me a short example?

johnar:
 Hi Steve.
 Attached is a simple example, tested on both Windows 7 and windows XP.
 Hopefully you'll have the same results as described in the note within.
  Thanks.

 EDIT: Have just discovered, that just double clicking the file 'seq1ExpNoFig.an8' will open anim8or, followed immediately by crash.
 'seq1Exported.an8' opens properly when double clicked.
 The difference between the 2 files is:
 'seq1Exported.an8' is a sequenced exported with a figure, (working),
and 'seq1ExpNoFig.an8' is the same sequence, exported with NO figure. (not working)

Steve:
Thanks, that helps.  It shoul dbe fixed fro the next build.

#100-003 - Importing a Sequence that doesn't have a Figure crashes.

johnar:

--- Quote from: Steve on April 24, 2017, 06:26:28 pm ---Thanks, that helps.  It shoul dbe fixed fro the next build.

#100-003 - Importing a Sequence that doesn't have a Figure crashes.

--- End quote ---

Awesome. Thanks steve.
 This could solve the problem i've had with a few older files as well. In fact, i'm pretty sure of it.
 Thanks.

Navigation

[0] Message Index

Go to full version