General Category > Anim8or v1.0 Discussion Forum

Redraw failure + keyboard remapped on SAVE



While UV mapping a texture I needed to maximize Anim8or.
After maximizing, the viewport failed to redraw.  After returning to windowed mode it came right.

Around about the same time this happened, I also tried to save the project but when trying to enter a filename to save as, I found that my keyboard was giving the wrong chars.
eg. I would press the "-" key and get a single quote. The ";" key would give md something like an "a" with some sort of umlat decoration.

Note that around the time these issues appeared, I had also downloaded a couple of random textues, so this behaviour may be indicative of a virus rather than an actual Anim8or bug, but it would ne interesting to see if anyone else can replicate these issues.

Are you in point edit mode ore the base object modeler when this happens?
What OS and graphics chip do you have? See the About->SystemInfo menu command for this.

I can't reproduce it but that doesn't mean it is or isn't a bug in Anim8or ;)

I was adjusting texture alignment on selected faces at the time, so point edit mode.
(ie. the yellow UV tool was visible, however once maximized I couldn't get rid of it because none of the controls were clickable due to whatever the iossue was.)
OS=WIN7 SP1 64bit
Graphics= Intel HD4000 (integrated)

I can't replicate the problem now either, so I wouldn't worry too much about it Steve. Probably not a bug, but due to whatever was going on with my machine at the time (remember I also had those keyboard issues around the same time -- which have also not re-occurred).

I think it's safe to assume this is not a bug, but if it happens again I'll try to get a handle on the exact cause / circumstances, and I'll let you know.


OK if it recurs let me know.

Will do.

One thing I do recall is that at the time that this occurred, I had just discovered the alt-RMB function no longer worked and I was trying to find out (by trial and error) what key combination would de-select faces. So it may be possible that some random combination of CTRL / SHIFT / ALT and RMB caused this issue, as well as the issue with the diacritic characters on the keyboard (as both issues occurred around the same time).

I do think it more likely that whatever I did put the OS into some strange state, rather than Anim8or, but this might just give you an avenue to replicate it.



[0] Message Index

Go to full version