General Category > Anim8or v1.0 Discussion Forum

Trouble with the shell function


VERY happy to see version 1 released at last - I've been using Anim8or since 0.6... :)

One problem I'm having with the latest version is with the shell function. When I apply it to a single-sided object which has shelled fine in previous versions, random spikes appear (see attached screenshot). Some of the new vertices appear to have been created a long way off their intended position. Simple primitive shapes seem to be all right, but more complex ones are not; I haven't worked out what makes the difference. It happens on a range of machines, mostly Windows 7 with one Windows 10, and is still there in the latest 1.00b release. I can go back to 0.98 and the same object shells as it always has.

Before I raise this with Steve, I thought I'd check to see if anyone else had seen the problem?

I made some changes to the Shell tool to create more uniform thickness in the walls. I suspect that there might be an issue with that. Can you send me an example?

Thanks Steve! I've e-mailed an example to the support address.

EnglishBob I've posted a fix for this problem. There was a similar problem with the ExtrudeConnected command. This fixes

#100-014 - Shell and Extrude Connected commands can cause spikes.

Try this build 1309 out and let me know how it works.

I'll post more on what's going on tomorrow when I have more time.

That works for me! I hadn't had cause to use ExtrudeConnected yet on the 1.00 release, but I've tried that now and confirm that it also seems to be fixed - on a sample of one, anyway. :)

Thanks for the speedy fix!


[0] Message Index

Go to full version