Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: Problems rendering  (Read 2154 times)

Dosser

  • Full Member
  • ***
  • Posts: 104
    • View Profile
Problems rendering
« on: June 11, 2008, 05:13:38 am »

Hello all,

I'm having a lot of trouble getting rendering to work (in version 0.95), and am not sure if it is due to bugs or not. I have read the anim8or manual (section on scene mode), and I think I'm doing everything ok.

There are a few problems: firstly (and probably worst of all) the textures don't show. The textures work fine in object mode, so they should be there. I can't find any references to being able to disable / enable textures, so am currently assuming this is a bug (I blame Vista, perfect scapegoat for any weirdness in my experience ;) )

My other major issue is that my small local lights seem to be covering the whole model in their warm yellow glow. These lights should be basically candles (compared to the rest of the scene), and I have tried fiddling with their radius. Is there any other way to control the brightness of a light?

There are a few other things, but they seem to be genuinely my fault (not knowing how to insert background images / turn on antialiasing, manual seems to explain that stuff ok though). I haven't really used scene mode before, but think it is the right tool for the job and I want something a little better than the usual (in object mode -> render -> render image).

Thanks all
Logged

hihosilver

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1294
    • View Profile
Re: Problems rendering
« Reply #1 on: June 11, 2008, 06:10:14 am »

For the first one, try going "view>preferences" and check the 'textures' box in the File Output section.  If that doesn't work, I'm not exactly sure what your problem is.

As you said, fiddling with the radius can help.  To change the brightness, just drag down the slider on the right of the RGB hexagon.  Though it will seem like an incorrect color, the blacker a light is doesn't mean it casts black light, it means it has a lower brightness.  So if you want a yellow, choose a yellow in the RGB hexagon, then drag the slider down to lower the intensity of the light.

"Settings>Environment" should get you a step closer to background images/panorama's/cubemaps
You turn on antialiasing in the pop-up box when choosing to render an image.

Yes, scene mode will normally always do better than rendering simply in object mode.  The shadows and perspective of the camera add a very good deal of realism.  Also, you can add multiple objects and animate!
Logged

Dosser

  • Full Member
  • ***
  • Posts: 104
    • View Profile
Re: Problems rendering
« Reply #2 on: June 11, 2008, 10:57:22 am »

Thanks, gave it a shot. not sure I did the best render, but all the stuff you told me worked :D

http://www.anim8or.com/smf/index.php?topic=867.0
Logged