Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: ART v0.97b cubemap error  (Read 3116 times)

hihosilver

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1294
    • View Profile
ART v0.97b cubemap error
« on: June 13, 2008, 01:49:15 am »

Alright, here's my first error I'm posting here.  The rest I've been able to deal with, or other people have already addressed.
I've been trying to render my mustang model, but Anim8or continually crashes on me.  I believe it may have something to do with the cubemap, though it's tricky as it will occasionally work with different settings, but not with those I want.
I'm using the "specular>reflection" attribute in Anim8or.  The render seems to crash every time I use a cubemap in the scene.  Though, it has also not crashed on me a few times, once when I used a specular level of 0.4 instead of 0.2 for the material.  Also when I used a spec. level of 1.5.
At first I thought it had something to do with the model being only one poly thick, but after shelling, I still got the same error.
So I'm a bit stumped with this issue.
Here's the file with the Cubemap textures, I hope this can help!
hihosilver.anim8or.org/Mustang_crash.zip
Logged

$imon

  • Sr. Member
  • ****
  • Posts: 540
    • View Profile
Re: ART v0.97b cubemap error
« Reply #1 on: June 13, 2008, 07:57:20 am »

I got the same error on your file.. So, instead of using a cubemap as an environment I put a large sphere around the object, with a cubemap on it as environmental map.. that worked, as you can see in the attachment.

But when I tried to add a surface under the car, anim8or crashed again.. I'm not sure whats wrong

Plus, of course, the shadows are buggy :P
Logged

hihosilver

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1294
    • View Profile
Re: ART v0.97b cubemap error
« Reply #2 on: June 14, 2008, 08:38:59 am »

Thanks $imon.  I actually tried that as well, but for some reason it crashed then as well.  Though I had a big urge to get the cubemap working for some reason  :P
I'll give it another shot though, thanks for the help!
(You seem to have the top and bottom texture flipped btw  :P)

Still, I hope this issue can be addressed.

Edit:  I just registered what you said about adding a ground to the model.  Perhaps that was the problem with me doing the sphere.  My environment uses some sand that the car's resting on.  So my guess is that that's the problem.
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1520
    • View Profile
Re: ART v0.97b cubemap error
« Reply #3 on: June 14, 2008, 11:06:29 pm »

It looks like I broke environment-map backgrounds in v0.97b.  It doesn't crash for me but it doesn't show the background either.  I'm looking into it now.

#097-010 - Cubemap backgrounds crash

hohisilver, just curious, what graphics card do you have?  I think I've found the problem - it's an undefined variable - but it really shouldn't cause a crash.
« Last Edit: June 15, 2008, 12:25:11 am by Steve »
Logged

hihosilver

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1294
    • View Profile
Re: ART v0.97b cubemap error
« Reply #4 on: June 15, 2008, 12:25:13 am »

Yes, normally when I open the file, the cubemap doesn't show up.  So then I check the cubemap box again, or just re-pick the cubemap, then it selects for me... and crashes.
Thanks for the help.
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1520
    • View Profile
Re: ART v0.97b cubemap error
« Reply #5 on: June 15, 2008, 12:35:37 am »

The problem is an undefined variable - CubeMapOutOfDate.  If it's not set then the background won't be sent to OpenGL to draw.  Changing the settings in the dialog sets it to true ans it will then work.

Did you see my question about what graphics card you are using?  It really shouldn't crash, I think, just not draw.
Logged

hihosilver

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1294
    • View Profile
Re: ART v0.97b cubemap error
« Reply #6 on: June 15, 2008, 12:42:45 am »

Ah, I think I understand now :P  perhaps a bit.

Sorry, I missed the graphics card question.
I'm not sure if this is the right information, but the directX diagnostic says:  Mobile Intel(R) 945GM Express Chipset Family.
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1520
    • View Profile
Re: ART v0.97b cubemap error
« Reply #7 on: June 15, 2008, 10:31:01 pm »

Yes, that's the graphics chip info I wanted.  The Intel driver shouldn't have crashed - it should have simpley not draw the cubemap texture according to the OpenGL spec.  But I've fixed Ani8or so it will draw.
Logged

hihosilver

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1294
    • View Profile
Re: ART v0.97b cubemap error
« Reply #8 on: June 16, 2008, 08:53:29 am »

Thanks Steve.
You work wonders ;)
Logged