Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: Bug - Cameras & lights in 0.75b  (Read 2921 times)

Thanos

  • Full Member
  • ***
  • Posts: 104
  • -.-
    • View Profile
Bug - Cameras & lights in 0.75b
« on: June 19, 2008, 02:53:48 pm »

Hi. I found 2 bugs:
1)This bug was fixed for ART, but I now see this:

The camera and the light shouldn't be there. Rendered using Scanline.
2)ART shows me this (in the same scene, different angle):

There is an extra line at the bottom with the background color.
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1546
    • View Profile
Re: Bug - Cameras & lights in 0.75b
« Reply #1 on: June 19, 2008, 03:07:33 pm »

I believe that this is the same as http://www.anim8or.com/smf/index.php?topic=842.0.  What view are you using to render these images?
Logged

Thanos

  • Full Member
  • ***
  • Posts: 104
  • -.-
    • View Profile
Re: Bug - Cameras & lights in 0.75b
« Reply #2 on: June 19, 2008, 04:03:56 pm »

Hi Steve. It's custom view ("user 1"), I use the Arc Rotate tool.
I think that bug 1 is a bit different from that topic, the other one is about the camera shadow in ART renderer, this one is about the rendering of the cameras and lights in scanline. But I'm not totally sure :/
What about bug 2?
Logged

hihosilver

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1294
    • View Profile
Re: Bug - Cameras & lights in 0.75b
« Reply #3 on: June 20, 2008, 01:15:12 am »

Thanos, both times the camera should be rendered.  You're in the orthographic view.  In an ortho view, the scene should always render the camera.  The camera will not be rendered when you view it from another camera though.  The point of the ortho view is to rotate around your scene or model without the distortion of perspective.  Normally people render in the perspective view since it's realistically what's going to happen.
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1546
    • View Profile
Re: Bug - Cameras & lights in 0.75b
« Reply #4 on: June 20, 2008, 05:59:03 am »

Yes the bug is that the ART renderer doesn't show the camera in that view.
Logged

Thanos

  • Full Member
  • ***
  • Posts: 104
  • -.-
    • View Profile
Re: Bug - Cameras & lights in 0.75b
« Reply #5 on: June 20, 2008, 08:38:10 am »

 :D cool! I didn't know it! Thanks guys!
Logged