Anim8or Community

General Category => General Anim8or Forum => Topic started by: Zatnikitelman on November 17, 2008, 01:52:51 am

Title: Big time texturing problems-help needed.
Post by: Zatnikitelman on November 17, 2008, 01:52:51 am
First of all, Anim8or can't seem to handle BMP images though it indicates it can.
Second, I'm trying to build a rocket with the decal for the space agency on its upper part. When I apply the UV coordinates however, I get a reverse texture on the side directly opposite of the side I clicked the UV button on. I've ran though all the options, but can't find anything that would affect this.
Thanks for any help,
Zatnikitelman
Title: Re: Big time texturing problems-help needed.
Post by: rellik420 on November 17, 2008, 02:56:35 am
ur faces might be inside out. when u select ur faces and everything is blue. that means its inside out. u have to flip normals. and u can use bmp files
Title: Re: Big time texturing problems-help needed.
Post by: Francesco on November 17, 2008, 03:26:27 am
Everything is as it should be, you selected an object and you hit the UV tool. Now you just have to learn controlling that yellow-circle scale-rotate screen, and start texturing groups of faces instead of the entire object. As for bitmaps, some formats are supported and some aren't. The manual and searching the forum will help you.
Have fun
Title: Re: Big time texturing problems-help needed.
Post by: Zatnikitelman on November 17, 2008, 03:49:46 am
It still doesn't work. I select all the faces and hit UV and I still get the reverse of what I want on the other side of the cylinder. I use all the UV "clicks" (left mouse, right mouse, center mouse) and there's no way to get it right.
Title: Re: Big time texturing problems-help needed.
Post by: Maxfield on November 17, 2008, 06:07:22 am
It sounds to me like you may be applying a planar map to the side of the rocket. Try a cylindrical map instead. Select the rocket, press the UV button, then double-click the object. That will give you a choice of mapping layouts.

Better still, download a copy of UVMapper Classic or Lithunwrap. They'll give you more options for unwrapping.

As for the BMP texture, make sure it's 24-bit. AFAIK, Anim8or can't handle 8-bit textures. A quick fix would be to open the image in Windows Picture and Fax Viewer, then save as a JPEG.
Title: Re: Big time texturing problems-help needed.
Post by: Zatnikitelman on November 19, 2008, 08:03:02 pm
Double clicking in UV mode does nothing.
Title: Re: Big time texturing problems-help needed.
Post by: lynn22 on November 19, 2008, 10:29:12 pm
I would suggest that you go to Point Edit mode and select only those faces where you want the decal to appear and apply your material on those faces only, then click UV and put them in position. That way your decal will not appear on the reverse side of your rocket.

If all else fails, then follow Maxfield's suggestion and download an unwrapper and place your decal on the UV map in any graphics program.
Title: Re: Big time texturing problems-help needed.
Post by: Zatnikitelman on November 20, 2008, 03:28:40 pm
Already done both of that. Even if I just select the faces I still get two logos instead of just 1. Even using a UV unwrapper, it's still just a 30m tall by 5m diameter cylinder so there's nothing special there.
Title: Re: Big time texturing problems-help needed.
Post by: RudySchneider on November 20, 2008, 04:02:54 pm
Zatnikitelman ---
You should be able to select individual faces and apply separate textures, like this:

(http://img303.imageshack.us/img303/4994/multifacebox00009az.th.jpg) (http://img303.imageshack.us/my.php?image=multifacebox00009az.jpg)

If not, chances are you've done something wrong.  It may help if you explain what it is you're doing, exactly.
Title: Re: Big time texturing problems-help needed.
Post by: Zatnikitelman on November 30, 2008, 12:10:38 am
Sorry it's been so long, but I've been busy.
What it is is a simple cylinder 5m in diameter that I'm trying to stick a 512x512 pixel texture on. Specifically, this is for the Orbiter Space Flight Simulator. The texture is scaled so that when stretched onto the model it looks exactly right.
When I apply the texture either by selecting the cylinder object (not a mesh) or by selecting all faces (after conversion to mesh) I always get a left to right inverted image directly opposite of my view point.
The texture is simply the circular patch of the space agency I'm simulating on a orangeish background with no real details.
Title: Re: Big time texturing problems-help needed.
Post by: falloffalot on November 30, 2008, 12:16:51 am
Download UVMapper (it's free) unwrap it and apply what ever details you like in photoshop them apply it back in Anim8or. It takes a little longer but the results can be amazing.
Title: Re: Big time texturing problems-help needed.
Post by: xalener on December 02, 2008, 05:12:27 am
You don't need to do all that. It sounds to me like you've been using the drag select tool instead of the courser select.

When you Drag, you select all the faces on the other side of the mesh too. To avoid this, use the courser select and right click to add to your selection.
Title: Re: Big time texturing problems-help needed.
Post by: Zatnikitelman on December 03, 2008, 08:50:59 pm
I tried following the UVMapper tutorial best as I could, but I still don't get it. It says save your new OBJ, then Save out your texture map. When I bring the rocket back into Anim8or as an obj, will I just set the whole thing as having the texture map in 1 material? Are the individual mesh groups preserved?
Title: Re: Big time texturing problems-help needed.
Post by: Francesco on December 03, 2008, 11:12:54 pm
Zat, after following this topic a bit I came to the same conclusion of xalener. It really looks like you were selecting (and applying the texture) to more faces than you desire - I speak about where you try to texture individual faces, not about texturing all at once using a mapper.

Did you make sure that you're selecting only the faces you want to texture?

As I would do, first of all I would make sure that the faces I want to texture are exactly in front of me, rotating the view.
Then I would:
Click on "point edit" mode
Click on "face select" mode
Click on the "select" tool
Click on the first model's face I want to texture, using the left mouse button
Click on every other face I want to texture, using the right mouse button this time

Here, normally, I switch again to rotate-view mode and I make sure that only the interested faces are selected. Then I bring the selected faces in full view again and I exit the rotate-view mode.

Finally I click on the UV button, which presents me with the yellow circle of the texture tool, and there I arrange the texture by clicking with the various mouse buttons, either inside or outside of the yellow circle.

Hope that helps.

Edit:
Wait a moment... Lynn suggested just the same some posts above... did you try that Zat?
Title: Re: Big time texturing problems-help needed.
Post by: falloffalot on December 04, 2008, 01:51:03 pm
Post some screen shots Zat so we can get clear picture of what the problem is.
Title: Re: Big time texturing problems-help needed.
Post by: Zatnikitelman on December 04, 2008, 03:19:35 pm
Ok, the first picture "rocketfrontview" shows what happens after I've UV'd and scaled the texture in the front view.
In the second picture, I've used the view rotate (green circle) and am looking at the back of the rocket. Notice how the logo (stands for Civil Space Authority) is inverted left to right. The same thing happens even if I select the faces individually and apply to the faces!
Title: Re: Big time texturing problems-help needed.
Post by: floyd86 on December 04, 2008, 03:26:40 pm
Yes this happend to me ones, when i tried to apply a logo to a spaceship. The easiest way to fix this is to open you texture in a paint program and flip it to make a second material. Then apply this second texture to the back faces.
Title: Re: Big time texturing problems-help needed.
Post by: Francesco on December 04, 2008, 05:18:14 pm
You don't need to make a mirrored image, it's enough to select only the faces on the back, hit UV and rotate the texture till it shows in the right way. Do it by clicking and dragging one of those squares sideways of the yellow circle - this ensures that you rotate it only around the y axis.