Anim8or Community

General Category => ASL Scripts => Topic started by: headwax on July 19, 2009, 02:39:41 am

Title: Using export_obj_plugin.a8s
Post by: headwax on July 19, 2009, 02:39:41 am
Hello

http://www.anim8or.com/scripts/export_obj_plugin.a8s

Any tips on how to use this please. Hoping to manage to get an mtl file associated with an obj file.

Thanks in advance


headwax
Title: Re: Using export_obj_plugin.a8s
Post by: lynn22 on July 19, 2009, 08:02:29 am
Headwax, out of curiosity, what version of Anim8or are you using ?

I use 97c and when I export to obj I get a myfile.obj and a myfile.mtl in one sweep and when I import them in Vue nothing needs changing but some software specific texture adjustments.
Title: Re: Using export_obj_plugin.a8s
Post by: headwax on July 19, 2009, 08:30:50 am
Hya lynn22

Thanks for answering,

I am using .97d which mostly crashes when I export, if it doesn't (when the obj is very simple?)  I do get an mtl file pointing at the materials.

So when I export I go back to .96a. - and don't get an mtl file at all!

Neither with .95c :(

I'm "sure" it's a vista problem????

I'll hunt down verison .97c

I've probably got it somewhere.

3ds works fine except the meshes are triangulated when I import them into Carrara!

thanks again

Title: Re: Using export_obj_plugin.a8s
Post by: 3Dgeek11 on July 19, 2009, 11:25:21 am
97d does that to me, also. So I use 0.95 to do my OBJ exporting. But I don't know if it's a vista problem, anyway, I hope you find something that works!
Title: Re: Using export_obj_plugin.a8s
Post by: lynn22 on July 19, 2009, 01:39:22 pm
I am not familiar using Carrara therefore my question; is it a problem that your meshes are triangulated on import ?

Vue triangulates both obj and 3ds but so far it does not affect my project. With 1480 objects and 165,917 polygons so far - and not yet half-way done - rendering runs smoothly and fast on a dual-core.
Title: Re: Using export_obj_plugin.a8s
Post by: headwax on July 20, 2009, 08:32:43 am
Thanks 3dgeek

I see this gent's having similar problems http://www.anim8or.com/smf/index.php?topic=2470.msg18240;boardseen#new

Hya Lynn,

I do some tweaking in Carrara as it has soft select and the triangulated mesh seems much more complicated and dense unfortunately.

Makes it harder to tweak the uv's as well as Carrara has a tendency to be a bit screwy with them.

:(

Sounds like there aren't (m)any people who have found a need for this export plugin?

Title: Re: Using export_obj_plugin.a8s
Post by: Claude on July 20, 2009, 05:12:29 pm
I understand you have a problem with the Anim8or native obj
export.Not much,I can do about that.

I don't use the obj script,but I might be able to help
if you tell me what is wrong with it.
An example might be useful.I don't know.
If it's needed,make as small as possible.

Claude

Title: Re: Using export_obj_plugin.a8s
Post by: headwax on July 21, 2009, 08:14:42 am
Thanks Claude that's very kind of you!

I played with some simple stuff today. One sphere UV textured with one texture. No problems getting an ml file at all with obj export!

But when I load up a complicated scene with lots of textures it crashes - I realised that it's probably because an8 is not being able to acess all the textures - just as the person in that link above mentions.

Trouble I am having is that I have three computers with my textures spread around, and even though irt appears I have all the textures available on a mesh (because the materials in the materials list are all correctly coloured - not that rainbow orange and green colour), I have been missing out on my bumpmaps and spec maps etc - which perhaps dont show up as missing in the materials list. ?????

I think this is the problem - all my fault because I have not been a good housekeepr over the last few years as far as texture direcoried go :(

So I will work though that and If I still have problems will take you up on your kind offer.



cheers for now

headwax :)