Anim8or Community

General Category => Anim8or v0.98 Discussion Forum => Topic started by: Steve on October 02, 2013, 09:55:37 pm

Title: New preview with XP fix ready: v0.97f
Post by: Steve on October 02, 2013, 09:55:37 pm
I just uploaded a new Anim8or (v0.97f) with the following fixes:

- Fix 097e-101 - Incompatible with Windows-XP.
- Fix 097e-102 - Requires MSVCR110.DLL to run.
- Fix 097e-103 - Add edges to a mirrored object when the end point is an axis point duplicates the point.
- Fix 097e-104 - Select orphans can leave on point unselected.
- Fix 097e-105 - Viewing OpenGL info crashes.
- Fix 097e-106 - Adding edge as new mesh (shift-click-drag) crashes.
- Fix 097e-107 - Add Windows Vista, Windows 7 and Windows 8 to OS Information dialog.
- Fix 097e-108 - Knife tool does not cut all the way on the mirrored side, when starting from a point.
- Fix 097e-109 - UVs do not get mirrored when using the Texture UV tool.
- Fix 097e-110 - Mirrored Mesh: Subdividing a face of a mirrored mesh in the point editor crashes.
            (Was: When manipulating the added mesh data within a subdivided face
             (Edit->Subdivide Faces), erroneous results occur.)
- Fix 097e-111 - Subdivision Mesh: When 0 working divisions, stays non-shaded when in point edit mode,
   regardless of shading mode.
- Fix 097e-112 - Materials: If the specular and emissive factor isn't change from the default,
  then it doesn't get saved in the .an8 file even when a texture is applied to that channel.
- Fix 097e-114 - Add Edge tool: Starting a new mesh with the Add Edge tool (by shift-click-dragging) causes crash.
- Fix 097e-115 - Convert to Mirror: Edges not in faces are lost when converting a Mesh to a Mirrored Mesh.
  Also added automatically convert parametric objects into a mesh.
- Fix 097e-116 - User Interface: Vertical Resize Bar: Behaves erratically when click-dragging it.
- Fix 097e-117 - Sequence data fails to save: Sequences save as empty keyframes in the file.
- Fix 097e-118 - Sequence data from older versions fails to reload properly.
- Fix 097e-121 - Splash Screen: Mode->Object comand crashes when initial project is loading.

I have not fixed these known issues yet but I am working on them:

#097e-113 - Bevel tool: destroys UVs of surrounding faces.
#097e-119 - Morph Targets: Do not work with Mirrored Meshes.
#097e-120 - Background images: Appear dark in the workspace and when using the opengl renderer.

There are also a couple of minor new things:

- Add option to restore window position in next session.
- Enhance face properties dialog to show more information.

You can download a copy here:

Anim8or v0.97f XP Compatible Preview (http://www.anim8or.com/download/preview/files/anim8or_v097f_preview.zip)

!!!!!!!!!!! I fixed the link (again!) My web-site editor and I don't always agree on where files should be :)  !!!!!!!
Title: Re: New preview with XP fix ready: v0.97f
Post by: johnar on October 03, 2013, 12:27:12 am
(http://s23.postimg.org/zaoogxv9j/BGwavegry.gif)  Hi there Steve.
 Downloaded and opened on XP. Had a quick play around. So far so good. Awesome!!
Man you've been busy. This is beyond Gr8. Thank you, thank you, thank you, very very much.
 Can't wait to get some projects happening with v0.97f.
 Massively Awesome.  (http://s8.postimg.org/j64xwcx9d/Big_Grin_Gry.gif)
Title: Re: New preview with XP fix ready: v0.97f
Post by: Raxx on October 03, 2013, 01:08:28 am
Hey Steve, thanks for the hard work!

Couple of bugs:
Title: Re: New preview with XP fix ready: v0.97f
Post by: headwax on October 03, 2013, 06:24:54 am
thanks Steve, muchos gracias :) as we say in Oz.
Title: Re: New preview with XP fix ready: v0.97f
Post by: Steve on October 03, 2013, 09:10:02 pm
Raxx, do you have shaders enabled?  If so this explains the lack of flat shading.  This is a known issue.

The double opaqueness occurs because both the mesh and it's controlling shell are drawn.  For a subdivision of 0 they are the same surface.  I'll see if I can find an easy way to fix this.
Title: Re: New preview with XP fix ready: v0.97f
Post by: Steve on October 03, 2013, 09:13:27 pm
headwax: Hey, I didn't know that muchos gracias was auzzie talk  :)

johnar: I'm relieved to finally get XP working. MS is such a pain - they're trying to kill it even though half of the Windows computers users still prefer it.
Title: Re: New preview with XP fix ready: v0.97f
Post by: headwax on October 04, 2013, 04:11:27 am
headwax: Hey, I didn't know that muchos gracias was auzzie talk  :)


ha hah, we like to keep our special talk to ourselves but occasionally out it escapes :)
Title: Re: New preview with XP fix ready: v0.97f
Post by: Raxx on October 04, 2013, 03:23:29 pm
Raxx, do you have shaders enabled?  If so this explains the lack of flat shading.  This is a known issue.
Whoops

The double opaqueness occurs because both the mesh and it's controlling shell are drawn.  For a subdivision of 0 they are the same surface.  I'll see if I can find an easy way to fix this.
I figured as much, but I didn't like it compared to the original opacity so I thought it was worth a mention.
Title: Re: New preview with XP fix ready: v0.97f
Post by: Thanos on October 05, 2013, 08:32:13 pm
Working on win7 and Fedora 17 with wine. Thanks a lot, Steve, glad to see you back.

I noticed some bugs with the smooth-flat-wire buttons (maybe related to Raxx's bug?). I have shaders enabled:
- win7: Flat doesn't work, shows smooth instead
- linux: Tried rolling between smooth-flat-wire buttons a couple of times, and noticed a per-button lag: ie. pressed smooth, then pressing flat activated smooth, then pressing wire activated flat, then pressing smooth activated wire etc.
...hope this helps (TM)
Title: Re: New preview with XP fix ready: v0.97f
Post by: Steve on October 05, 2013, 09:16:13 pm
OK I'll look into flat shading and the double transparency a bit more to see if I can improve things.
Title: Re: New preview with XP fix ready: v0.97f
Post by: Claude on October 07, 2013, 12:51:30 pm
Options/Debug/Morph Normals
If this allows morph normals to be exported to the file,then it doesn't work in version e and f.
If it's something else, it would be nice to know
so that I could add morph normal output to the
feature request list.
Title: Re: New preview with XP fix ready: v0.97f
Post by: ianross on October 07, 2013, 01:17:51 pm
Bug report, firstly thank you Steve, it opens up in XP. In the scene mode when I tried to render a two sided material i.e a 2d render  version 0.97f shut down.
I used scanline renderer.
Title: Re: New preview with XP fix ready: v0.97f
Post by: Steve on October 08, 2013, 03:35:09 am
Thanks, Claude and ianross.  I'll look into these.
Title: Re: New preview with XP fix ready: v0.97f
Post by: kreator on October 11, 2013, 03:54:24 am
try this link, I`m getting a 404 Error now on the original link

[Steve] I fixed it (again!) Sorry about the problems, everybody. Here's the new place:

Anim8or v0.97f XP Compatible Preview (http://www.anim8or.com/download/preview/files/anim8or_v097f_preview.zip)

Note: I also deleted several messages about the broken link so this topic will be easier to read.
[/Steve]
Title: Re: New preview with XP fix ready: v0.97f
Post by: SubDrag on October 12, 2013, 08:16:03 pm
Not sure if supposed to report bugs here, but, one of the bigger problems I have, is certain bitmaps will open in anim8or. But when you export to .obj, bam anim8or crashes.
Title: Re: New preview with XP fix ready: v0.97f
Post by: kreator on October 12, 2013, 08:55:56 pm
The built-in obj .export always crashed in 0.97D, and continues to do so with 0.97e and 0.97f I think its because it does not write an mtl file.


 If you look in the ASL script database, http://www.anim8or.com/smf/index.php/topic,1705.0.html (http://www.anim8or.com/smf/index.php/topic,1705.0.html) you should see under Export Scripts one for Wavefront.obj files. you can install this into your plugins folder and it will work it`ll even export a decent mtl file as well!


I always use this plugin now for .obj files
Title: Re: New preview with XP fix ready: v0.97f
Post by: SubDrag on October 12, 2013, 10:10:27 pm
I can get some obj/mtls to export fine in anim8or's obj export, it's just some bitmaps, for example 4-bit, and some random ones, crash on export.  It seems to crash on export if a bitmap is not "valid"?
Title: Re: New preview with XP fix ready: v0.97f
Post by: Steve on October 14, 2013, 07:20:25 pm
Oops!  Sorry about that, SubDrag! Everything should be OK now.  I updated the link in the top topic and added it here as well:

Anim8or v0.97f XP Compatible Preview (http://www.anim8or.com/download/preview/files/anim8or_v097f_preview.zip)

Title: Re: New preview with XP fix ready: v0.97f
Post by: Steve on October 31, 2013, 05:01:04 am
SubDrag, can you send me a .an8 project that shows the bitmap export bug (along with the bitmsp)? I'm having trouble reproducing this.
Title: Re: New preview with XP fix ready: v0.97f
Post by: daniel99 on November 11, 2013, 03:03:06 am
Glad to see the update :D

But there's still some problems when renaming the bones. It crashes.

Also, when do you think you can activate the IK button ?
Would be very useful to have the Ik function in scene mode also...
Title: Re: New preview with XP fix ready: v0.97f
Post by: Steve on November 13, 2013, 07:54:03 pm
daniel99 I can't reproduce this crash.  Can you send me a project and instructions on how to reproduce it?
Title: Re: New preview with XP fix ready: v0.97f
Post by: SubDrag on November 18, 2013, 05:18:16 am
Sorry for the delay in response.  I can't seem to recreate the crashing, it must have been fixed in v.97f or I lost my crashing files. If it happens to me again, I'll post it.

However, I kindly request the support of two other kinds of bitmaps (4-bit and 16-bit). I don't care as much about the 16-bit, but 4-bit is a common format and would be very helpful if could read it! Here are two samples:

http://goldeneyevault.com/priv/showerhead_4bit.bmp      - 4 bit
http://goldeneyevault.com/priv/9A4B61w20h200x34COLORS.bmp       - 16 bit
Title: Re: New preview with XP fix ready: v0.97f
Post by: daniel99 on November 22, 2013, 08:57:05 am
Hey, Steve. Here's a video screen capture. I have the figure placed in the scene. Then, I move to the figure mode, and renaming the Torso bone. If I change back to the scene mode, it crashes.

youtube.com/watch?v=mWYq1pcbuaY[/youtube]]http://www.
(http://www.[youtube)

I also hope you will answer my questions:
1. Is there a chance to make the IK available?  ::)
2. Is there a way to lock the feet bones, and be able to move the character using the root, the feet remaining locked ?  I think this would need the IK to be active ?

Thank you.