Anim8or Community

General Category => General Anim8or Forum => Topic started by: JSmith_DumDumDumDumDum on February 10, 2014, 07:24:53 pm

Title: texture problem with cube
Post by: JSmith_DumDumDumDumDum on February 10, 2014, 07:24:53 pm
Hello! How is everyone doing? I am your newest addition to the community.

I started using Anim8or a few days ago. Have a few project for TheSims 1 to create. haha

I've learned how to apply textures to objects through the material button, but a problem arises when I try to apply it to a cube (And perhaps some other hedrons?): The texture shows up nicely on the x and -x faces but is stretched to stripes on the other faces. I would like the texture to show up on all faces, but don't know how.

The anim8or guide mentioned the "face edit" tool, but I'm not sure how to use it, since, when I'm in the mode, it won't even let me select any object; nor am I sure if it's necessarily the tool to use to fix this problem.

Thanks greatly for your help!

JSmith
Title: Re: texture problem with cube
Post by: captaindrewi on February 10, 2014, 08:22:08 pm
Select a face and use the uv tool.
it's a basic uv tool but is what you're after at the moment i think.
Title: Re: texture problem with cube
Post by: Raxx on February 10, 2014, 09:40:38 pm
The stretches are the default UVs for the cube, so yes, you have to go into point edit mode and select each face and individually remap them. However, the cube is a parametric shape, not an editable mesh. So select the cube and go to Build->Convert to Mesh. Then you can do the editing you need.

Alternatively, you can use the UV Block script located in the ASL Scripts thread (http://www.anim8or.com/smf/index.php/topic,1705.msg12723.html#msg12723), which creates a cube that has proper UVs for each side.
Title: Re: texture problem with cube
Post by: captaindrewi on February 11, 2014, 12:36:16 am
UV block link seems dead.
Title: Re: texture problem with cube
Post by: cooldude234 on February 11, 2014, 12:40:52 am
Raxx got to it before me :P
My suggestion is the same as his
(shameless credit stealing   ;D )
Title: Re: texture problem with cube
Post by: JSmith_DumDumDumDumDum on February 11, 2014, 04:11:10 am
Thanks for the responses and resource, guys!  :) :)


Title: Re: texture problem with cube
Post by: JSmith_DumDumDumDumDum on February 13, 2014, 08:22:03 am
So, this evening, I ran into a new problem: lighting.

Looking at the most recent variant model that I'm working on, one can barely tell the dimensions that are applied to the borders of the chessboard: The red eretria inner border is supposed to be higher than the checks but shorter in height than that of the azulcielo outer border. Can you tell?

I realized that applying lighting to the different faces of these figures would solve this problem. is there such a feature in anim8or?

Thanks again.

Title: Re: texture problem with cube
Post by: captaindrewi on February 13, 2014, 12:41:29 pm
You need to be in scene mode to use the lighting and shadows.