Anim8or Community

General Category => Anim8or v0.98 Discussion Forum => Topic started by: SubDrag on April 15, 2014, 01:29:36 am

Title: Skinning crashing in scene mode
Post by: SubDrag on April 15, 2014, 01:29:36 am
I have been unable to get skinning to work in Scene mode.  In my normal model, if I turn on "Enable Skinning", by double clicking in Figure mode. Then go to Scene it crashes.  In the simpler test I attached, it oddly doesn't crash as soon as go to Scene mode with skinning on, but then if go back to figure it crashes.   Something seems broken with skin mode. 
Title: Re: Skinning crashing in scene mode
Post by: Steve on April 15, 2014, 05:47:39 am
Thanks, I'll take a look at it.
Title: Re: Skinning crashing in scene mode
Post by: SubDrag on April 15, 2014, 03:50:02 pm
After reading the help, looks like the issue was assigning multiple objects to different bones.  I guess the real issue is crashing, instead of probably getting an error box or not letting do that in first place.  And I guess a second thing, is, probably intentional but can't assign objects to root node (instead need a 0 length bone attached to root).  It might be intentional.
Title: Re: Skinning crashing in scene mode
Post by: Steve on April 15, 2014, 11:26:03 pm
Crashes are bad. Must Get Rid Of Crashes! :)  Yes, you can't attach objects to the root bone.
Title: Re: Skinning crashing in scene mode
Post by: RudySchneider on April 16, 2014, 02:34:42 am
Steve ---
I don't know if you're a fan of Southpark, but I couldn't help but think of Mr. Mackey just then...

"Crashes are bad, mmmm-kay?  So don't do crashes, mmmm-kay?"
Title: Re: Skinning crashing in scene mode
Post by: Steve on April 17, 2014, 10:20:01 pm
I think I have this fixed. I'll post a new update in a few days for you to test.
Title: Re: Skinning crashing in scene mode
Post by: SubDrag on April 17, 2014, 11:15:53 pm
Sounds good! Thanks.
Title: Re: Skinning crashing in scene mode
Post by: Steve on April 19, 2014, 04:07:57 am
The new update is ready - see the  Ongoing Anim8or Development (http://www.anim8or.com/smf/index.php/board,7.0.html) forum for details :)
Title: Re: Skinning crashing in scene mode
Post by: SubDrag on April 19, 2014, 02:35:09 pm
Checks out, appears to be fixed, thanks!
Title: Re: Skinning crashing in scene mode
Post by: Steve on April 20, 2014, 05:14:59 am
Thanks for the bug report - it helped make Anim8or better :)