Anim8or Community

General Category => Anim8or v1.0 Discussion Forum => Topic started by: kreator on May 06, 2017, 11:08:14 am

Title: Movie Mode Crashes
Post by: kreator on May 06, 2017, 11:08:14 am
Scanline and ART movie modes crash Anim8or V.1.0 Beta 1 & 2 after the first frame render. OpenGL though, works perfectly for the 71 frames that I tested.
Title: Re: Movie Mode Crashes
Post by: Steve on May 06, 2017, 04:10:24 pm
Can you give me some more details, such as image size, AA, what codec you are using, etc.?
Title: Re: Movie Mode Crashes
Post by: kreator on May 06, 2017, 05:34:45 pm
Hi Steve using ART renderer , AntiAliasing 16 samples regular, Movie ,jpg @90 750 x 450 all frames Xvid codec...Crash. :(


Will not work in any other mode apart from OpenGL which renders out all the frames.
Title: Re: Movie Mode Crashes
Post by: Steve on May 06, 2017, 06:26:46 pm
Are you trying to render a simple scene or a complex one? Can you try smaller image, different codes, not using AA, etc. to see if anything else works?  Also what OS? are you using
Title: Re: Movie Mode Crashes
Post by: kreator on May 10, 2017, 06:30:20 am
TBH it is a Complex scene and I expect Anim8or cannot cope with the additional moving object ( Using the splash screen project) I tried another project I had and it rendered OK
Title: Re: Movie Mode Crashes
Post by: Steve on May 10, 2017, 05:45:53 pm
I suspect the cause is running out of memory. Try turning off Fast-AA in the Renderer->AA-Setup dialog. It uses a lot of memory, something I'm working to reduce.

Note: you have to have the ART renderer selected to see the proper dialog.
Title: Re: Movie Mode Crashes
Post by: kreator on May 19, 2017, 04:17:54 pm
Finally got it working, none of my machines would play ball when I tried to render with ART, even after disabling fast render.

Then it dawned on me! what was using up all the memory ?

All the ASL extras I had in the menubar, Switching them all off made it possible to do


Title: Re: Movie Mode Crashes
Post by: Steve on May 19, 2017, 04:53:47 pm
Cool! That'd make a great animated splash screen :)
Title: Re: Movie Mode Crashes
Post by: ronaldefarmer on May 20, 2017, 12:39:28 am
Amazing work, Kreator!