Anim8or Community

General Category => Anim8or v1.0 Discussion Forum => Topic started by: Gyperboloid on July 21, 2017, 11:21:51 pm

Title: Copy past issue. World-object coordinates issue
Post by: Gyperboloid on July 21, 2017, 11:21:51 pm
Just some bugs ( tiny  :D) as I remember were there from the 0.97d version ( wich was the first I used and the most here used for a long time). The first is about the copy past command of an item no matter is a mesh or parametric or whatever. I don't know actualy it's a bug or on intence, but when you copy a mesh and past it second time on a row ( the first is ok as it should be, on the exact position as the original ) its new location is kind of higher on y axis and farther on the +x axis. If you keep past it the new copies keep going higher. Maybe I do it wrong way, but when I copy past things usually I want to move them on an axis which meens I want them to automaticaly past on the same location with the original one.

Another one is the world coordinates moving command isuue where the Y axis and the Z axis are reversed. Which means in world coordinates with the left mouse button the object should be moved up and down while with the right mouse button front and back. But the opposite happens: LMB for Z axis RMB for Y axis, which is incorrect. The rotation in world coordinates works right though.Only the "move" command.

And the last one is the object coordinates which do the same thing as the world coordinates, no matter how the axis/pivot of the object is rotated. If the pivot is rotated some amount in pivot axis editor shouldnt in object coordinates the object moving in direction of its edited axis and not as if theworld coordinates were selected?
Title: Re: Copy past issue. World-object coordinates issue
Post by: Steve on July 23, 2017, 11:51:52 pm
Gyperboloid: Thanks for the post.

1. The paste operation offset is intentional. It adds the first copy in the original location, then offsets each new paste in the X and Y axis. I did this because it isn't easy tell if you accidentally pasted more than one copy.

2. This is a bug. You shouldn't be able to move in the World-Y Z direction when only the Y axis enabled.

3. This is also a bug. The result should be as you expected.

I'll fix these :)
Title: Re: Copy past issue. World-object coordinates issue
Post by: Gyperboloid on August 02, 2017, 06:25:43 pm
Woh, thanks.
About the paste operation , as I wrote, I thought it could be intentional and for exact reason you described.  :)
That object coordinates was always handy but never available, so it will be superb if it can be usable.
As for Y-Z axes in world coordinates notice that the main bug is the Y-Z reverse, which happens even if all axes are active. Though having Y axis active only and still being able to affect object in Z axis may be another bug itself. Anyway, you know better :)

Gyperboloid: Thanks for the post.

1. The paste operation offset is intentional. It adds the first copy in the original location, then offsets each new paste in the X and Y axis. I did this because it isn't easy tell if you accidentally pasted more than one copy.

2. This is a bug. You shouldn't be able to move in the World-Y Z direction when only the Y axis enabled.

3. This is also a bug. The result should be as you expected.

I'll fix these :)

About the paste operation , as I wrote, I thought it could be intentional and for exact reason you described.  :)
That object coordinates was always handy but never available, so it will be superb if it can be usable.
As for Y-Z axes in world coordinates notice that the main bug is the Y-Z reverse, which happens even if all axes are active. Though having Y axis active only and still being able to affect object in Z axis may be another bug itself. Anyway, you know better :)


Ahh, Steve! I realized that it could be intentional as well! In perspective view, in scene mode especialy, by the LMB only, while World coordinates enabled, user can "slide" an object on the ground ( X-Z plane ). And that's because the LMB in the up n' down movement affects the Z-axis in World coordinates, though normaly it should affect the Y-axis. If it will affect the Y -axis ( and the RMB the Z-axis and not the Y-axis as it does now, in World coords always ) user will be able to "slide" an object in Y-X plane  by the LMB. Which would be handy if someone would like to "hang " a picture on a wall though  :D .Finaly it only takes to remember that in world coordinates the Y-Z axes are reversed I think.
P.S.: I tested that in the first version of Anim8or originaly posted on September 20, 1999   :)  And it worked as supposed : in World Coordinates LMB for Y and X axes , RMB for the Z axis. And in Object Coordinates ( after a twik on objects pivot ) it also worked as should be. Though after a second ( and I opened before and after the v. 1.0 also ) it turned to have the same behavior as v. 1.0. again. Weird ,but funny.
Title: Re: Copy past issue. World-object coordinates issue
Post by: Steve on August 07, 2017, 03:07:53 am
I just about have a fix ready for the rotation issues. I still need to QA it. I've pretty much rewritten the code. I'll post an update soon.
Title: Re: Copy past issue. World-object coordinates issue
Post by: Gyperboloid on August 15, 2017, 06:20:03 pm
Steve !!! In the new built v.1.0 a  the rotation in the Object Coordinates works perfectly !!! Nice. But it seems to ignore the move command in Object Coordinates and  still has the behavior like in the World Coordinates. I downloaded the file in CoriDavis's post about Object Axis issue, was kind of  not an official built release though ?  ???
And another thing, maybe I can write it here so I wont start yet another topic. I noticed from the build 1152 ( the one I have just before that is the 1146 and it doesn't have that feature, I don't have the in-betweens) , as I remember it's when you changed the way x-y-z buttons were enabled, in Point Editor was added a new super cool way of selecting faces-edges-points. When you use hot keys x-y-z or in tool bar "Component" section, every time one type of elements ( faces-edges-points ) can be selected. When you select an edge then just hit "faces only selected" ("g") and every face to that belong that edge will be selected. The same works in opposite, like from faces to points, select a face, hit "v" and the vertexes of the face will be selected. In addition to the "Grow face selection", "Invert selection", "Select all", " Select face edges" ( this one still works, hot key "t", but removed from Edit Select menu  :P )" Quad Ring and Loop select" and other the selecting possibilities are huge.
But, with the official reales of v.1.00  you removed that possibility . Was all that intentional ??? Don't know what others think about it though.
Title: Re: Copy past issue. World-object coordinates issue
Post by: nemyax on August 16, 2017, 06:23:41 am
Gyperboloid
Steve made selection conversion an option in the release. Go to File | Configure UI and enable Extend PFE Selection.
Title: Re: Copy past issue. World-object coordinates issue
Post by: Gyperboloid on August 16, 2017, 11:08:46 am
Wow, nemyax, thanks! It works! I saw that option back then, but couldn't understand what it was for, since I guess didn't give attention on the new p/e/f selection announce. And actually there's a reason I didn't understand this option in File Menu, since when I checked it, it didn't stay checked after I hit Ok. Though there was a result, but I couldn't see it. But still, it doesn't stay checked when I open the UI Configuration , the box is unchecked, so if I want to disable the extended PFE Selection I have to check the empty box again, then ucheck it and only then press OK to close the dialog window. I don't know if it's a tiny bug or it's my computer's glitch.

Just figured out, that not only every time I open the Configure UI dialog the box on Extend PFE selection is uncheked, but in some manner the Solid View Smooth Points option seems to get randomly enabled-dissabled, while the PFE selection in the work space get dissabled too. ???
Title: Re: Copy past issue. World-object coordinates issue
Post by: Trevor on August 16, 2017, 11:09:43 am
To be honest, it took me a while to work that one out too.

Trev
Title: Re: Copy past issue. World-object coordinates issue
Post by: Steve on August 20, 2017, 10:03:23 pm
There was a bit of a discussion on how this should work - some people liked it the to grow the selection and others not. So I made it an option (http://www.anim8or.com/em/johnar/smile.gif)
Title: Re: Copy past issue. World-object coordinates issue
Post by: Steve on August 22, 2017, 09:50:14 pm
Gyperboloid:
Quote
But it seems to ignore the move command in Object Coordinates and  still has the behavior like in the World Coordinates.
You're correct, the move command uses World coordinates when Object coordinates are selected. I checked earlier releases, including v1.0, and they do the same thing. I'll fix it.

#100-013 - Object/Move command uses World coordinates when Object coordinates are selected.
Title: Re: Copy past issue. World-object coordinates issue
Post by: Gyperboloid on August 23, 2017, 01:24:19 pm
Sweet, Steve !!! Though you should check it not from the v.1.0 but form v.0.1 , since this issue was there like always. It was the first thing I noticed since I discovered Anim8or . :) Cool !
Now just some tiny other things, since I don't feel would be a good idea to create more topics just about them and since there's  going kind of a discussion here about relative tools ( commands ) :

1) Why in "Component selection"  in the right toolbar "points" ("p"-hotkey) were renamed to "vertexes" ("v"-hotkey), since everywhere in edit menu there are "point - commands " and not "vertex commands".

2) Maybe the most unimportant thing : ( hotkeys do their job right so we don't touch them ) in p/e/f component selection again, with the use of LMB one item only is selected, while the previous is deselected. With the RMB you add to selection or deselect an already selected item while other not affected ( see deselected ). But , say you have only edges selected, if you click on them with RMB which deselect a selected item , the selection " jumps " on points ( vertexes ) . Whouldn't it be more logical if you click on only selected item with RMB it would do nothing as if you click on the only selected item with LMB ( though "doing nothing" is not exatly correct, since it deselect and select again the same component, right ? ). In other words the command ( RMB ) will " see" that there are no other components selected and it won't deselect the selected one. Just to keep thing as " clean" as possible, though as I said, that's not a bug, so see it as the most low priority.

3)
There was a bit of a discussion on how this should work - some people liked it the to grow the selection and others not. So I made it an option (http://www.anim8or.com/em/johnar/smile.gif)
Wow, nemyax, thanks! It works!... But still, it doesn't stay checked when I open the UI Configuration , the box is unchecked... I don't know if it's a tiny bug or it's my computer's glitch.

Just figured out, that not only every time I open the Configure UI dialog the box on Extend PFE selection is uncheked, but in some manner the Solid View Smooth Points option seems to get randomly enabled-dissabled, while the PFE selection in the work space get dissabled too. ???
I figured out how it behaves exactly. It seems that the " Extend PFE ( why PFE and not PEF :) ) selection " show ( and actually gets ) unchecked everytime the " Configure UI " dialog is called. Though Anim8or remembers  every other box settings status as I leave them, even after programm being closed. It happens no matter right after Anim8or start up, in the middle of the session, in other words not affected by other manipulations. Second to that it seems ( actually is ) the " Smooth point " visibility in " Solid views " in " Configure UI " always,  follows the status of the " extend PFE selection " . If I ckeck the " extend PFE selection " box while leave unchecked the " Smooth points " and hit OK, next time I open the dialog again, the " extend PFE selection " will be unchecked but the " Smooth points " checked. And now if I hit OK as is, next time I will open the " Configure UI "  both will be unchecked, the " extend PFE selection " because it gets so always and the " Smooth points " because it fallows the PFE status. Though that is something that happens to me and only if others can verify the same behavior on their systems it can be called a bug.

4) In the same dialog window there's an option about Anim8or color scheme. Since I don't think some will disagree that the new theme is awsome  8) , is there a need for that extra option in the Configure UI dialog ? Now if there would be kind of a choise to set a user color  :P , though the grey is the best for the eyes and why to " play " with colors in that manner doesn't seem clear. Others thoughts needed.
Title: Re: Copy past issue. World-object coordinates issue
Post by: nemyax on August 23, 2017, 01:46:43 pm
Why in "Component selection"  in the right toolbar "points" ("p"-hotkey) were renamed to "vertexes" ("v"-hotkey), since everywhere in edit menu there are "point - commands " and not "vertex commands".
The hotkey was changed to v so that you can switch to any component type effortlessly with your left hand.
Title: Re: Copy past issue. World-object coordinates issue
Post by: Steve on August 23, 2017, 06:37:52 pm
Gyperboloid:

1) --- What nemyax said :)

2) RMB toggles the V E F enable that you click on. If only one is enabled and you toggle it off then there is nothing left enabled (which is kind of useless, or so I thought) so Anim8or enables V.

3) This is a bug - the box should be checked accordingly. The setting is currently saved in the registry so that when you restart Anim8or it is remembered. However the dialog sets the value of "Smooth Points" instead of "Extend PFE Selection", so when you open the dialog and exit with "OK" the setting is cleared and "Smooth Points" gets the old value, unless you have re-checked everything. I'll fix this.

3A) What do you think about changing PFE to VFE in the dialog to be consistent with the hot-keys.

4) I preserved the old color scheme because some people like it better.
Title: Re: Copy past issue. World-object coordinates issue
Post by: Trevor on August 23, 2017, 10:12:51 pm
I am one of those "Old Colour" users as I find the new one odd, I'm just used to seeing an8 in blue.

Yes, lets change PEF to VEF, that should alleviate some confusion around "point" and "Vertex" (Gyperboloid: the Plural of Vertex is Vertices although I too have been know to use the incorrect Vertexes before)

Agreed on Steve's point2

Trev
Title: Re: Copy past issue. World-object coordinates issue
Post by: selden on August 24, 2017, 10:11:55 am
Some of us with older eyesight prefer the older color scheme because it has higher contrast than the newer one.
Title: Re: Copy past issue. World-object coordinates issue
Post by: nemyax on August 24, 2017, 11:25:27 am
What do you think about changing PFE to VFE in the dialog to be consistent with the hot-keys.
I'd suggest changing this to "Extend selection when switching to points, edges or faces" or something like that. "PFE" and "VFE" are unclear and sound like chemical initialisms.
Title: Re: Copy past issue. World-object coordinates issue
Post by: Gyperboloid on August 24, 2017, 04:28:40 pm
What do you think about changing PFE to VFE in the dialog to be consistent with the hot-keys.
I'd suggest changing this to "Extend selection when switching to points, edges or faces" or something like that. "PFE" and "VFE" are unclear and sound like chemical initialisms.

Well, right on the top of it there's the definition of PFE ( or VFE ) - " Points, Edges, Faces " so should not be that unclear. Though, " Extend selection when switching to points, edges, faces" sounds good , maybe even " Extend selection when switching between points, edges, faces ". But don't know if this will fit in the dialog window. May look kind of odd if there'll be a whole paragraph to click on . : )

Well, couldn't imagine that a lot would prefere to stay with the old color scheme, so then there's a good reason to leave it as is.


Gyperboloid:

1) --- What nemyax said :)

2) RMB toggles the V E F enable that you click on. If only one is enabled and you toggle it off then there is nothing left enabled (which is kind of useless, or so I thought) so Anim8or enables V.

3) This is a bug - the box should be checked accordingly. The setting is currently saved in the registry so that when you restart Anim8or it is remembered. However the dialog sets the value of "Smooth Points" instead of "Extend PFE Selection", so when you open the dialog and exit with "OK" the setting is cleared and "Smooth Points" gets the old value, unless you have re-checked everything. I'll fix this.

3A) What do you think about changing PFE to VFE in the dialog to be consistent with the hot-keys.

4) I preserved the old color scheme because some people like it better.


1) Actually, originaly what is the exact name of points ( vertices - Trevor ;) ) in 3D CG ? If it's "vertex" and not " point", then it should be called as so everywhere inside Anim8or, including all commands all settings e.t.c. . And then a hotkey will be given relative to a correct name, and not the opposite I think. After all, we are not playing Quake, right? :D

2) I guess you wrote some lines of code to jump to "points" ( "vertices") when clicking on the only enabled item ( "edges" or "faces" ) with the RMB, to prevent nothing left enabled, right ? So, whouldn't it be better to " jump " to the currently enabled ( it will deselect it and instide of selecting " points",it will enable the " previously enabled item" ) . In other words to stay on the same and not jumping always to points.  ::)

3)OK

3A)As i wrote above, maybe it should be given the name it  ( everything actualy ) has in general in CG and hot-keys will be applied relatively , not the opposite ? ???

4) Yeap, the classic is classic 8). Though I love the new one .
Title: Re: Copy past issue. World-object coordinates issue
Post by: nemyax on August 24, 2017, 06:31:28 pm
Well, right on the top of it there's the definition of PFE ( or VFE ) - " Points, Edges, Faces " so should not be that unclear. Though, " Extend selection when switching to points, edges, faces" sounds good , maybe even " Extend selection when switching between points, edges, faces ". But don't know if this will fit in the dialog window. May look kind of odd if there'll be a whole paragraph to click on . : )

Yeah, shorter would be better. How about "Points, edges, faces" as the title and "Extend selection when switching modes" as the label?
On a general note, the UI would look a lot better if it used sentence case everywhere that isn't a menu item or window title. Because at this time, Everything in Anim8or Looks Like the Name of a Movie.

Actually, originaly what is the exact name of points ( vertices - Trevor ;) ) in 3D CG ? If it's "vertex" and not " point", then it should be called as so everywhere inside Anim8or, including all commands all settings e.t.c.
Well, they're usually vertices in the context of polygonal geometry. Graphics APIs also call them vertices. Geometry types other than polygons have points, CVs (in NURBS) or CPs (in Hash splines). But the Anim8or UI traditionally refers to them as points, nothing wrong with that. Come to think of it, a vertex/point in a modelling program is a broader concept than an OpenGL vertex.

After all, we are not playing Quake, right? :D
No, but motor skills matter here also.
Title: Re: Copy past issue. World-object coordinates issue
Post by: thecolclough on August 26, 2017, 01:38:31 pm
3A) What do you think about changing PFE to VFE in the dialog to be consistent with the hot-keys.
it should be VEF rather than VFE, but yes.  the term 'vertex' is more precise and therefore preferable, for my money at least.
Title: Re: Copy past issue. World-object coordinates issue
Post by: Steve on August 27, 2017, 07:38:58 pm
I just posted an update v1.00b (http://www.anim8or.com/download/files/animv100b.zip) dated August 27, 2017 with the following fixes:

New commands:

 Build->SplitSolids in main Object editor that separates unconnected parts of a mesh or subdivision surface
 Edit->Pivot->CenterPivot
 Edit->Pivot->AlignWithShape
 Edit->Pivot->AlignWithWorld

Bug Fixes:

Fix initialization bug in ConfigureGUI dialog for "Extend PEF Selection" check box.
#100-013 - Object/Move command uses World coordinates when Object coordinates are selected.
           Note: Holding the Shift key moves 1/4 as far.
           Note: Holding the Ctrl key enables drag-select LMB and drag-deselect MMB (existing behavior).
Title: Re: Copy past issue. World-object coordinates issue
Post by: nemyax on August 28, 2017, 12:57:19 pm
#100-013 - Object/Move command uses World coordinates when Object coordinates are selected.
Steve
Can you make object coordinate system transforms work for points as well as objects?
Also, pivot rotation in screen coordinates doesn't work in perspective mode, even though pivot moving does. Do you test in perspective?
Title: Re: Copy past issue. World-object coordinates issue
Post by: Steve on August 28, 2017, 03:52:36 pm
nemyax: I think Point Move works properly for all coordinate systems, including Object. But Point Rotate looks like it's using World coordinates when it should be using Object.

Pivot rotations has multiple issues, not just in perspective views...
Title: Re: Copy past issue. World-object coordinates issue
Post by: nemyax on August 28, 2017, 03:59:55 pm
Point Move works properly for all coordinate systems, including Object. But Point Rotate looks like it's using World coordinates when it should be using Object.
Yes, that's true. And non-uniform scale behaves like rotate.
By the way, why do you disallow scaling to zero and negative scaling? They come in very handy sometimes.
Title: Re: Copy past issue. World-object coordinates issue
Post by: Gyperboloid on August 28, 2017, 04:26:16 pm
Steve, cool !!! For me, Anim8or was followed by those coordinate issues and now when they're almost fixed that Version 1 tag is fair enough.  8)

#100-013 - Object/Move command uses World coordinates when Object coordinates are selected.
Steve
Can you make object coordinate system transforms work for points as well as objects?
Also, pivot rotation in screen coordinates doesn't work in perspective mode, even though pivot moving does. Do you test in perspective?
nemyax: I think Point Move works properly for all coordinate systems, including Object. But Point Rotate looks like it's using World coordinates when it should be using Object.

Pivot rotations has multiple issues, not just in perspective views...


I checked it and yes, point manipulations seem to work properly according to object pivot in all coordinate systems.

As for the pivot rotation I checked it too. It has the same exact issues in all views including the user defined ( global thing ).
Exactly in Object/Axis mode : For the move command the pivot in World and Object coordinates behaves the same, has the old behavior ( in object coords pivot moves as in the world coords, with y and z axes in world coords being reversed, screen coords are fine ). As for the rotation command the opposite happens, in object coords the pivot's rotation works properly, relies on object pivot ( see itself ), while in world coords it relies again on object pivot and not on world axis. In screen coords the rotation is totally strange, something in-between values of axes, but stiil seems to relie on object pivot orientation  ???

Point Move works properly for all coordinate systems, including Object. But Point Rotate looks like it's using World coordinates when it should be using Object.
Yes, that's true. And non-uniform scale behaves like rotate.
By the way, why do you disallow scaling to zero and negative scaling? They come in very handy sometimes.

Checked that too, but seems to have normal behavior also  ::) Though, in Object/Edit the result is visible only when you finish your mouse dragging and not during the mouse movement, as happens ( and which is the correct way ) with scaling ( both uniform and non- ) of points in Point Edit mode.

Sorry for that message blending :P , just don't want to create kind of a chat here, so I just update this reply of mine :
Sorry, I meant non-uniform scale uses the wrong coordinate system (like rotate does), not that it rotates things.

It seems to behave according to screen coords only, in all coordinating systems.
Title: Re: Copy past issue. World-object coordinates issue
Post by: nemyax on August 28, 2017, 04:35:54 pm
Sorry, I meant non-uniform scale uses the wrong coordinate system (like rotate does), not that it rotates things.
Title: Re: Copy past issue. World-object coordinates issue
Post by: Steve on September 02, 2017, 07:56:17 pm
Here's a build with fixes for many of the issues with Screen, Object and World coordinate systems' Move and Rotate functions:

http://www.anim8or.com/download/files/animv100b_1298.zip (http://www.anim8or.com/download/files/animv100b_1298.zip)

Give it a try and let me know if these Object Editor tools now work properly. Note: This build does not address related issues with Scaling, or anything in the other editors. That'll come later.

--- Move/Rotate Object/Edit, Object/Point and Object/Pivot all now work correctly ---
- Fix problems with Point Rotate in Object Coordinates.
- Fix problems with Move Pivot in Object and World coordinates.
- Fix problems with Rotate Pivot in Screen and World coordinates.
- Change: use mouse RMB in the X direction to move in the Z axis (was the Y direction) to be consistent with rotations.
- Global changes to Rotations:
  * Screen coordinates: X/Y axes act as if you are physically rolling the object - X dir rotates in screen Y axis,
    Y dir rotates in X axis.
  * Object and World coordinates: +X/Y/Z movement rotates around the X/Y/Z axis in the counter-clockwise direction
    when looking in the -X/-Y/-Z direction. This is how rotations are generally described.
Title: Re: Copy past issue. World-object coordinates issue
Post by: nemyax on September 04, 2017, 11:00:53 am
Rotation works properly in the latest build. Now, if only there were a way to specify a custom rotation and scaling pivot in point edit mode =)
Title: Re: Copy past issue. World-object coordinates issue
Post by: Steve on September 04, 2017, 04:56:36 pm
Ahhhh, so there is a command Edit->Rotate->RotateCustom in Point Edit mode -- but it never has done anything! What were they thinking when they wrote this thing?

Looks like something that should I should work on next :)
Title: Re: Copy past issue. World-object coordinates issue
Post by: nemyax on September 04, 2017, 06:26:46 pm
What were they thinking when they wrote this thing?
They were probably thinking, "The scope and complexity of this thing are BLOODY HUGE! Will I ever get to fix the point rotations, I wonder?" =)
Title: Re: Copy past issue. World-object coordinates issue
Post by: Gyperboloid on September 22, 2017, 04:54:39 pm
Nice Steve !!! In the last release everything works just great !!! Coordinate systems now behave as they supposed to !
 What a long way that was! :D Since you mentioned it, couple of things I report again, if allowed. :)

1)   
Ahhhh, so there is a command Edit->Rotate->RotateCustom in Point Edit mode -- but it never has done anything! What were they thinking when they wrote this thing?

Looks like something that should I should work on next :)

It works, the rotation. But maybe you could disable the other commands in Edit menu in Point Editor which are not available ( Scale, Locate ), like the Pivot ?

2) In the same menu ( Edit  -- > Select ) in Point Editor , I don't remember from which version, the " Select Face Edges " command was removed, though it's still usable in Point Editor through its hotkey "t". Can you restore it ?

3) You added the " Split Solids " command in Build menu in Object Editor but in Point Editor the " l " shortcut for the split solids command still works, when nothing selected joined meshes split. Since you added the command in Object Editor in Build menu, maybe it's a good idea to remove, if possible, that possibility ( split solids ) from Point Editor. Since originaly the " l " hotkey stands for the " loop cut " command, if nothing is selected when hitting " loop cut " ( "l" hotkey ) nothing should happen, so no solids would split by mistake.

Later I'll add some other things  ;D
Title: Re: Copy past issue. World-object coordinates issue
Post by: nemyax on September 22, 2017, 07:55:23 pm
the " Select Face Edges " command was removed, though it's still usable in Point Editor through its hotkey "t". Can you restore it ?
That's taken care of by the Extend Point Edge Face Selection option now.
Title: Re: Copy past issue. World-object coordinates issue
Post by: Gyperboloid on September 23, 2017, 03:57:22 pm
Hm, yes I thought about it. Then I should say that "t" shortcut should be removed from Point Editor instead, like the " l " shortcut too.
Title: Re: Copy past issue. World-object coordinates issue
Post by: fefe01 on October 16, 2017, 11:29:01 am
Help me guys! I can't find the setting for the object, figure, sequence, and scene mode. As a consequence, i can't rename them. I can't put the figure to the sequence mode. I can't also modify the environment and the scene setting. Was the path changed or is it a bug? ???
Title: Re: Copy past issue. World-object coordinates issue
Post by: thecolclough on October 16, 2017, 04:49:13 pm
Was the path changed or is it a bug? ???
the menu path changed in the development builds leading up to v1.0, so the manual might now be out of date.  settings for each object are now accessed through Object > Properties, and so on for the other modes.  Scene > Properties gives you access to the Environment and Movie Image controls too :)
Title: Re: Copy past issue. World-object coordinates issue
Post by: fefe01 on October 16, 2017, 05:54:40 pm
Thank you very much Thecolclough. It helped me a lot! :)
Title: Re: Copy past issue. World-object coordinates issue
Post by: thecolclough on October 16, 2017, 06:22:23 pm
you're welcome =]
Title: Re: Copy past issue. World-object coordinates issue
Post by: Gyperboloid on November 02, 2017, 05:23:42 pm
Hm, yes I thought about it. Then I should say that "t" shortcut should be removed from Point Editor instead, like the " l " shortcut too.

Steve restored it, yay ! It is actually practical since there's the option to switch between PEF extended selection. So when  it's turned off, there you have the "Selelect Face Edges" command ( "t" - hotkey ) through the Edit -----> Select menu. Then you can switch from edges to points ( verticies ) just by deselecting edges and leaving points being only selected.

If there's no problem I'll post some stuff that popped up.

1) Following what I said about "Select Face Edges" command and the PEF Extended Selection particularly : as was mentioned from others, sometimes you don't want all the mess that is created by switching components ( PEF ) with the "PEF Extended Selection" enabled,while right after you would like to use it, then again to select something with the PEF Extended Selection" being off etc., it would be very practical if user could switch it on or off somewhere on the component panel beside ( left tool bar ) and not going through the Configure UI menu every time.

2) About the Coords Systems, I think Steve mentioned it, but I say it again. In the Object Mode all three Coords Systems work perfectly !!! In the Figure, Sequence and Scene modes the rotation of the bones is also perfectly relevant to the Coords System choosen, but for the objects we have the old behavior. Object Coords System behaves as World, with Z-Y axis reversed, for move and rotate commands.

3) Following that, is it possible to add something like buttons under Coords Systems for the World Coords System only,in Scene Mode, to reverse:  Y - Z axes ( currently they are ) <----- one button
                           X - Z axes  <------- second button
While the LMB ( Left Mouse Button ) stands for the movement in Y and X axes reversing everytime Y or X with the Z axis, for the move command only ( the buttons under Coords become selectable only when "move" tool activated) , user could "slide" objects on the ground ( Z - X plane, Y - Z axes reversed in World Coords------what actually happens currently, since in Scene mode Coords not fixed ) and " to hang a picture on a wall " ( Y - Z plane, X - Z axes reversed and Y - X plane, with no axes reversed ). In Perspective, ortho and other, not "currect" views, it would be ( maybe ) usefull to have the ability to move things in two-axes-planes with the use of a single mouse button ( LMB ).

4) One thing I dealed with, is that you can't change the name of an object folder. If there are more than 1 objects inside the folder and you trying to change the name of the folder for the particular selected object, then that object becomes "orphan", located outside the folder. If there's only one object and you rename the folder, after hitting OK the object becomes again "orphan" but the folder gets deleted ( maybe "empty" folders should be allowed, so later you could put enything inside them. Anim8or has no problem with "empty" objects inside folders though ) .So , if you think the name of a folder doesn't fit anymore to the contained objects, the only way you can go, is to create a new folder with the desired name and manually relocate all ( !!! ) the objects.  It seems Anim8or can't delete and create new folder when you are trying to rename the " old " one. Being able to simply rename a folder is ( seems to be ) very practical, but I guess Anim8or can't access ( and chcange ) object's settings on folder belongingness ( OMG what did I write )

5) Find out this very important and maybe not difficult to implement. Layers. First when they were introduced, couldn't clearly see how helpful they could be. Everything works great, only some tiny fixes and it's perfect ! Something mentioned before, about grouping things in the same layer. They should stay in the same layer. Currently they go to the default, but if you working on any other and the default is invisible, grouped items from other layer become invisible too. Shapes being grouped from same layer should stay on that same layer, the group should not be put in the default layer automatically. When you ungroup things they return to their original layers though, even if shapes were in different layers before grouping. Although I see that it can be difficult, maybe, to code, since everything new created goes on the default layer.  Another thing is that Sphere, Cube and Sylinder as a parametric shape when created, while default layer is not the "0" one ( nothing created still ) , goes on that default layer ( "1"- "2" -"3" whatever ) but the "0" one ( not underlined though since not default ) becomes visible, though doesn't contain shapes. Then you create another Parametric Shape or bring up the shape settings window and the '0" layer goes off. The "0" layer is too jealous, you know.
The last and the most important : I think "Working" instead of "Default" layer maybe is a better title, since it's "the currently working" layer. And following the previously said, while working on something I felt the need for being able to switch the "working" (  ;) ) layer on the top panel using the ( only available ) MMB ( Midle Mouse Button ). Currently users "lock" and "hide" "unhide" layers with LMB and the RMB, using the Options menu to change the "working" ( ok, ok "default" ) . Will speed up the workflow a lot, on complex objects, with different items on different layers.

6) Since mentioned the "hide"-"unhide" thing. Very usefull commands. Being able to hide selected items is pure gold. The "show all" command is good too. But, I think, if possible, the "show selected" command( with the use of the "item list" ) would be pure platinum ( or what's the next after the gold  :P ). Picking an item/items from the "item list", from those hidden, making them visible again, without the need to use the "show all" command and select again all the shapes you want to keep hidden, exept those you want to stay visible. Frustrating .  :o

Last one, since the new Arc Rotate Tool introduced, you need to click 3 (!!!)  times on the view mark ( left upper corner ) to change the view. Numpad and view menu works fine. Only on workspace window the problem exists. On previous versions user even could clicking on the view mark and while holding down the mouse button dragging through view options and releasing the button on the desired view option. Very quick way to select views. Good if it can be restored.
And to remove the ability to split solids in Point Edit Mode with the use of "loop cut" command, since "Split Solids" command was implemented in the Build menu in the Object Mode. When nothing is selected ( edge loop ) in Point Edit Mode, while hitting "l" or from the Edit menu, an aware window should pop-up and remind that " no edge loop is selected" instide of splitting solids. Splitting Solids should be available only in Object Edit mode through Build menu.
Title: Re: Copy past issue. World-object coordinates issue
Post by: Steve on November 02, 2017, 10:51:12 pm
Quote
1) Following what I said about "Select Face Edges" command and the PEF Extended Selection particularly : as was mentioned from others, sometimes you don't want all the mess that is created by switching components ( PEF ) with the "PEF Extended Selection" enabled,while right after you would like to use it, then again to select something with the PEF Extended Selection" being off etc., it would be very practical if user could switch it on or off somewhere on the component panel beside ( left tool bar ) and not going through the Configure UI menu every time.
Interesting idea. Maybe add a button just below the P E F buttons "Extend PEF" that toggles the setting. It also could be useful for an "All" button that you could click to enable all 3.

Quote
2) In the Figure Editor ... Object Coords System behaves as World, with Z-Y axis reversed, for move and rotate commands.
Oops, I forgot to look at this. I'll fix it.

Quote
3) Following that, is it possible to add something like buttons under Coords Systems for the World Coords System only,in Scene Mode, to reverse:  Y - Z axes ( currently they are ) <----- one button
                           X - Z axes  <------- second button
...
I'll have to think about this. I make the World coordinates work this way in the Scene editor because it allows you to move things around on the ground. But I see your point.

Quote
4) One thing I dealed with, is that you can't change the name of an object folder.
Good idea.

Quote
5) Shapes being grouped from same layer should stay on that same layer
Also a good idea.

Quote
6) "show selected" command ... item window ...
Also an interesting idea.

Quote
new Arc Rotate
This is still very much a work in progress. The extra click to change the view is simply a bug which I''l fix.

Quote
When nothing is selected ( edge loop ) in Point Edit Mode, while hitting "l" or from the Edit menu, an aware window should pop-up and remind that " no edge loop is selected" instead of splitting solids.
Will fix.

Thanks for the great feedback. I probably missed a few things so I'll come back to it again later.