Anim8or Community

General Category => Anim8or v1.0 Discussion Forum => Topic started by: selden on September 17, 2017, 12:06:47 am

Title: v1.0b: point edit extrude faces doesn't
Post by: selden on September 17, 2017, 12:06:47 am
Problem: Sometimes when two faces are selected, only one of them gets extruded.

I'm trying to create what looks like a pair of doors in the end of a cylindrical container.

I use the following set of operations: create cylinder, convert to mesh, point edit, select the top end,
inset, extrude face (inward), cut selected face in half, inset, leave both faces selected, extrude.

Only one of the two faces extrudes. When drawn as shaded surfaces, the face which does not extrude has a darker coloration than the face which does extrude. Presumably this is another symptom of the underlying problem.

I've attached the .an8 of the model after the faces fail to extrude properly.

Here's a link to a 2.5 MB mp4 screen recording of the failing extrusion attempt, showing everything from scratch:
https://www.classe.cornell.edu/~seb/celestia/files/cylinder.mp4
Title: Re: v1.0b: point edit extrude faces doesn't
Post by: Steve on September 17, 2017, 03:54:24 am
I'll take a look at this.
Title: Re: v1.0b: point edit extrude faces doesn't
Post by: kreator on September 17, 2017, 05:46:11 am
Works ok for me!  using v1.00b (what version are u using?)
Title: Re: v1.0b: point edit extrude faces doesn't
Post by: selden on September 17, 2017, 11:05:41 am
Sorry: I'm using v1.0b 1298.

It works for me once in a while, but it's not predictable. It isn't obvious to me what the difference is. Maybe it's how Anim8or selects the points that are the ends of the cut?