Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Apophis

Pages: [1]
1
General Anim8or Forum / What's the best way to have objects touching?
« on: August 28, 2008, 12:19:39 pm »
When I try to have two objects touching (no space between a face on one and a parallel face on the other), I can't get it to render well. If I put them so that the two faces are at the same coordinates, they don't render correctly. If I put them very slightly apart from one another (say a gap of .0005 or whatever), I can see light pass between them at certain angles. How can I make it look like they're touching without the bottom of one occupying the same physical space as the top of the other?

2
General Anim8or Forum / IRC
« on: August 23, 2008, 07:34:42 pm »
#anim8or on irc.irchighway.net seems to be dead. Did the channel move to another server or something?

3
Anim8or v0.98 Discussion Forum / ART Ray Tracer renders weird
« on: August 23, 2008, 06:52:37 pm »
The same images are rendering differently with Scanline and ART Ray Tracer. Specifically, objects are being shaded/casting and receiving shadows oddly. ART is giving me an odd, partial shadow. How can I fix the shadows in the ART renders?


I've included some examples. Other than moving the camera, nothing has been changed in any way.  As you can see, only the bottom half of the jewel is casting a shadow.

The settings are as follows:

    Rendering Antialiased
    Light and Camera hidden
    Rendering from View->Camera

    Environment:
            Background: Solid,     Color: 153, 153, 153
            Ground Grid: Off
            Fog: Enabled, Start: 300, End: 1250, Max%: 100, Color: 153, 153, 153
            Shadow Bias: 0.0010
            Clip Planes: Z-Near: 50, Z-Far: 10000

    Light:
            Color: 255,255,255
            Type: spot
            Inner: Radius 500, Angle 30
            Outer: Radius 5000, Angle 40
            Casts Shadows, Percent Dark: 70, Ray Trace

    "Jewel" material:
            Ambient:  0.300     Color: 206, 6, 1
            Diffuse:    0.300     Color: 206, 6, 1
            Specular: 1.000     Color: 126, 12, 9
            Emissive: 0.100     Color: 0, 0, 0
            Rough: 5
            Brilliance: 1
            Transparency: 0.30

    "Wall" material: none/default

    The "Jewel" also has Smooth Angle: 20 (I've since changed it to 10, which has no effect on the shadows but makes it look more like a jewel.)

     



Edit: Here's are two more examples. They're the exact same settings as the two above, except that I turned on the ground grid. As you can see, the shadow is more complete, but there are still strange gaps. Why am I getting these gaps, and why is the ground affecting the shadows?

     

Pages: [1]