Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - johnar

Pages: [1] 2 3 4
1
Anim8or v1.0 Discussion Forum / graph editor and timetrack
« on: September 13, 2017, 11:28:35 am »
 Hi steve,
 I've been working on quite a bit of lip syncing, and a bit of anim8ion, lately, and Anim8or is a great tool for lipsyncing your characters. (once you have the timing sheet)
  (Depending on the qualities of the morph shapes), the keyframing and graph editor functions make it possible to have excellent, and simple, control over the morphing process.
 Shortcut keys for 'keying selected and 'keying all' have hugely sped up the proccess of animating.
 Although some other softwares have automated lip syncing, and probably with the ability to tweek the keyframes afterwards,  Taking into account what i've said above, i reckon Anim8or is right up there with the best of them.
 If you have a great quality model, or character, and some great quality morph targets made, Anim8or has the capabilities to make some truly great results in face expression and speech.
 I'm working on fine tuneing the lipsyncing process in Anim8or, and am really getting somewhere.
 One day, when i have it perfected, i'll do a video tut, which i'm sure will be very helpfull to many people.
  I'm working with what we've got, and will post things relevant, pluses and minuses.
  So, one thought i wanted to share, after many hours of lipsyncing.....



  When the graph editor is showing above the floating timetrack, it cuts the timetrack in half. If theres a lot of morph targets in the timetrack, and the graph editor is hiding half the screen, then its back to scrolling up and down trying to locate the different morph targets. Being able to drag the height of the timetrack, as above, would fix this 'really annoying' problem.
 What do you think?
 By the way. Now that we can hide bones within folders in the timetrack, i can see 'all' of my morph targets without having to scroll. The difference is night and day.
 (In the gif above, i've got the graph editor being turned on and off from within the floating timetrack. Although it would be cool, its not really necessary, because theres always hotkeys Ctrl-P to do that)
 Nice one steve. Keep up the outstanding work.
 Anim8or rocks.  :)
   

2
Finished Works and Works in Progress / Emotogif update 2017
« on: June 07, 2017, 10:56:58 am »
 Have updated the links for the emotogifs from this post.
http://www.anim8or.com/smf/index.php/topic,4707.0.html
 (most of the old links had died)

 Folder with updated links attached. (must make some more of these........
                                       

3
Anim8or v1.0 Discussion Forum / frame views in scene
« on: May 08, 2017, 01:22:15 pm »
Something i've noticed for a long time now, and seems as we're nearing Version 1, where 'the more tidy and consistent the better', it might be worth a mention, because it's a 'quirk'.
 When you're in scene mode with multiple views and you press 'f' for 'frame view', it frames all views 'including the camera view'.
  Usually the camera view is like, the main final view, whereas the other views are often more the 'working views'.
  As it is, it basically means when you 'frame view' in scene mode, the next step is regain the camera view.
 Changing this would not only save time, but also help to keep things consistant, because when changing between smooth, flat and wireframe views, that only applys to the selected view.
 If this is making sense, perhaps 'f' for frame view in selected window, and 'Ctrl-f'  for frame all views. (Ctrl-f seems to be available?)
 

4
Anim8or v1.0 Discussion Forum / character anim8ing
« on: May 05, 2017, 02:50:34 pm »
Anim8or is so cool.
Got a couple of thoughts after my latest wee dabble...
https://s3.postimg.org/4v3zxcpcz/ggymn4c.gif

 
 Changing between object and screen co-ordinates seems fairly crucial now, for me anyway, when animating a character.
 A new habit to learn when in scene mode. Use 'Object Coordinates' when animating a rig, then change to 'Screen coordinates' to move position or orientation. (has caught me out a few times now. Thank god, (steve), for being able to slide outside the work area to cancel the last move. Has saved my butt many times)
  I notice  'co-ordinates' change globally, maybe it would be better if they didn't..?
... any thoughts anyone.....
 
(btw steve: shortcut key 'j' for Screen Coordinates is showing as 's' in Scene mode.  ((in the info bit at bottom left of screen when hovering over a button.)). 'j' works tho.  's' is scale of course. :)

 The other thing,

 Selecting a bone in the timetrack, (left colum), doesnt show the associated trackball in the scene, but often selecting a bone through the timetrack is because you can't clearly see the bone to select it.
 Its a gr8 way of selecting a bone that you can't reach.
 So the trackball should probably show when the bone is selected by timetrack entry.

Anim8or is so cool.


5
Anim8or v1.0 Discussion Forum / IK in additional cameras
« on: April 25, 2017, 10:56:55 am »
 
 Hi steve. Have just discovered that Animating a figure with IK is unresponsive in extra camera views. (camera 2, Camera 3 etc...) (not sure if you already know that)
 
 Sorry i've been a bit tied up lately, but winter is arriving now, here in nz, so looking forward to spending some cozy nights at home with anim8or.
 ... i'll keep reporting in more often from now on....
...and froyd's itching to get mobile again



   

6
Anim8or v1.0 Discussion Forum / Sequence import bug
« on: April 22, 2017, 08:29:59 am »
Sequence import crashing if no figure is in the sequence file.
 All builds up to, and including, 1253 don't have a problem importing a sequence that doesn't have a figure referenced in the sequence file, but all builds from 1255 upward, including V1betas, will crash Anim8or, when trying to import a 'figureless' sequence.  8)  ;)

 

7
Anim8or v0.98 Discussion Forum / problems and traceinit....
« on: January 03, 2017, 06:23:06 am »
 I can't do pretty well anything in scene mode in builds 1261, 1263 and now 1264.  :'(
 As soon as i try anything, like arc rotate, moving a figures bone, and so on, anim8or stops working and i have to close the program.
 Could traceinit help to find the problem, and if so, can someone please tell me how to make a traceinit log file?

 All works fine on other previous versions, and if i boot up Windows XP on this same windows 7 pc, it also works ok, but very slowly.
 Any help appreciated.
 Thanks


System Info:
 OpenGL Renderer: GeForce 8600 GT/PCIe/SSE2
 OpenGL Version: 3.3.0
 OS Version Windows 7 (6.1) build 7600

8
General Anim8or Forum / Gym Figure. (sausage man)
« on: December 18, 2016, 09:11:47 am »
This is Gym.


 He's fast and light to move and render.
 Not sure how to fix the few 'missing objects' listed when opening.
 He's ready to animate and has 'look left', 'look right' and 'eyes closed' morph targets.
  Help yourself, and have fun.
 

9
Anim8or v0.98 Discussion Forum / Import sequences bug in 1255
« on: October 15, 2016, 11:55:13 am »
 Anim8or 'stops working' when trying to import a sequence. Build 1255.
 I tested against 1253 and sequence import working properly there.

Makes no difference if importing the figure with the sequence or not.  8)

EDIT. New test.  Exported sequence and figure from build 1255.
 That sequence and figure Imported properly in 1253.
Stopped working when trying to import into 1255.

10
Anim8or v0.98 Discussion Forum / Deleting Scene bug
« on: April 15, 2016, 12:18:50 pm »
Deleting a scene is causing anim8or to crash. (anyone else?)
 On windows 7 32bit. Not happening on windows XP
Builds 1215 and below are fine. Problem starts at 1219 and above.
 I've tested on several builds  and different scenes.(even empty scenes)
 Looks like it only happens if there's more than 1 scene in the file.  ;)

My easiest test is:
 New file -> Scene mode. Scene -> new. (Scene2)
Scene -> delete. ......"Anim8or has stopped working"

11
Anim8or v0.98 Discussion Forum / scene not selecting
« on: March 05, 2016, 09:19:14 am »
Bug: In scene mode, when you click on the word 'Scene" at the top of the list in the left of the timetrack, that would normally select everything in the scene.
 This stopped working at Build 1202plus.   

12
Anim8or v0.98 Discussion Forum / 'Key all bones' not selecting
« on: December 13, 2015, 10:06:24 am »
build 1203.  Awesome.
 Have found a bug to report:
Selecting figure in scene mode, or 'figure' in timetrack, is not selecting all bones, as it did in previous builds/versions and is not showing bounding box of selected figure.
Related is:
  'Key all bones' is 'keying all bones', but is not selecting them.
 Important for quick keying then copy/pasting.

13
Anim8or v0.98 Discussion Forum / joint values not resetting in scene mode
« on: November 26, 2015, 09:46:43 am »
When double click on bone in scene mode, entering values into value box does not reset bone value. Also shows wrong frame number
It does work when double clicking on bone name in timetrack and entering value there. Frame number is correct.


14
Anim8or v0.98 Discussion Forum / bones not showing in scene
« on: April 13, 2015, 12:34:22 pm »
Can't work this out. 
 The bones aren't showing up in the timetrack list, but you can see them in the workspace.
 (When i click on a bone it says no controllers.
 But the bones are set to no limits in figure mode.
 Create a controller, and 1 axis of one bone shows up in the timetrack.)
 Its happening on winxp and win7, and seems to be any version of anim8or.
 How can this be?
 I've been trying for the last long time to work this out. . lol. Please someone tell me it's something simple.
 This is so strange......

 Edit: Has it always been like this..??
  Normally, when you import a figure into scene mode, aren't the bones automatically there under the figures name in the timetrack?
 Maybe i've just been dreaming thats how it was ... 

15
Anim8or v0.98 Discussion Forum / Deleting sequence bug.
« on: February 11, 2015, 08:56:10 am »
 Hi Steve
  reporting a bug for future reference  :)
 Deleting sequences in scene mode.

 This is about this short thread here.
http://www.anim8or.com/smf/index.php/topic,5070.0.html
 This is a bug report, so posting the message here.
 There is an occasional problem when, for some reason, even tho anim8or will delete the keys, the little lines stay.  And then if you go to paste another key value on one of those little lines, anim8or will give the notice that you're pasting into an existing sequence,..... Even tho theres no actual keys there, and the sequence has supposedly been deleted.
. definately a bug.


 

Pages: [1] 2 3 4