Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - argee

Pages: [1]
1
argee: The crash on start-up that you reported should be fixed. Can you give it a try?

Yes! starts up fine with no file association required! Thanks Steve!   :)

2
Excellent! Thanks Steve!

3
No, just double-clicking Anim8or_1235.exe.

When I didn't see a registry entry for version 1235 I figured I would add one by creating the file association by right-clicking a .an8 file and selecting a default program to open it with.  Seems to have made the problem go away.  Might be something to look at as I don't recall seeing this problem with previous versions before I set up the file association.  Anyway, it could just be some weird corner case.

Thanks,

argee

4
Actually I think my edit of my last post was the key to this.  Once I associated .an8 files specifically with version 1235, now it works fine with "Start in Previous" enabled.  D'ohp!  Don't know why I haven't come across this problem before, but that seems to fix it.

Thanks for your help!

argee

5
I tried what you suggested and it opens fine.  The killer seems to be if I re-enable "Start in Previous".  I tried it with several different files and the same crash occurs when I start version 1235.  And yet I can open those files once I've started version 1235.  It's fortunate that I can reset the setting using version 1234 or this would have been a short test (lol).

As for the command window, I think the problem is that Windows puts up the initial message and then puts up another message window about sending in a report and if you decline that it closes the whole program, command window and all.

I tried accepting the report send and by default it tried to open the debug file in VS 2013.  That didn't go too well, but it did spit out this line over and over:
First-chance exception at 0x002232B6 in Anim8or_1235.exe: 0xC0000005: Access violation reading location 0x0000003C.

I don't know if that has any meaning for you, I don't speak Greek :).

BTW I'm running Windows 7.  Attached is from when I opened version 1235 successfully (with "Start in Previous" disabled) and from when it crashed.

edit:  I don't know if this is relevant, but I did a quick search through the registry for any Anim8or entries and found stuff for various versions up to and including version 1234, but nothing for version 1235

Hope this helps some anyway.

Thanks

argee

6
Hi Steve,

I just tried something else.

I started version 1234, went to the File-Configuration and unchecked "Start in Previous" and "Remember Window Location".  I restarted 1234 and now the window isn't maximized on start.  I then ran version 1235 again and now it works and also starts with the window not maximized.

Is there an external file that stores the configuration?

edit:  Looks like it was the "Start in Previous" setting that was the culprit.  There's something about the file I created in version 1234 that version 1235 doesn't like I think (although I can open the file once I'm in Anim8or - Odd!).

thanks,

argee

7
Hi Steve,

Attached (I hope) is what I could grab from the screen running the -traceinit.  That window disappears as soon as I close the "stopped working" message. It appears to stop right before the "Timer started" message that appears when I run version 1234.

Thanks

argee

8
version 1235 won't run for me.  I get the Windows "Anim8or has stopped working" message as soon as the Anim8or startup window is displayed.  If I go back to version 1234 everything's OK again.

Anyone else having problems?  Anything I should try?  I'm running Windows 7, changing compatibility settings makes no difference (I didn't have to set those for version 1234 anyway).

9
Ongoing Anim8or Development / Re: Initial CAD-style feature
« on: March 29, 2014, 09:30:21 pm »
Really liking this new CAD feature!

Are you thinking of adding the ability to edit the numbers that appear?  In-place would be nice, but even edit boxes at the bottom of the screen (like a lot of CAD programs) would be OK with some kind of indication of which number is in edit mode.

Thanks!

Pages: [1]