Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: Shadows  (Read 2748 times)

AlecJames

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Shadows
« on: January 26, 2018, 09:21:40 pm »

When I enable casts shadows in my light I see shadows in an ART render.  The object's casts shadows and receives shadows check boxes do not have any affect.

I don't see shadows in scanline or opengl renders, at all.

Is that the current functionality of shadows or should I be able use the object's casts shadows and receives shadows to change the way shadows appear?
A
Logged

slex

  • Jr. Member
  • **
  • Posts: 94
  • 3D-TV
    • View Profile
Re: Shadows
« Reply #1 on: January 26, 2018, 10:35:08 pm »

in light parameters go to- advanced and check Ray Trace instead of volume
Logged

ENSONIQ5

  • Sr. Member
  • ****
  • Posts: 949
    • View Profile
    • Mission Backup Earth
Re: Shadows
« Reply #2 on: January 27, 2018, 02:15:45 am »

Unless this has been fixed in a recent update, shadows are always 100% in ART renderer.
Logged

Gyperboloid

  • Sr. Member
  • ****
  • Posts: 260
  • It's better not to do anything, than to do nothing
    • View Profile
Re: Shadows
« Reply #3 on: January 27, 2018, 05:15:44 am »

As ENSONIQ5 said : those boxes in menu have no affect on ART, only on Scanline . Try what slex suggested for Scanline .
There are some issues there like for ever. Not only in Scene ( render ) mode. Step by step Steve will fix them all we hope.
Logged

AlecJames

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Re: Shadows
« Reply #4 on: January 27, 2018, 10:22:16 am »

Thanks all :)
Logged

fefe01

  • Newbie
  • *
  • Posts: 32
  • make professional works only using simple softwares
    • View Profile
Re: Shadows
« Reply #5 on: February 02, 2018, 07:28:21 am »

hello folks! I would like to take advantage from this topic to talk about my problem with shadowing. is it possible with anim8or to have shadow nuance? for example, when the caster is close to the receiver of shadow, the shadow is very clear and the further the caster go from the receiver, the more blured the shadow on the receiver will be.
« Last Edit: February 02, 2018, 07:30:55 am by fefe01 »
Logged

ENSONIQ5

  • Sr. Member
  • ****
  • Posts: 949
    • View Profile
    • Mission Backup Earth
Re: Shadows
« Reply #6 on: February 02, 2018, 09:06:06 am »

Yes, soft shadows can be set in Scene mode.  In Light Properties, click 'Advanced' button in Fixed Properties section, select 'Ray Trace' shadows, select 'Soft' in Ray Parameters section and set the size of the light source.
Logged

fefe01

  • Newbie
  • *
  • Posts: 32
  • make professional works only using simple softwares
    • View Profile
Re: Shadows
« Reply #7 on: February 02, 2018, 11:21:50 am »

thank you very much ENSONIQ5. i happened to see that menu many times but never thought that it causes soft shadow.
Logged

itsstillthinking

  • Newbie
  • *
  • Posts: 45
    • View Profile
Re: Shadows
« Reply #8 on: March 07, 2018, 10:12:26 pm »

I my self am also having issues as well. Any ideas?
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1667
    • View Profile
Re: Shadows
« Reply #9 on: March 07, 2018, 10:21:40 pm »

For shadows you need to:

1. Check both the Casts Shadows and Receives Shadows boxes in an Element's properties dialog in the scene editor.
2. Add a User light and check the Casts Shadows box and the Soft Shadows box and set the size of the light in the light's Advanced properties dialog.
3. Render using anti-aliasing.
Logged

itsstillthinking

  • Newbie
  • *
  • Posts: 45
    • View Profile
Re: Shadows
« Reply #10 on: March 08, 2018, 07:21:05 am »

Tried all those settings and it was still very "Black", adding more lights everywhere seemed to help a little but it still is super bright or very dark
Logged