Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Author Topic: A few issues (bugs), a few things that'd be sweet to see...  (Read 601 times)

davdud101

  • Sr. Member
  • ****
  • Posts: 987
  • Couldn't ever use Blender or Maya. Anim8or's good.
    • View Profile
A few issues (bugs), a few things that'd be sweet to see...
« on: January 18, 2019, 03:19:11 pm »

- I'm running into at least one bug on my two most recent projects where if I have a subdivide on screen, general at Division level 3 or 4, and then I bring up the CAD Annotations and then enter Point Edit mode, Anim8or will outright crash. It doesn't seem to be a case of too-high poly count or anything because it'll be smooth sailing right up until it crashes.

- I love using edge properties, as they avoid having to create complex geometry and stuff for more refined models. However getting to them is hard to do, and getting them to seem to say set to their value is also tough (they'll visually stay the same but sometimes the number just won't be there depending on what the value is)

- For some reason the drag-select doesn't like working properly sometimes. Every once in a while (like last night) I'll open the software and drag select will only select a few things at a time regardless of what I drag across.

- Scene editor has ALWAYS, for just about as long as I can remember, been freezing up while playing back scenes. I'm not sure if anyone else has had this issue but it does it pretty much always for me. This is my first time trying full-on animation again after years of not touching the Scene editor. Got a scene for a CAD animation that's 16s long and it freezes about 2s in and unfeezes when it's done.

- Doesn't seem like Anim8or plays back scenes in real time. I think this has been the downfall of the quality of many Anim8or users' animations. I mentioned a while ago that I've got a pretty beefy system that would be more that capable of handling Anim8or at its highest output.




The main thing for ME that I think would sweeten the pot as far as using Anim8or for animation would be keyframe editing buttons in Scene mode, maybe at the very bottom of the timetrack, that allow simply adding a keyframe for the selected object, changing the Key type (which for me has always made it tough to animate - that slight 'lurch' back that everything with a smooth key type does before moving in the intended direction, which seems to be the default). I guess it has some interpolation which is fine for organic stuff, but oftentimes needs to be corrected when it's something inorganic/more static which takes a LOT of times when there's a lot of objects moving and things happening.




In any case Anim8or is still without question my go-to software for quick-but-accurate prototyping of ideas. I'm just finding that when I extend my use of the program any further than what I KNOW I can do with it, I'm running into issues that make it much harder to work.
Logged
?

AlecJames

  • Full Member
  • ***
  • Posts: 172
    • View Profile
Re: A few issues (bugs), a few things that'd be sweet to see...
« Reply #1 on: January 18, 2019, 04:51:52 pm »

You probably already know - pushing and holding the right cursor key sort of plays the scene without it hanging.

For me too it only hangs (display frozen) until it reaches the end of the scene. I never put loop scene on because then it hangs forever....

(I haven't run the latest version in anger yet, my comments are based on older v1+ versions)
 

Logged

davdud101

  • Sr. Member
  • ****
  • Posts: 987
  • Couldn't ever use Blender or Maya. Anim8or's good.
    • View Profile
Re: A few issues (bugs), a few things that'd be sweet to see...
« Reply #2 on: January 19, 2019, 07:20:47 am »

You probably already know - pushing and holding the right cursor key sort of plays the scene without it hanging.

For me too it only hangs (display frozen) until it reaches the end of the scene. I never put loop scene on because then it hangs forever....

(I haven't run the latest version in anger yet, my comments are based on older v1+ versions)
 



Oh yeah, that I've used a lot. But sometimes you just crave to see the fruit of your labors without having to put in ANY more effort, lol

Glad to know it's not just me! I think those are the big two issues I've perpetually had with Scene mode- it doesn't play back at full speed (so you have to sort of guess and then render and hope it's right) and then it freezes DURING playback so you can't even get a decent preview without holding the right arrow key.
Logged
?

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1714
    • View Profile
Re: A few issues (bugs), a few things that'd be sweet to see...
« Reply #3 on: January 19, 2019, 11:59:00 am »

Good feedback, davdud101. I'm aware of the scene playback problem that happens on a lot of systems, but haven't been able to isolate the cause. It works OK for me almost all the time so it's difficult to catch in the debugger.

Do you have an example of the subdivision crash that you can send me?

The backward lurch is a side effect of simple Bezier splines. I have some ideas for eliminating it that should help.  Stay tuned...
Logged

davdud101

  • Sr. Member
  • ****
  • Posts: 987
  • Couldn't ever use Blender or Maya. Anim8or's good.
    • View Profile
Re: A few issues (bugs), a few things that'd be sweet to see...
« Reply #4 on: February 08, 2019, 01:12:06 am »

Hey Steve, I'll try to send a sample if it comes up in a recent model. Thanks for all your work!


Suppose I'd ought to mention one more thing - maybe a bug, not a huge issue but just a minor annoyance (that could very well be me hitting keys that I'm unaware of) - the "Snap to Grid" option seems to turn itself on really often during long sessions. I feel like I'm probably hitting hotkeys making that happen myself though?
Logged
?