Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

Ian Ross has just released a book on Anim8or. It's perect for a beginner and a good reference for experienced users. It contains detailed chapters on every aspect, with many examples. Get your own copy here: "Anim8or Tutorial Book"

Author Topic: Bug: Drag-select doesn't select all meshes  (Read 6934 times)

selden

  • Full Member
  • ***
  • Posts: 195
    • View Profile
    • Modelling for Celestia
Bug: Drag-select doesn't select all meshes
« on: October 11, 2016, 06:20:55 pm »

Bug:

Running Anim8or v0.98b, build 1253, in the Object Edit mode, the "select multiple" tool doesn't select all of the meshes that it should.

This bug has been present for quite a few builds.

This bug can be demonstrated using the enclosed .an8 file (in the .zip) and is illustrated
in the enclosed screengrabs.

Instructions to duplicate this bug:

In the Object editor, drag select so that all of the individual meshes
are outlined. Release the mouse button. Only a few of the meshes
are highlighted and selected. They all should be selected.

This isn't a big deal when only a few meshes need to be selected, but it
is quite painful when most, but not all, of a large number of objects
need to be selected.

Selden

Logged
Selden

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1991
    • View Profile
Re: Bug: Drag-select doesn't select all meshes
« Reply #1 on: October 11, 2016, 07:20:00 pm »

Interesting.  It selects everything in Flat Shaded or Solid Shaded mode, but not in Wireframe.  I'll look into it.
Logged

selden

  • Full Member
  • ***
  • Posts: 195
    • View Profile
    • Modelling for Celestia
Re: Bug: Drag-select doesn't select all meshes
« Reply #2 on: October 12, 2016, 07:09:18 am »

Thanks!

I like to use wirefreame mode to decide if I'm using the right viewpoint direction to avoid selecting unwanted objects.
Logged
Selden

ELECTROHERMIT

  • Newbie
  • *
  • Posts: 23
  • Medical Illustrator AEIMS AMI
    • View Profile
    • ELECTROHERMIT
Re: Bug: Drag-select doesn't select all meshes
« Reply #3 on: October 18, 2016, 08:25:04 pm »

Okay, I resolved the font issue with an earlier build of 98 (2014). The white box issue remained. I'm going to regroup and dig into this a bit more.

Thanks for the input everyone.

DD
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Posts: 1991
    • View Profile
Re: Bug: Drag-select doesn't select all meshes
« Reply #4 on: October 18, 2016, 08:58:46 pm »

This is fixed for the next build:
#098-093 - Drag-select doesn't select all Shapes in wireframe mode.
Logged

selden

  • Full Member
  • ***
  • Posts: 195
    • View Profile
    • Modelling for Celestia
Re: Bug: Drag-select doesn't select all meshes
« Reply #5 on: October 19, 2016, 06:09:51 am »

Thanks!
Logged
Selden