Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  


Ian Ross has just released a book on Anim8or. It's perect for a beginner and a good reference for experienced users. It contains detailed chapters on every aspect, with many examples. Get your own copy here: "Anim8or Tutorial Book"

Author Topic: Hi to all, and running on Linux, and zoom level on render  (Read 6721 times)


  • Jr. Member
  • **
  • Posts: 53
    • View Profile
Hi to all, and running on Linux, and zoom level on render
« on: December 26, 2018, 01:17:24 pm »

Hello Thanks for keeping this alive all these years.  Back in 2003 I decided while I was in hospital to try my hand at gamemaking and used anim8or for about 6 months and had no idea what 3d modeling was and so ended up just doing 2d sprites.

Years later after mastering sketchup for woodworking and furniture I decided to get back into gaming and to make a RTS game and wanted a certain style of sprites. I no longer own any windows computers and so I needed a 3d program for linux.  Blender really has a steep steep learning curve. I know blender does everything- but I dont need everything I just need a low poly models without hassle.    So I remembered anim8or from more a than a decade ago and was really pleased to find it still available!  So I downloaded and run it perfectly on Sparky Linux under wine. Created two models and I am very pleased.

My challenge:  I cannot find put why anim8or will not run under Linux Mint wine.  It starts, has all menus and it actually creates the models but there is not screen output in the opengl works. Just a black empty space.  one difference besides the linux flavors is the computer that anim8or under is not working is a laptop.  I cannot get an error because anim8or is not malfunctioning it is running and doing what it should, WINE is not rendering the window.  It also does the same thing in VIACAD 10 pro. 

So if you wish to use linux and anim8or I suggest get Sparky linux and run the Game Meta option which will install all linux gaming components.  I run my system on a toshiba external HDD with no actual installed HDD.

Thanks I appreciate application- it's small, easy, and free.  I really love the render and save to PNG.

Is there a way to choose the zoom level on the render?


  • Hero Member
  • *****
  • Posts: 1067
  • Couldn't ever use Blender or Maya. Anim8or's good.
    • View Profile
Re: Hi to all, and running on Linux, and zoom level on render
« Reply #1 on: January 10, 2019, 03:03:08 pm »

Why not try a Windows VM or look for a free copy of a Windows distribution? I can attest to that I've never been able to get Anim8or running on Mac and to be honest I gave up a few years ago and just run it on my Windows battlestation.

As far as zoom level, I'd recommend (for consistency's sake) that rendering using cameras in the Scene mode. Then you don't have to reset the view every time you want to render, you just go to a camera that's set in an exact spot and render right there.


  • Newbie
  • *
  • Posts: 8
  • Mike Garcia
    • View Profile
    • my gamedev blog
Re: Hi to all, and running on Linux, and zoom level on render
« Reply #2 on: March 27, 2019, 09:25:23 pm »

Hi guys,
So last time I used anim8or was in 2016 and I was able to use it in linux32 (mint 14 I think) in wine and/or Virtual box (winXP 32bit), no problems.
I'm using 64bit OS'es now and while the it loads fine and some features work.. using shapes do not or crashes or crash the VM.

I've tried running in native and the recommended XP mode in service pack 3 compatibilty option.
I've tested this in wine64, windows via VB (win7 64bit) winXP SP3 32bit and all about the same.
Stable animv0981 work fine on everything.
animv1.0 works on VB with my winXP SP3 32bit, but animv1b+ crashes
wine64: animv1.0 and above doesn't crash but doesn't render anything, as per OP

Currently the newest version that works for me is Anim8orv1.00 (May 29 2017) via VB winXP SP3.
That's good enough I guess, but would like to get on the latest.

Lastly, I have an old win7 32bit laptop and it also cant run anything newer then same v1.0.

I'm happy to test out other builds to find the issue or post logs etc.

On my old laptop, I installed mintlinux 18 32bit with wine 1.6.2 and the last build works fine.
On my mintlinux 19 64bit desktop, I removed all wine stuff, followed this:
And installed wine4.0 (1.6.2 32bit) but still has a blank screen.
Looks like you need a 32bit linux OS

update 2:
So with the above, launching wine like this worked:
export WINEARCH=win32; wine Anim8or_1357.exe

But it uses it's own .wine profile and it's not compatible with 64bit wine.. I'm not wine expert, so i have two .wine profiles, which I rename when I need either 32 or 64bit wine :/

Not a perfect solution but it's a win!

update 3:
I've renamed my wine32bit .wine folder to .wine-animator and launch like this and works great!
export WINEPREFIX=$HOME/.wine-animator; export WINEARCH=win32; wine "c:\anim8or\Anim8or_1357.exe"
« Last Edit: March 28, 2019, 01:34:00 am by gwald »


  • Full Member
  • ***
  • Posts: 221
    • View Profile
    • Modelling for Celestia
Re: Hi to all, and running on Linux, and zoom level on render
« Reply #3 on: March 29, 2019, 05:31:50 pm »

Although your results suggest that it might not be relevant, what graphics hardware and drivers are you using? I'm wondering if there might be an incompatibility issue there, too.


  • Newbie
  • *
  • Posts: 8
  • Mike Garcia
    • View Profile
    • my gamedev blog
Re: Hi to all, and running on Linux, and zoom level on render
« Reply #4 on: March 29, 2019, 07:57:41 pm »

intelHD graphics, 3.0 MESA 18.0.5, win7 SP1 6.1, x86/mmx/sse2 as per anim8or's opengl/sys info.
I'm on an old (2012) dell i5 (quad core) with 16GB RAM, haven't felt the need to upgrade.
« Last Edit: March 29, 2019, 08:02:15 pm by gwald »