Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

Ian Ross has just released a book on Anim8or. It's perect for a beginner and a good reference for experienced users. It contains detailed chapters on every aspect, with many examples. Get your own copy here: "Anim8or Tutorial Book"

Author Topic: Loading Textures Question  (Read 6986 times)

mikespitzer

  • Newbie
  • *
  • Posts: 16
    • View Profile
Loading Textures Question
« on: May 13, 2022, 12:47:19 pm »

I am not sure if this question is best asked here (since I am working in new version) or in the general questions area ....

I have an OBJ I downloaded from CGTRADER .....

It demonstrates what the dinosaur object should look like with all the textures loaded.

I have been trying to populate the Texture file fields in Anim8or for 3 days now -- also reading the available tutorials and Ian Ross's book, but I must still be doing something wrong  ----- as you can seen I am not getting the fully textured character inside Anim8or

I have provided a photo showing the Dinosaur as it should look when fully textured (alslo link to the CGTrader page for this object) ... the textures provided
compared to what I am seeing inside Anim8or

Can anybody provide direction on how I need to be doing this properly "?

Thanks

https://www.cgtrader.com/3d-models/animals/dinosaur/tyrannosaurus-rex-45970fe7-6fe1-4ba7-97db-eff67cfb5a30
Logged

mikespitzer

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: Loading Textures Question
« Reply #1 on: May 13, 2022, 02:28:23 pm »

UPDATE -- It would seem I am not grasping the proper concept for blending overlapping textures when building a material inside Anim8or

It seems no matter what I load or what combinations or settings I use, I can only see the texture loaded in the Diffuse field on my Object itself ..

See screen shot in attached file.

I confess I think I am stumped on what to try next

It's probably easy once one learns the right way to do it

Thanks in advance
Logged

ianross

  • Sr. Member
  • ****
  • Posts: 251
  • Imagination is the elixir of life.
    • View Profile
    • https://www.tradebit.com/filedetail.php/164976574-part-1-anim8or-tutor-course
Re: Loading Textures Question
« Reply #2 on: May 16, 2022, 06:20:42 am »

Hi Mike,
           this is how I textured my T-Rex, I don't have your texture files so I can't experiment.
Please review my textured model, sorry I have not fully resolved your issues but I hope you develop some solutions via my enclosed pictures.
Logged

mikespitzer

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: Loading Textures Question
« Reply #3 on: May 16, 2022, 09:18:33 am »

Mr Ross,

I am stumped ...

Comparing your images for textures to what I am using ... and comparing settings, what I am trying to do is virtually identical to what you show here.

Yours is working perfectly, but for some reason I am only seeing whatever images I place in the Ambient and Diffuse fields....

Any image I place into those 2 fields will appear on my object ---- but nothing that goes into the other fields will appear

I tried to perfectly match your settings in this example --- still no luck.

Perhaps I am missing and overlooking something ?

Thanks

Logged

mikespitzer

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: Loading Textures Question
« Reply #4 on: May 16, 2022, 10:36:50 am »

Mr. Ross

Update -- I might be on the right track ---

I found options for View- Shading - ARB Fragment Program in the top menu bar

Enabling those boxes made the various textures start showing up ..

Now some experimenting with the texture settings to get the right balance

See photo attached ..

I notice the 2 options make a big difference in the appearance of the model and textures

Might I ask what your settings are in this
« Last Edit: May 16, 2022, 10:59:34 am by mikespitzer »
Logged