General Category > Anim8or v1.0 Discussion Forum

Anim8or v1.01.1318 doesn't select all surfaces

(1/3) > >>

While working on a rather large model, I discovered that Ctrl-A selected only half of the surfaces. The model consists of two adjacent meshes and only the surfaces of one of those meshes was being selected. See the attached screengrab.

The zip of the model is too large to attach (3.5MB) so here's a link to it:


I've seen something similar. I haven't yet worked out exactly what's going on, so take my comments with a grain of salt.
I think this is related to the Group/Layer changes. It looks like there may be still some gremlins to work out.

In my case I had one group of meshes in layer 6, and another group in layer 0. The (faces of) the groups/meshes in layer 6 were selectable, but (faces of) the group in layer 0 were not.
I disabled the visibility of layer 6, and ungrouped the group which was unselectable. It disappeared, so I re-enabled layer 6, and there were it's constituent parts (whose faces are now selectable). However, if I re-group those objects, they automatically return to layer 0 (at least their group does) and once again, the faces are not selectable.

So there seems to be a few issues here.
1. The sub-meshes seem to retain a "memory" of their previous layer membership when grouped, and on un-grouping, they return to that layer (in this case layer 6). If I then immediately re-group those objects, the new group returns to layer 0. The combination of these 2 things it seems to me makes it impossible to permanently change the layer membership of a group of meshes, because they retain their memory of another layer instead of inheriting the layer of the group.
IMO, if you move a group to a different layer then the sub-groups and sub-meshes of that group should also inherit that change, whether they remain grouped or are subsequently un-grouped.
2. It seems to me that the fact that the faces are not selectable has something to do with the fact that they are in a group. Is this also the case with you?
When I ungrouped, the faces of the ungrouped objects became selectable (in layer 6), but these were also grouped objects themselves, which again suggests to me that this has something to do with the object layer not matching the contained object's layer(s), rather than simply the fact that they are part of a group.

None of this I'm sure of ... more testing is required ... but I hope this helps.

EDIT: Bingo! I've just worked it out.
As I said. the objects contained in my "unselectable" group seem to think they are members of layer 6, even though they are grouped in layer 0. When layer 0 (the group's layer) is visible the group is visible, and the faces are also selectable, BUT ONLY IF LAYER 6 IS ALSO ENABLED. If layer 6 is disabled, the objects remain visible (because they are members of a group in layer 0 (which is still enabled), however they are not selectable because they "think" they're still members of layer 6 (which is now disabled).
It seems that the "selectability" of objects and their faces is linked to their layer membership (and it's visibility status) ... (probably as it should be), but, because they seem to be retaining their memory of layer 6 membership, they are not selectable when that layer is disabled.... even though they are grouped (and visible) in layer 0.

The selection issue, only seems to be an issue for "sub-groups", "meshes" however still seem to be selectable when part of a group in another layer, even when their own layer is disabled. It seems to me that layer membership is not being propagated down and applied from the top-level group to the sub-groups.


Thanks for the analysis. Unfortunately, in this case I hadn't selected any layers at all. All of the layer settings were left in their default states.

Any groups involved? ... in my case I definitely saw a difference in "selectability" between meshes and groups... which makes me suspect some issue with group-layer memberships.

YMMV - well obviously it does!  ;D

Nope, no groups are involved, either.

To be more specific:

I used MeshLab v1.2.3 to convert two STL models into OBJ format, then imported the OBJs into Anim8or. (That process causes all of the meshes of each of the OBJs to be imported as a single solid.) I moved the two solids so they were properly aligned, then typed Ctrl-A so I could try to find out which surfaces of those meshes needed to have their normals flipped. (When selected surfaces are drawn blue, their surface normals are pointing in the wrong direction. Yellow surfaces are OK.) That's when I discovered Ctrl-A selected only the surfaces which were in one of the two meshes which had been imported.

Fortunately, though, there is a workaround: Object/Point Edit's "Drag Select" option can be used to select all of the surfaces in the current Object, including those that Ctrl-A doesn't select.


[0] Message Index

[#] Next page

Go to full version