Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Steve

Pages: 1 ... 100 101 [102] 103 104 ... 107
1516
Anim8or v0.98 Discussion Forum / Re: texture messed up
« on: March 28, 2008, 08:14:12 pm »
Yes, there is a bug in the ray tracer.  I'm looking for the cause.  More examples would really be helpful.  Siragin, can you e-mail me your .an8 file?

1517
Anim8or v0.98 Discussion Forum / Re: Trouble with atributes
« on: March 28, 2008, 08:11:04 pm »
You need to click the "New" button and type in the name of the attribute that you want to add.  Then click "OK" and select the type, set the value, and you're done.

Attributes are a general mechanism to add things that aren't directly supported by Anim8or.  There are many applications that read and write .an8 format files.  Attributes allow those apps to export models to Anim8or to be edited and read them back in while retaining arbitrary other information that they may need.

I used them to extend materials for the initial ray tracing renderer.  Yes, I know they aren't as convenient as built in buttons.  But since the ray tracer is still getting new features attributes are a fast way to support them.  Writing the dialog code is very time consuming so this allows me to get the ray tracing preview out much sooner and to not waste time rewriting the material dialogs each time the ray tracer changes.

1518
Anim8or v0.98 Discussion Forum / Re: A Not so recent bug.
« on: March 28, 2008, 04:32:54 am »
Well, I guess I'll finally have to multithread Anim8or.  That will probably solve this problem.  Now I have to learn how to do that.  (Darn Vista! What a pain it is.)

1519
Anim8or v0.98 Discussion Forum / Re: Light Settings-Max Rays
« on: March 27, 2008, 07:19:09 pm »
You can choose the number.  It is controlled indirectly by the aa setting.

Each ray intersection sends a ray to each light to see if it's visible.  If you has 1 million pixels and 16 samples per pixel they you will get at most 16 million smaples per light assuming no reflections or transparency.  The background doesn't need to sample the light so it could be fewer.

BTW if what you want is to take more samples per light for each ray intersection instead of just one, it's better, say, double the number of samples per pixel at the start than to quadruple the ligt samples but not increase the samples per pixel.

1520
flametiger74, are you referring to the different sampling methods in the AA setup dialog?  Those are simple different strategies for sampling the image when computing a pixel's value.

Anti approximates the light that reaches a pixel by evaluating multiple places within that pixel and blending the values together.  Sample methods are different ways of placing the samples.  All of these methods except Random first divide the pixel into a regular grid of NxN.  Then:

Regular samples a fixed set of regular positions, one per cell.

Jittered picks one random location in each cell.

Multi-juttered further subdivides each cell into another NxN sub grid.  Then it picks a random location in the a sub grid location but always choosing a different sub grid cell for eack main cell.  This is probably the bes method for sampling most images.

Random is just random locations.  It isn't really that good because it creates too much noise for a given number of samples.  But some people like it because it looks a bit like film grain.

1521
Anim8or v0.98 Discussion Forum / Re: Really wierd render bug
« on: March 27, 2008, 06:27:17 pm »
Heh, heh.  There are a bunch of canned images that I built into Anim8or when I was first working on the ray tracer.  They are supposed to be disabled in release builds but apparently it didn't happen.

To render these tests on your computer, click the Options->Debug->DebuA command.  Each time you do that it will cycle to the next build image.  (You need to do a render to see it, of course.)  You will need to exit Anim8or and restart it to get back to normal.

These tests are old.  They might not work and don't cover every material.   But you might have fun looking at them :-)

1522
Anim8or v0.98 Discussion Forum / Re: A Not so recent bug.
« on: March 27, 2008, 06:22:51 am »
I think you misunderstand most of what is happening.  I will try to clarify:

Turning off render preview will not have much effect on the timing for well written graphics drivers.  That's why it's on by default.   However some drivers are VERY slow at copying raw pixel bits to the screen using OpenGL - particular some low end, integrated grahics drivers - so I added the ability to turn it off.  You SHOULDN'T see much difference on NVidia cards :-)

If your computer DOES speed up a lot when you disable render preview, then you have a BAD driver.

The reason that Anim8or seems to lock up during a render (it doesn't really - it's just fully busy doing the render.  It ignors all the thousands of Windows messages it gets per second because some drivers are TERRIBLE at this and slow down horribly even they aren't doing anything - thay just are inefficient - So I ignore almost all Windows messages when rendering.  You should still be able to ESC out of the render.  Anim8or is not frozen by any means -- it's just ignoring you :))

You should NOT see much of a speedup changing the priority.  Anim8or will normaly get 99% of the CPU time.  In fact I am thinking of lowering the priority so other Windows tasks won't get starved for CPU cysles.  Windows isn't a very good OS at switching between tasks.  MACs, for example, are much, much better at it.

Your graphics card is a very good one for Anim8or.  I have an 8600 on one of my computers at work and it runs Anim8or quite nicely.

Hope this helps clarify a few things (to you and others).

1523
Flametiger74 - Please post this kind of thing to a new topic.  This thread simply anounces that v0.97 is available.  It is not for bug reports.  (What graphics card do you have?  THis is most certainly a driver problem, possible a badly designed driver.  That's exctly why I added the ability to turn off renders.)

1524
Anim8or v0.98 Discussion Forum / Re: Bug Report
« on: March 26, 2008, 05:54:47 am »
hihisilver - I need an example .an8 project.  I can't fix it without one.  It looks like a sampling problem.

csf - What OS and graphics card do you have?  They upgrading your graphics driver.  I open and close dozens of projects and do all kinds of rendering without crashes.  I think you are hitting a problem with some other part of your system besides Anim8or.

1525
Anim8or v0.98 Discussion Forum / Re: Bug Report
« on: March 25, 2008, 08:56:06 pm »
Tanzim - That is a well documented problem with volume shadows in the scanline renderer.  Use the ray traced shadows options to fix it.

As I understand it, CobraSpectre's bug report is about the new ART Ray tracer (which is the only one that supports 4xaa.)

1526
Anim8or v0.98 Discussion Forum / Re: Bug Report
« on: March 25, 2008, 04:25:01 am »
OK then I have an aliasing problem with the sampler at 4x.  I never got your email however.

1527
Anim8or v0.98 Discussion Forum / Re: Bug Report
« on: March 24, 2008, 04:38:32 pm »
The ART ray tracer does not match the scanline renderer exactly and never will.  It is based on a more accurate physical model of light that the scanline renderer, which takes a lot of shortcuts and adds it's own rules.  For example a local light's min and max radius are a hack, not on how real light works, and aren't supported by the ray tracer.
Depth and alpha channel aren't doen yet so I'll probably disable those until they work.


The volume shadow bug with the horizontal lines is know (this is with the scanline renderer, right?  It's not clear which renderer you are talking about on some of these bugs).  You need to use ray traced shadows for these cases.


1528
Wow, a weak power supply!  That's a hard thing to diagnose.  Good job, Tanzim and Roygee.

1529
Yes, that's a bug.  The scanline renderer's shadwos don't work on the ground grid.  I'll fix it.

1530
Anim8or v0.98 Discussion Forum / Re: Not getting it
« on: March 23, 2008, 02:37:00 am »
Roygee - it might help to look at the attributes in the examples for each material type.

Pages: 1 ... 100 101 [102] 103 104 ... 107