Anim8or Community

Please login or register.

Login with username, password and session length
Advanced search  


An update to Anim8or, v1.00b, is available with a few bug fixes. Get your copy HERE. See the "ReadMe" file for details.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Gyperboloid

Pages: [1] 2 3 ... 18
Since those changes would not affect the working process at all ( but even if they would, what can we say, right  :) ) , implementing them is only a good thing. So there's no question : be  !  :) Due to the nature of the development, it's all about what Steve can say about it. Ya know what I mean ??  ;)

General Anim8or Forum / Re: Using Animator 8 (beginner)
« on: February 04, 2018, 10:35:46 am »
The original manual is the only thing you need !!! ( at your first steps at least  )

Just to say, although Steve claim to fix it, I don't think layers should affect export. It supposed that the layers affect the "working space process " only and that was ( maybe not ? ) the original purpose of implementing them . Different layers should contain different parts of a  single object, so the whole object should be exported as is.

The current development release is v1.01.1318, January 25, 2018:


Previous v1.01.xxxx releases:

Major changes for build 1317 dated January 14, 2018:
Fix #101-017: Issues with Groups and Layers.
   Use group's layer instead of each component's layer when displaying or selecting a group.
   Use the group number of the components in a group when creating a group.
   For multiple group numbers, use any one of them.
Fix #101-018: Reading a .an8 file with a script-based parameteric shape in a group crashes.
Fix #101-019: Script controllers for scene morph targets with aren't saved in .an8 file.
IK effector: Change to not move location of effector unless the user have specifically moved it
(i.e. not when it was moved because it couldn't be reached when the whole figure was moved).
Connected Face Extrusion: Expand cases when new faces are kept parallel to original faces.
Inset Tool: Change to inset edges parallel and equal distance to original edges. Previous behavior (that moved edges relative to the length of each individual edge) is available using the Shift key.
Scene Editor: Add menu command Edit->Bones->KeySelectedControllers.
Fix #101-020: Object Editor: Copy/Pasting a Group with a sub Group doesn't work correctly.


I don't know how I missed the 1317 release  :o , but that's superb Steve. Can the exact same behavior be implemented for the Bevel tool also ?

Ongoing Anim8or Development / Re: Experimential Track Ball for Arc Rotate
« on: January 27, 2018, 05:27:07 am »
You zoom in with the mouse scroll button. By default it zooms at the mouse pointer but you can make it zoom at the center of the frame by holding the Ctrl key down. Note: you don't need to be in Arc rotate mode to zoom.

He means Shift

General Anim8or Forum / Re: Shadows
« on: January 27, 2018, 05:15:44 am »
As ENSONIQ5 said : those boxes in menu have no affect on ART, only on Scanline . Try what slex suggested for Scanline .
There are some issues there like for ever. Not only in Scene ( render ) mode. Step by step Steve will fix them all we hope.

Finished Works and Works in Progress / Re: Freddy!
« on: December 30, 2017, 05:34:05 pm »
Arik , you're alive !!! Still waiting for the wireframes of that submarine though ;D

Finished Works and Works in Progress / Re: Merry Christmas
« on: December 30, 2017, 05:26:51 pm »
Great video. Well done . Happy New Year !!!

Finished Works and Works in Progress / Re: My Anim8or Projects
« on: December 20, 2017, 10:22:49 am »
Super! I wonder why people don't post ALL their work created in Anim8or . Time by time people past by and post some wonderfull stuff.

Layers, as I finaly figured out, are very usefull. We just should clear it up a little bit.
First: Steve, it seems that the "0" layer has kind of a "higher priority" by default, always. When you hide that layer, in the material bar, the matterials ( visuals , spheres ) don't show, you can see the names only ( pic.1 ).
Also there's something with the primitive (the Mesh Primitive - see "a mesh" - is fine) created on an empty layer set as default, different than "0". The "0" layer pops up, although other was set as default. When you double click on the primitive and then close ( only by "Ok" ) the parameter window the "0" layer turn off and the ( say ) "1" gets active with the underline under it ( the same result can be achieved by simply converting the primitive into a mesh )( pic.2). Note: when creating two or more primitives without changing the settings, first gets active the " 0 " layer ( first primitive ) and then as an addition the default ( if different than " 0 " ).

Now, very important, about grouping- ungrouping. Ofcourse very important others opinion, how they generaly go around with it.

1)When grouping items of the same layer, it's obvious the group should stay in that same layer  (period) Ungrouping items, that originaly were located on the same layer, should be relocated on that " old" layer and not transfered automaticaly to the "default" layer
2) About grouping items from different layers: first I thought it would be good to prohibit that possibility and to mention, by a pop up window ( So'd just you know window  :) ), that items can be grouped only when they belong to the same layer and they must be manualy transfered to the same layer before you can group them. Then, ofcourse I understood that it would be stupid, because you loose the ability to group at once a lot ( million ? ) of items without the need to manualy ( !!! ) edit their settings !!! So, grouping items, that originaly belong to different layers should locate the newly created group into the default layer.
And here I bring up again the suggestion, if it is at all possible, to set the " default " layer via the Midle Mouse Button on the tool bar directly. You just click ( MMB ) on the layer you are currrently working in ( better maybe "working layer " - as a replacement to that " default"  ), that layer gets the underline and everything you group will be transfered to that " working" layer. It's the way actually things work now, just you have to go all the time through the Options menu, wich is not practical. Currently, when ungrouping items that originaly were located in different layers, each item returns to its original layer and that's the correct way, nothing should be changed, because when editting often you need to group things just for a sec or two and then relocate everything back. The only thing is that grouping items from different layers, as you mentioned, hidding the layer (of the item originaly ) hides the item inside the group. That should not happen. The visibility of the group should relay only on the layer that the group belongs. Anim8or should " seek " for the group layer's visibility only and only when items will be ungrouped they can be affected by their original layers.

Finished Works and Works in Progress / Re: Gyperboloid's Lab
« on: December 03, 2017, 12:34:52 am »
Nope, Trevor, no glossyreflector on the walls. Basic Anim8or material. The blue light comes from 6 local lights ( 3 on each half ) above couch, behind the vases,for decoretive purposes. The noise is generated from the shadow size ( =10 )  of the 3 local lights (yellow color ) near the window ( one infront of the panel curtains, to produce the shadow on everything inside the room and two behind the curtains to create the shadows on the wall, above the couch and ceilling, to give that kind of a sunny day light. Although I used 64 AA sampling, it's still too rough, so much more samples needed. ( so more time too, >>15 min of mine )

As I remember, cooldude asked a question about your work . Repeating him actually : are there your games, for which you make all those characters, anywhere around ?

Finished Works and Works in Progress / Re: Gyperboloid's Lab
« on: November 30, 2017, 11:08:24 pm »
A light under the bulb works only when the bulb is under an untransparent lamp cover, so the shadow created on the ceiling is actually what you see in reality. But you still get the shadow even when the bulb is under a semi transparent material, which is not the way the light behaves in reality. So, actually no work around available yet. The only way is if Steve can add some code.  ;) I can't resist to mention it ( though, I 'll post a detailed message or two, in the forum when it'll be the right time to do so ) : read in the forum, in some old topics, Steve said that he actually ( I thought it's impossible at all, due to the rendering algorithms choosen at begginings ) to work on the photon mapping rendering method (!!!) with all the goods (caustics e.t.c ) but it would just take him like 3 - 6 months. 3 - 6 months ... it's actually like nothing ( Steve disagrees  :D ) !!! I don't mind to wait 3-6 years !!! ( Steve although would  ;D )

Project update : almost finished the whole pre-final stage thing.

Nice. A wireframe screenshot would be interesting.

Anim8or v1.0 Discussion Forum / Re: Problems with Anim8or V1.0 Scene mode
« on: November 30, 2017, 09:20:30 pm »
As I replied on the other topic, try to change the shading settings. View-> Preferences -> Shading turn it off at all or just change to the old ARB Fragment Program. It's set to the new GLSL by default I think, there's some kind of bug I guess, if that's the problem actually.

Pages: [1] 2 3 ... 18